
STRABOMICRO
USER GUIDE

StraboMicro Version 2.0.0 · February 2026



Contents
1 Introduction 6

1.1 Overview of the StraboSpot Ecosystem . . . . . . . . . . . . . . . . . . . . . . . . . 6
1.2 StraboMicro: A Modern Platform for Microscopy-Based Geoscience Research . . . 7
1.3 What’s New in StraboMicro 2.0 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
1.4 System Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
1.5 Getting Help and Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

2 Installation and Setup 11
2.1 Creating a StraboSpot Account . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
2.2 Downloading the Application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
2.3 Installing on Windows/macOS/Linux . . . . . . . . . . . . . . . . . . . . . . . . . . 12
2.4 First-Time Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
2.5 Automatic Updates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

2.5.1 Checking for Updates Manually . . . . . . . . . . . . . . . . . . . . . . . . . 14
2.5.2 Checking Your StraboMicro Version . . . . . . . . . . . . . . . . . . . . . . . 15

2.6 StraboMicro Instrument Catalog . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
2.6.1 Becoming an Institution Principal Investigator (PI) . . . . . . . . . . . . . . . 16
2.6.2 Accessing and Updating the Instrument Repository . . . . . . . . . . . . . . 16

3 Manage StraboMicro Projects 16
3.1 New Project . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

3.1.1 New Project from Field Data . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
3.2 Open Existing Projects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

3.2.1 Open a Local Project . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.2.2 Open a Remote Project . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.2.3 Open a Project with a Share Code . . . . . . . . . . . . . . . . . . . . . . . . 19

3.3 Recent Projects Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.3.1 Accessing Recent Projects . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.3.2 Working with Multiple Projects . . . . . . . . . . . . . . . . . . . . . . . . . . 20

3.4 Save Projects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
3.4.1 Save to Local Device . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
3.4.2 Upload to StraboSpot Server . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

3.5 Autosave System . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
3.5.1 How Autosave Works . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
3.5.2 Autosave Indicators . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

3.6 Version History System . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
3.6.1 Accessing Version History . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
3.6.2 Understanding Version Snapshots . . . . . . . . . . . . . . . . . . . . . . . . 23
3.6.3 Named Checkpoints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
3.6.4 Visual Diff Preview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
3.6.5 Restoring a Previous Version . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
3.6.6 Auto-Pruning Policy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
3.6.7 Storage Usage . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

3.7 Download Projects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

Back to Top 1



3.7.1 Download .smz File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
3.7.2 Export Project as PDF . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
3.7.3 Export Project as JSON . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

3.8 Download Project Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
3.8.1 Export All Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
3.8.2 Export Individual Annotated Images . . . . . . . . . . . . . . . . . . . . . . . 26
3.8.3 SVG Vector Export . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

3.9 Project Privacy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
3.10 View and Share Projects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

3.10.1 View in Online StraboMicro Viewer . . . . . . . . . . . . . . . . . . . . . . . 27
3.10.2 Sharing Projects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
3.10.3 Generate a Share Code . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

3.11 DOI Creation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
3.11.1 Generate a DOI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
3.11.2 View a Project via DOI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

4 User Interface Overview 28
4.1 Panel Flexibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
4.2 StraboMicro Terminology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
4.3 Project Viewer Pane: Project Navigation . . . . . . . . . . . . . . . . . . . . . . . . 31
4.4 Micrograph Viewer: Image Display . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
4.5 Metadata Pane Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

4.5.1 Spot Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
4.5.2 Toolbar Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
4.5.3 Data Entry Section . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

4.6 Top Menu Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
4.7 Theme Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
4.8 Keyboard Shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41

5 Sample and Spot Management 41
5.1 Add / New Sample . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41

5.1.1 Sample Info . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
5.2 Load Reference Micrograph . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

5.2.1 Step 1 of 7: New Reference Micrograph . . . . . . . . . . . . . . . . . . . . . 43
5.2.2 Step 2 of 7: Instrument and Image Information . . . . . . . . . . . . . . . . 43
5.2.3 Step 3 of 7: Instrument Data . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
5.2.4 Dependent Step: Instrument Settings . . . . . . . . . . . . . . . . . . . . . . 45
5.2.5 Step 4 of 7: Micrograph Metadata . . . . . . . . . . . . . . . . . . . . . . . . 47
5.2.6 Step 5 of 7: Orientation of Reference Micrograph . . . . . . . . . . . . . . . 47
5.2.7 Dependent Step: Define Top Corner (Fabric Reference Frame Only) . . . . . 49
5.2.8 Step 6 of 7: Set Micrograph Scale and Location . . . . . . . . . . . . . . . . 49
5.2.9 Step 7 of 7: Scale Input . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

5.3 XPL/PPL Synchronized Viewing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
5.3.1 Linking PPL and XPL Images . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
5.3.2 Toggling Between Views . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
5.3.3 Synchronized Pan and Zoom . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
5.3.4 Shared Spots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
5.3.5 Handling Different Image Dimensions . . . . . . . . . . . . . . . . . . . . . . 52

Back to Top 2



5.4 Spot Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
5.5 Adding a New Spot . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

5.5.1 Spot Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
5.5.2 How to Add a Spot . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
5.5.3 Spot Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54
5.5.4 Real-World Spot Measurements . . . . . . . . . . . . . . . . . . . . . . . . . 55

5.6 Batch Edit and Multi-Select . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
5.6.1 Multi-Select Methods . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
5.6.2 Batch Property Editing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
5.6.3 Batch Delete . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

5.7 Merge and Split Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
5.7.1 Merge Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
5.7.2 Split Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
5.7.3 Undo/Redo Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
5.7.4 Provenance Tracking . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

5.8 Recursive Spots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
5.8.1 Enabling Recursive Spot Display . . . . . . . . . . . . . . . . . . . . . . . . . 59
5.8.2 How Recursive Spots Are Rendered . . . . . . . . . . . . . . . . . . . . . . . 60
5.8.3 Interacting with Recursive Spots . . . . . . . . . . . . . . . . . . . . . . . . . 60
5.8.4 Filtering Recursive Spots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

5.9 Spot Navigation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
5.9.1 Keyboard Navigation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61

6 Data Entry and Observation Tools 61
6.1 Adding Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62
6.2 Types of Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

6.2.1 Mineralogy and Lithology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
6.2.2 Grain Size, Shape, and SPO . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
6.2.3 Fabrics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
6.2.4 Clastic Deformation Bands . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
6.2.5 Grain Boundaries and Contacts . . . . . . . . . . . . . . . . . . . . . . . . . 69
6.2.6 Intragranular Structures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
6.2.7 Veins . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
6.2.8 Pseudotachylyte . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72
6.2.9 Folds . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
6.2.10 Faults and Shear Zones . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78
6.2.11 Extinction Microstructures . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79
6.2.12 Fractures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80
6.2.13 Notes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
6.2.14 Associated Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
6.2.15 Links . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

7 Advanced Tools 86
7.1 Point Count System . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86

7.1.1 Purpose and Applications . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87
7.1.2 Grid Generation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87
7.1.3 Keyboard Navigation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88
7.1.4 Quick Mineral Shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88

Back to Top 3



7.1.5 Statistics Panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
7.1.6 Session Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
7.1.7 Export Results . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89

7.2 Grain Detection – OpenCV Method . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
7.2.1 Algorithm Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
7.2.2 Preview Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90
7.2.3 Adjustable Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90
7.2.4 Creating Polygon Spots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91

7.3 Grain Detection – FastSAM AI Method . . . . . . . . . . . . . . . . . . . . . . . . . 91
7.3.1 Technology Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91
7.3.2 Automatic Model Download . . . . . . . . . . . . . . . . . . . . . . . . . . . 92
7.3.3 Advantages Over Classical Methods . . . . . . . . . . . . . . . . . . . . . . 92
7.3.4 Cross-Platform Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92
7.3.5 GPU Acceleration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92

7.4 Quick Edit Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
7.4.1 Purpose . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
7.4.2 Keyboard Navigation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
7.4.3 Quick Mineral Assignment . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94
7.4.4 Statistics Panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94
7.4.5 Lasso Selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94

7.5 Quick Apply Presets . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94
7.5.1 Purpose . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
7.5.2 Preset Scope . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
7.5.3 Keyboard Shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
7.5.4 Additive Merge Behavior . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
7.5.5 Batch Application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
7.5.6 Creating Presets from Existing Spots . . . . . . . . . . . . . . . . . . . . . . 96

7.6 Grain Size Analysis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
7.6.1 Per-Grain Metrics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
7.6.2 Population Statistics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
7.6.3 Rock Type Classification Schemes . . . . . . . . . . . . . . . . . . . . . . . 98
7.6.4 Visualizations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98
7.6.5 Mineral Grouping . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
7.6.6 Scope Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
7.6.7 Export Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

7.7 Image Comparator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100
7.7.1 Purpose . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100
7.7.2 Grid Layout . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
7.7.3 Independent Pan and Zoom . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
7.7.4 Overlay Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101

8 Sketch Overlay System 101
8.1 Introduction to Sketch Overlay . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101

8.1.1 Common Use Cases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
8.2 Entering and Exiting Sketch Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

8.2.1 Entering Sketch Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102
8.2.2 Exiting Sketch Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Back to Top 4



8.3 Sketch Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
8.3.1 Pen Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
8.3.2 Marker Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
8.3.3 Eraser Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
8.3.4 Text Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104

8.4 Color and Width Controls . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104
8.4.1 Color Picker . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104
8.4.2 Width Slider . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105

8.5 Layer Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105
8.5.1 Accessing Layer Management . . . . . . . . . . . . . . . . . . . . . . . . . . 106
8.5.2 Creating a New Layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106
8.5.3 Selecting the Active Layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106
8.5.4 Layer Visibility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106
8.5.5 Renaming a Layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
8.5.6 Deleting a Layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

8.6 Undo and Redo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
8.6.1 Undo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
8.6.2 Redo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

8.7 Exporting with Sketches . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
8.7.1 Export Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
8.7.2 Include/Exclude Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
8.7.3 Format and Resolution . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

8.8 Keyboard Shortcuts Summary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
8.9 Tips and Best Practices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

8.9.1 Organizing Your Annotations . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
8.9.2 Choosing the Right Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
8.9.3 Export Strategies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
8.9.4 Workflow Integration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

9 Troubleshooting and FAQs 110
9.1 Getting Help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
9.2 Common Issues and Fixes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111
9.3 Frequently Asked Questions (FAQs) . . . . . . . . . . . . . . . . . . . . . . . . . . . 112

10 Appendices 114
10.1 Glossary of Terms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114
10.2 Keyboard Shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 116
10.3 Data Schema Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
10.4 Licensing and Attribution . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121

Back to Top 5



1 Introduction

1.1 Overview of the StraboSpot Ecosystem
The StraboSpot ecosystem is a suite of interconnected applications and software tools designed
to support the collection, management, integration, and sharing of field and laboratory data in the
geosciences. Its primary objective is to align data practices with the FAIR principles: Findable,
Accessible, Interoperable, and Reusable, by providing a unified system for managing multidisci-
plinary geologic data.

Developed through ongoing community input, the StraboSpot ecosystem includes several spe-
cialized applications: StraboField, which supports workflows in structural geology, petrology,
sedimentology, and tephra volcanology; StraboMicro, the modern rewrite of the original Stra-
boMicro application, which facilitates microscopy-based geoscience research with enhanced
performance and new capabilities; andStraboExperimental, which serves the experimental defor-
mation community. Each of these platforms utilizes controlled vocabularies developed by their
respective scientific communities to promote standardized data collection and to improve the
discoverability and interoperability of geologic data.

StraboSpot offers more than just a centralized data repository, it also includes tools for capturing
and organizing field and laboratory observations, including images. The system is built around
the concept of spots, which represent observations applied across defined spatial scales. This
hierarchical structure allows users to nest observations from the regional to the microscopic
scale and to organize data and images according to their specific workflow needs. This flexible
framework enables users to capture and relate geologically complex information in a coherent
and connected manner.

Figure 1: The StraboSpot ecosystem: StraboField, StraboMicro, and StraboExperimental are all
connected to the database at StraboSpot.org
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1.2 StraboMicro: A Modern Platform for Microscopy-Based Geo-
science Research

StraboMicro 2.0.0 is a complete overhaul of the original StraboMicro desktop application, rewrit-
ten using modern technologies to deliver superior performance, reliability, and user experience.
Designed specifically for microscopy-based workflows in geoscience research, StraboMicro pro-
vides a unique, image-centric organizational structure that enables users to efficiently manage
and annotate micrographs while preserving spatial relationships and associated scientific meta-
data.

Modern Architecture
StraboMicro is built on a modern Electron + React technology stack, providing:

• Cross-Platform Support: Native performance onmacOS,Windows, and Linux from a single
codebase

• High-Resolution Image Support: Optimized handling of large micrographs (100MB+ TIFF
files) with smooth panning and zooming

• Dynamic Level-of-Detail Rendering: Associated images remain sharp at any zoom level
through intelligent multi-resolution rendering

• 30+ New Features: Significant enhancements over the legacy application, including AI-
powered tools, version history, and advanced analysis capabilities

Figure 2: StraboMicro main interface showing the standard layout with left navigation pane, mi-
crograph viewer, and right side properties pane
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Core Functionality
StraboMicro allows users to create andmanage projects composed of geological samples. Each
sample includes:

• Reference Micrographs: Typically lower magnification, full-sample scans or stitched im-
ages that provide contextual overviews.

• Associated Micrographs: Higher magnification micrographs of the sample, often collected
using different imaging techniques or instruments. These can be precisely aligned using
several location, orientation, scale options.

Geoscience-Specific Metadata
A key feature of StraboMicro is its ability to link spatial image data with detailed geoscientific
metadata. Users can add metadata at the project, dataset, sample, and spot levels. Geologically
meaningful metadata and data, such as:

• Mineralogy and Lithology

• Grain Size, Share, and SPO

• Fabrics

• Clastic Deformation Bands

• Grain Boundaries and Contacts

• Intragranular Structures

• Veins

• Pseudotachylyte

• Folds

• Faults and Shear Zones

• Extinction Microstructures

• Fractures

• Notes

• Associated Files

• Links

See section 6.2

Spatial Annotation with Spots
Users can add spatial annotations called spots directly onto images. Spots may be defined
as points, lines, or polygons, each capable of storing customized observational data. This fea-
ture supports rigorous documentation of spatially-resolved geological features. StraboMicro en-
hances this with Quick Apply Presets for rapid classification of multiple features.
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Project Management and Data Sharing
StraboMicro is designed to facilitate the lifecycle of a research project:

• As new samples and observations are added, projects evolve in an organized and traceable
manner.

• The new Version History System ensures you never lose work—restore any previous state
with a single click.

• Projects can be shared publicly online, allowing others to view and search the data.

• A Digital Object Identifier (DOI) can be generated for each project, ensuring proper citation
and long-term accessibility for publication and archiving purposes.

1.3 What’s New in StraboMicro 2.0
StraboMicro 2.0 introduces over 30 new features and significant improvements over the legacy
application. Here are the major highlights:

Never Lose Your Work
• Version History System: Every change is automatically saved with full version history. Re-
store any previous state of your project with a single click.

• Automatic Updates: Stay current with the latest features and bug fixes through seamless
automatic updates.

Enhanced User Experience
• Dark/Light Theme Support: Choose your preferred visual theme for comfortable viewing
in any lighting conditions.

• Quick Apply Presets: Save commonly used spot configurations and apply them with a sin-
gle click for rapid classification of features.

• Sketch Overlay System: Create freeform annotations with customizable pen colors and
widths for quick markup and teaching purposes.

AI-Powered Tools
• FastSAM Grain Detection: Leverage artificial intelligence to automatically detect and out-
line grains in your micrographs, dramatically speeding up the annotation process.
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Figure 3: AI-powered grain detection using FastSAM automatically identifies and outlines grains
in micrographs

Advanced Analysis Features
• XPL/PPL Synchronized Viewing: View cross-polarized and plane-polarized images side-by-
side with synchronized panning and zooming.

• Grain Size Analysis: Generate statistical analysis of grain populations with automatic his-
togram and rose diagram generation.

• 3-Point Registration: Precisely align associated images using a simple three-point corre-
spondence system for accurate spatial overlay.
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Export and Sharing
• SVG Vector Export: Export your annotations as scalable vector graphics for publication-
quality figures that remain sharp at any size.

1.4 System Requirements
StraboMicro is designed to work on any modern computer. There are no specific hardware re-
quirements for running the software. The application runs natively on macOS, Windows, and
Linux operating systems.

While higher-performance systems with more RAM may offer improved speed and responsive-
ness when working with very large micrographs, the software does not mandate any minimum
systemspecifications. StraboMicro’s intelligent Level-of-Detail rendering systemensures smooth
performance even on modest hardware.

1.5 Getting Help and Support
To get started with StraboMicro and to enhance your understanding of its features, we recom-
mend the following resources:

• YouTube Tutorials: Watch the official StraboMicro tutorial videos available on our YouTube
channel for step-by-step guidance.

• User Manual: Refer to this manual for detailed explanations of functions and features.

• Weekly Office Hours: Join our live support sessions held every Thursday from 1:00 PM to
3:00 PM CDT (UTC-5).
Register here: https://strabospot.org/help

• Email Support: For additional help, contact us at StraboSpot@gmail.com.

2 Installation and Setup

2.1 Creating a StraboSpot Account
To use StraboMicro and access associated data services, you must first create a StraboSpot
account. Follow the steps below to register:

1. Open your web browser and navigate to https://www.StraboSpot.org.

2. On the homepage, go to the Accountmenu in the top navigation bar and select Register.

3. Fill out the registration form with your full name and a valid email address. Please use a
real and accessible email address, as it will be used to verify your account and for future
communication.

4. After submitting the form, check your email inbox for a confirmation message from Stra-
boSpot.
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5. Open the email and click the confirmation link to activate your account.

6. Once confirmed, you may log in to the StraboSpot website using your new credentials.

Note: If you do not receive the confirmation email within a few minutes, check your spam or junk
folder. If the issue persists, contact support at StraboSpot@gmail.com.

2.2 Downloading the Application
Follow the steps below to download the latest version of StraboMicro:

1. Open your web browser and navigate to https://www.StraboSpot.org.

2. Log in to your account:

(a) On the homepage, click Account > Log In.

(b) Enter your login credentials.

3. Navigate to the StraboMicro download page:

(a) Select Software > StraboMicro > Download StraboMicro.

4. Download the installer appropriate for your operating system:

• Windows: Download the .exe installer

• macOS: Download the .dmg file (choose Apple Silicon or Intel version based on your
Mac’s processor)

• Linux: Download the .AppImage file

2.3 Installing on Windows/macOS/Linux
Windows:

• Double-click the downloaded .exe installer file.

• Follow the on-screen instructions in the installer wizard.

• After installation, launch the application from your Start Menu or desktop shortcut.

macOS:

• Open the downloaded .dmg file.

• Drag the StraboMicro application into the Applications folder (Figure 4).

• Launch the app from your Applications folder or Launchpad.

• If prompted with a security warning, click Open to confirm. You may need to allow the app
in System Settings under Privacy & Security.

Note for macOS users: Two versions are available—one for Apple Silicon (M1, M2, M3, M4 pro-
cessors) and one for Intel processors. To determine your processor type, click the Apple menu
and select About This Mac. The chip or processor information will indicate whether you need
the Apple Silicon or Intel version.
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Figure 4: Drag StraboMicro2 to Applications folder on macOS.

Linux:

• StraboMicro is distributed as an AppImage file, which runs onmost Linux distributions with-
out installation.

• After downloading, make the file executable:

chmod +x StraboMicro2-*.AppImage

• Run the application directly:

./StraboMicro2-*.AppImage

• Optionally, move the AppImage to a convenient location such as /opt or ~/Applications.

2.4 First-Time Setup
When launching StraboMicro for the first time (Figure 5):

• You may be prompted to grant necessary system permissions for file access.

• The application will create a default data folder named StraboMicro2Data in your Docu-
ments directory. This folder stores your project data and local files.

• Application cache and settings are stored in platform-specific locations:

– macOS: ~/Library/Application Support/StraboMicro2

– Windows: %APPDATA%\StraboMicro2

– Linux: ~/.config/StraboMicro2

• A separate tile cache is maintained for high-resolution image rendering. This cache stores
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pre-generated image tiles for faster display of large micrographs and is managed automat-
ically by the application.

• Ensure you are connected to the internet to enable automatic syncing with your StraboSpot
account and access to vocabulary updates.

Figure 5: StraboMicro 2.0 first-time launch screen.

2.5 Automatic Updates
StraboMicro includes built-in automatic update functionality to ensure you always have the latest
features and bug fixes:

• The application automatically checks for updates when launched and every 30 minutes
while running.

• When an update is available, it downloads in the background without interrupting your work.

• Updates are installed automatically the next time you launch the application.

• No manual updating is required under normal circumstances.

2.5.1 Checking for Updates Manually

To manually check for updates at any time:

1. Open the StraboMicro application.

2. Click the Helpmenu in the top navigation bar.

3. Select Check for Updates.

4. If an update is available, you will be notified and can choose to download it immediately.
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2.5.2 Checking Your StraboMicro Version

To verify your current version of the application:

1. Open the StraboMicro application.

2. Click the Helpmenu in the top navigation bar.

3. Select About StraboMicro.

4. The version number will be displayed in the dialog window (Figure 6).

Figure 6: The About StraboMicro dialog showing version information.

2.6 StraboMicro Instrument Catalog
The StraboMicro Instrument Catalog enables laboratories and research groups to associate in-
strumentation with current and past research projects. It is designed to reduce redundancy in the
data input process by storing instrument metadata, including:

• Instrument name

• Type and make

• Location

• Collection and post-processing software

• Detectors

• Additional notes

Once instrument information is entered into the catalog, any StraboMicro user can select that
instrument during data entry. Relevant metadata will automatically populate, streamlining the
workflow and ensuring consistency.
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2.6.1 Becoming an Institution Principal Investigator (PI)

There are two ways to become a designated PI for an institution or laboratory:

1. During the ’Add New Sample’ upload process within StraboMicro, a link to add a new insti-
tution to the catalog can be found in the ’Select Instrument’ modal (Figure 7). Clicking the
link generates an email request.

Requesting a New Institute Entry:

• If your institution is not listed, click the blue link at the top of the modal: “Need your
institute added to the database? Click here.”

• This generates an email to StraboSpot@gmail.com with the following template:

Hello,

Please add the following institute to the StraboMicro Apparatus Repository:

Lab or Facility Name:
Institute Name:

StraboSpot Account: *your account email address*

Thanks,
*your account name*

• Complete the Lab/Facility and Institute fields before sending.

2. Alternatively, you may directly email the development team to request PI access. See Sec-
tion 1.5 for contact information.

2.6.2 Accessing and Updating the Instrument Repository

Once approved as a PI, you can manage instruments associated with your institution by visiting
https://www.strabospot.org. After logging in:

1. Navigate to your account.

2. Select My Instruments.

3. Access the StraboMicro Instrument Catalog, where you can view existing institutions and
instruments.

4. Use the provided links to add or edit instruments and institutional affiliations.

3 Manage StraboMicro Projects
StraboMicro projects differ slightly in structure from other StraboSpot applications. In StraboMi-
cro, each Project contains one or more Samples, which store the data. Projects are saved locally
in the StraboMicro2Data folder within your Documents directory and can be uploaded to Stra-
boSpot.org for backup and sharing.
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Figure 7: Screenshot of the StraboMicro Select Instrument modal.

To create a new project, open the StraboMicro desktop application. For installation details, see
Section 2: Installation and Setup.

From the File menu, choose either New Project or New Project from Field Data.

3.1 New Project
The New Project modal includes the following fields:

• Project Name*

• Start Date

• End Date

• Purpose of Study

• Team Members

• Area of Interest

• GPS Datum (default: WGS84)

• Magnetic Declination

• Notes

*Required field. After entering project details, you will be prompted to provide a Dataset Name.
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Once complete, the interface automatically opens the New Sample modal—the same one used
when selecting Add / New Sample or Create New Sample (see Section 5).

3.1.1 New Project from Field Data

Navigation: File > New Project from Field Data

This option creates a micrograph-based project using field data collected in StraboField.

Step 1: Select a Project

Opens theSelect a Project fromServermodal, listing all projects associatedwith your StraboSpot
account.

• Select a project and click Next.

Step 2: Select a Dataset

Choose a dataset within the selected project.

• All available datasets will be listed.

• Click a dataset to view associated samples.

Step 3: Choose a Sample

A searchable list of samples appears.

• Select a sample to begin the New Sample workflow.

• The process starts at the Load Reference Micrograph step (see Section 5.2).

Note: You may return later to import additional samples from the same dataset.

Metadata Auto-Population

Field samples automatically import the following metadata:

• Project and Dataset:

– Project Name, Start Date, GPS Datum, Magnetic Declination

– Last Modified Timestamp, Location, Dataset Name

• Sample:

– Sample ID/Name, Direct Link (StraboSpot.org), Location

– Sampling Purpose, Description, Material Type, Inplaceness

– Orientation Info, Size, Weathering, Notes
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3.2 Open Existing Projects
StraboMicro allows you to open existing projects stored locally, in your StraboSpot account, or
shared via code or DOI.

3.2.1 Open a Local Project

To open a local .smz file:

1. Launch the StraboMicro application.

2. Go to File→ Open Local Project.

3. Navigate to the .smz file on your device.

4. Select the file and click Open.

3.2.2 Open a Remote Project

To open a project from your StraboSpot account:

1. Ensure you’re logged into StraboMicro.

2. Confirm your login at the top of the window (Logged in as [email]).

3. Go to File→ Open a Remote Project.

4. Select the project and click Open.

3.2.3 Open a Project with a Share Code

To access a shared project:

1. Launch StraboMicro.

2. Go to File→ Open a Project with a Share Code.

3. Enter the provided code and click Next.

See Section 3.10.2 for instructions on generating share codes.

3.3 Recent Projects Menu
StraboMicro maintains a list of recently opened projects for quick access. This feature stream-
lines yourworkflowby allowing you to quickly switch between projectswithout navigating through
file dialog.

3.3.1 Accessing Recent Projects

Navigation: File > Recent Projects

The Recent Projects submenu displays up to 10 recently opened projects, sorted bymost recently
accessed. Each entry shows:

• Project name
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• Relative date indicating when the project was last opened:

– “Today” for projects opened today

– “Yesterday” for projects opened yesterday

– Day of the week (e.g., “Monday”) for projects opened within the past week

– Full date for older projects

• A checkmark next to any project that is currently open

Figure 8: The Recent Projects menu showing recently accessed projects with relative dates and
a checkmark indicating the currently open project.

3.3.2 Working with Multiple Projects

StraboMicro allows you to havemultiple projects open simultaneously. When you select a project
from the Recent Projects menu:

• If the project is already open, StraboMicro will switch focus to that project’s window.

• If the project is not open, StraboMicro will open it in a new window.

• If your current project has unsaved changes, you will be prompted to save before switching.

Tip: Having multiple projects open is useful when comparing samples across projects or trans-
ferring observations between related studies.
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3.4 Save Projects

3.4.1 Save to Local Device

To save the currently open project:

1. Go to File > Save Project, or use the keyboard shortcut:

• macOS: Cmd+S

• Windows/Linux: Ctrl+S

2. The project is automatically saved to ~/Documents/StraboMicro2Data/.

Note: Projects are saved with the .smz extension. If you wish to save to a different location, use
File > Save Project As... and choose your preferred destination folder.

3.4.2 Upload to StraboSpot Server

To back up or share your project online:

1. Go to File > Upload Project.

2. Read the upload prompt:

Uploading your project backs up your data andmakes it accessible via StraboSpot.org.

3. If the project already exists, check Project Already Exists. Overwrite? to proceed.

Note: StraboSpot.org retains version history. Frequent uploads are recommended to prevent
data loss and preserve project history.

3.5 Autosave System
StraboMicro includes an automatic save system designed to protect your work and prevent data
loss. The autosave feature operates transparently in the background without interrupting your
workflow.

3.5.1 How Autosave Works

• Inactivity-based saving: StraboMicro automatically saves your project after 5 minutes of
inactivity. This ensures your recent work is preserved even if you step away from your
computer.

• Save on close: When you close the application or quit StraboMicro, the system checks for
unsaved changes. If changes exist, your project is automatically saved before the applica-
tion closes.

• Version snapshot creation: Each autosave creates a new version snapshot in the Version
History system (see Section 3.6), allowing you to recover previous states of your project if
needed.
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3.5.2 Autosave Indicators

The application displays subtle indicators to show autosave status:

• A small cloud icon or save indicator in the title bar shows when changes are being saved.

• The window title shows an asterisk (*) when there are unsaved changes.

• After a successful autosave, the asterisk disappears.

Note: Autosave does not replace intentional saves. It is recommended to manually save (Cmd+S
or Ctrl+S) after completing significant work, especially before closing the application.

3.6 Version History System
StraboMicro includes a comprehensive version history system that tracks changes to your project
over time. This feature provides peace ofmind by allowing you to reviewpast versions and restore
previous states of your project when needed.

3.6.1 Accessing Version History

Navigation: File > View Version History

The Version History dialog opens, displaying a chronological list of all saved versions of your
project.

Figure 9: The Version History dialog showing a list of project versions with timestamps, change
summaries, and options to preview or restore. The visual diff preview showing added (green),
removed (red), and modified (yellow) entities between two project versions, refer to Section 3.6.4
for more information.
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3.6.2 Understanding Version Snapshots

Each time you save your project (manually or via autosave), StraboMicro creates a version snap-
shot. Each snapshot records:

• Timestamp: The exact date and time the version was created.

• Save type: Whether the save was manual, autosave, or a named checkpoint.

• Change summary: A brief description of what changed since the previous version.

3.6.3 Named Checkpoints

You can create named checkpoints to mark important milestones in your project. Named check-
points have special properties:

• Custom names: Assign meaningful names like “Before grain analysis” or “Final review ver-
sion”.

• Protected from auto-pruning: Named checkpoints are never automatically deleted, even
when the version limit is reached.

• Easy identification: Named checkpoints appear with a bookmark icon in the version list.

To create a named checkpoint:

1. Go to File > Create Named Checkpoint (or use Cmd+Shift+S / Ctrl+Shift+S).

2. Enter a descriptive name for the checkpoint.

3. Click Create.

3.6.4 Visual Diff Preview

Before restoring a version, you can preview the differences between that version and your current
project state. Refer to Figure 9 for an example screenshot. The visual diff shows:

• Added entities: New samples, micrographs, or spots that exist in the current version but
not in the selected version (highlighted in green).

• Removed entities: Items that exist in the selected version but have been deleted in the
current version (highlighted in red).

• Modified entities: Items with changed metadata or positions (highlighted in yellow).

3.6.5 Restoring a Previous Version

To restore your project to a previous state:

1. Open the Version History dialog (File > View Version History).

2. Select the version you wish to restore.

3. Click Preview Changes to review the project differences (optional but recommended).

4. Click Restore This Version.

5. Confirm the restoration when prompted.
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Important: When you restore a previous version, StraboMicro automatically creates a backup of
your current state before applying the restoration. This means you can always return to where
you were if you change your mind.

3.6.6 Auto-Pruning Policy

To manage storage space, StraboMicro automatically prunes old versions according to the fol-
lowing policy:

• Maximum versions: Up to 200 versions are retained per project.

• Retention period: Versions older than 30 days may be pruned.

• Minimum kept: At least 10 versions are always retained, regardless of age.

• Named checkpoints: Named checkpoints are never automatically pruned.

When the version limit is reached, the oldest unnamed versions are removed first.

3.6.7 Storage Usage

To view how much storage space your version history is using:

1. Open the Version History dialog.

2. Click Storage Info at the bottom of the dialog.

3. A summary shows total storage used by version history and individual version sizes.

Tip: If storage is a concern, you can manually delete old unnamed versions that are no longer
needed while keeping your important named checkpoints.

3.7 Download Projects

3.7.1 Download .smz File

Method 1: From StraboSpot.org

1. Go to https://strabospot.org or access it via the StraboMicro app (File > Go to My
Data).

2. Log in and navigate to Account > My StraboMicro Data.

3. Click Options next to a project and select Download.

Method 2: From the Online Viewer

1. Go tohttps://strabospot.org, log in, and open the desired project viaMy StraboMicro
Data > View.

2. Click Download .SMZ in the top-right corner of the viewer.
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3.7.2 Export Project as PDF

StraboMicro can export your entire project as a professionally formatted PDF document, ideal for
sharing with collaborators, including in publications, or archiving.

PDF Export Features The exported PDF includes:

• Table of Contents: Automatically generated with clickable links to each section.

• Internal hyperlinks: Cross-references between samples, micrographs, and spots are click-
able within the PDF.

• All micrographs: Full-resolution images with annotations and spots visible.

• Complete metadata: All entered metadata for the project, samples, and spots.

Method 1: From the Desktop App

1. Open your project in StraboMicro.

2. Go to File > Export Project as PDF.

3. Choose a destination folder.

4. Click Export.

Method 2: From the Online Viewer

1. Log in to https://strabospot.org.

2. Navigate to Account > My StraboMicro Data.

3. Open the project via Options > View.

4. Click Download PDF in the viewer.

Note: Projects must be uploaded to the server before they can be viewed or exported online.

3.7.3 Export Project as JSON

1. In StraboMicro, go to File > Export Project as JSON.

2. Select the destination folder.

3. The project will be saved as a JSON file containing all metadata and structural information.

Tip: JSON exports are useful for data analysis, integration with other tools, or programmatic
access to your project data.

3.8 Download Project Images

3.8.1 Export All Images

Navigation: File > Export All Images
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StraboMicro allows you to export all micrographs from your project in a batch operation, with
flexible format options.

1. Go to File > Export All Images.

2. The Export Images dialog appears with the following options:

• Image Format:

– JPEG — Smaller file size with adjustable quality (70-100%).

– SVG (Vector) — Vector format that preserves spots and annotations as scalable
graphics, ideal for publication figures.

• Include Annotations: Check this option to include spots, lines, and polygons in the
exported images.

• Include Scale Bar: Check this option to embed the scale bar in exported images.

3. Select a destination folder.

4. Click Export.

The app exports a .zip archive containing all micrographs organized by sample, with a folder
structure matching your project hierarchy.

Figure 10: The Export All Images dialog showing format options (JPEG and SVG) and annotation
settings.

3.8.2 Export Individual Annotated Images

To export a single micrograph with its annotations:

1. Open the micrograph in the Micrograph Viewer.

2. Click the Download button in the right panel.

3. Choose your preferred format (JPEG or SVG).

4. Select a destination and click Save.

Tip: To hide overlays in exports, use the Show/Hide icon for each layer before downloading.
Only visible annotations will be included in the export.
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3.8.3 SVG Vector Export

The SVG export option is particularly valuable for publication-quality figures:

• Scalable graphics: SVG files can be scaled to any size without loss of quality.

• Editable annotations: Spots, lines, and polygons remain as separate vector objects that can
be edited in vector graphics software (e.g., Adobe Illustrator, Inkscape).

• Raster + Vector hybrid: The micrograph image is embedded as a raster element while an-
notations are preserved as vectors.

Note: SVG exports are best suited for figures with clear annotations. For very large micrographs,
JPEG may be more practical for general sharing.

3.9 Project Privacy
All projects are private by default in StraboMicro and StraboSpot. Users have full control over
project visibility and can change privacy settings at any time.

To update a project’s privacy, visit www.strabospot.org and log in. Navigate to your account,
then select My StraboMicro Data. A list of your projects will be displayed, each with a toggle
labeled Public? next to the project title.

If the toggle is switched to the right and appears green, the project is public and discoverable by
other users through the StraboSpot search interface. If your project is public and you would like
to make it private again, simply toggle the switch back to the left.

3.10 View and Share Projects

3.10.1 View in Online StraboMicro Viewer

1. Log in at https://strabospot.org.

2. Go to Account > My StraboMicro Data.

3. Click Options > View next to a project.

Ensure the latest version has been uploaded before viewing online.

3.10.2 Sharing Projects

The Share feature allows others to download your project using a short code—no login required.
Shared projects are independent copies; changes made by others do not affect your original.

Important: Share codes always retrieve the most recent uploaded version, not a snapshot. To
share a static version, use a .smz export or create a DOI (see Section 3.11).

3.10.3 Generate a Share Code

1. Log in at https://strabospot.org.

2. Go to Account > My StraboMicro Data.
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3. Click Options > Share next to the desired project.

4. Follow on-screen instructions to generate and copy the share code.

Note: Shared projects are not collaborative; each copy is independent.

3.11 DOI Creation
You can generate a DOI (Digital Object Identifier) for a static, citable version of your project. Once
created, the DOI links to a permanent snapshot, unaffected by future changes.

3.11.1 Generate a DOI

1. Log in at https://strabospot.org.

2. Go to Account > My StraboMicro Data.

3. Click Options > Get DOI for Project.

4. Follow the instructions to finalize DOI creation.

3.11.2 View a Project via DOI

1. Go to https://strabospot.org.

2. Navigate to Search > Search All StraboSpot Data.

3. Log in to your account.

4. Enter the DOI and click Add.

5. Select View next to the desired project.

Tip: DOIs are ideal for citing your data in publications. Include the DOI in your manuscript’s data
availability statement to ensure reviewers and readers can access your project data.

4 User Interface Overview
StraboMicro features a modern, responsive user interface designed for intuitive navigation and
efficient interaction with micrograph data and metadata. The interface has been completely re-
designed usingmodernweb technologieswhile preserving the familiar workflow from the original
StraboMicro application. The layout is organized into four main panels, all of which are resizable
and collapsible to suit your workflow preferences.
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Figure 11: Overview of the StraboMicro desktop application. The interface features a modern
three-pane layout with resizable panels, a collapsible bottom notes section, and enhanced navi-
gation capabilities.

• Left Panel (Project Viewer): The primary navigation pane where users browse and select
samples andmicrographs within a project. Navigation tabs at the top allow organization by
Samples,Groups, Spots, orTags. NEW:A statistics footer displays total counts for samples
and micrographs in the current project.

• Center Panel (Micrograph Viewer): Displays the currently selected micrograph for viewing,
annotation, and analysis. Built on the high-performance Konva.js canvas engine with ad-
vanced rendering capabilities. NEW: Supports up to 20x zoomwith dynamic Level-of-Detail
(LOD) rendering for consistently sharp imagery.

• Right Panel (Metadata Pane): The metadata and information pane where users enter and
manage structured data associated with each micrograph or spot. Features tabbed organi-
zation for Micrograph/Spot data, Sketches, and Project settings.

• Bottom Panel (Detailed Notes): A collapsible detailed notes section containing all notes
from any of the fields available for the selected micrograph or spot. This section updates
dynamically based on the current selection.

• Menu Bar: Provides access to core application functions, including file management, edit-
ing tools, view options, analysis tools, account settings, and help documentation.
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4.1 Panel Flexibility
NEW:All panels in StraboMicro 2.0 are fully resizable and collapsible, giving you complete control
over your workspace layout:

• Resizable Panels: Drag the divider between any two panels to adjust their relative sizes.
The application remembers your panel sizes between sessions.

• Collapsible Panels: Each side panel can be collapsed by clicking its edge or using the col-
lapse button, maximizing space for the micrograph viewer when needed.

• Double-Click Reset: Double-click any panel divider to reset panels to their default propor-
tions.

This modular layout supports a streamlined and customizable workflow: navigate samples and
micrographs on the left, analyze them in the center, view or enter detailed data on the right, and
review notes below. The tabbed navigation system in the Project Viewer pane enhances flexibility
by allowing users to organize data according to their preferred context.

4.2 StraboMicro Terminology
Understanding key terms used in StraboMicro will help users organize and interpret their image
data effectively. Two important concepts in the platform are Reference Micrographs and Asso-
ciated Micrographs.

Reference Micrograph

A Reference Micrograph is typically a low-resolution or stitched image—often a full thin section
scan—that serves as a spatial framework for other, more detailed images. It provides context and
scale for viewing and organizing high-resolution micrographs.

Associated Micrograph

An Associated Micrograph is any image that is spatially linked to a ReferenceMicrograph. These
images inherit the scale and spatial position defined by the reference image, allowing users to
relate high-magnification data (e.g., specific features, grains, or deformation structures) back to
the broader context of the thin section.

There is no limit to the number of nested Associated Micrographs. Users can create hierarchical
relationships among images at increasing levels of magnification or focus. This nested structure
supports the documentation of geologic features from the thin section scale down to the grain
or subgrain level.

Example Hierarchy

• Reference: Thin Section Scan

• Associated: Shear Zone Micrograph

• Associated: Specific Area within Shear Zone
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• Associated: Image of Individual Grain

• Associated: EBSD Map of Grain

This hierarchical framework allows for the integration of multiple scales of observation, support-
ing detailed documentation and analysis within a consistent spatial context.

4.3 Project Viewer Pane: Project Navigation
The Project Viewer Pane in StraboMicro serves as the primary navigation area for organizing and
accessing project content, including samples, micrographs, groups, spots, and tags. The pane is
designed to support flexible workflows and customizable data organization.

Navigation Tabs

At the top of the Project Viewer Pane are four navigation tabs that control how data is displayed:

Figure 12: Navigation tabs in the Project Viewer Pane allow switching between different organi-
zational views.

• Samples (Default): Displays a hierarchical view of all samples, including reference and as-
sociated micrographs. Each sample is represented with a thumbnail image and can be
expanded to reveal its related micrographs.

• Groups: Displays groups of micrographs organized by user-defined themes or characteris-
tics. For example, users can group all micrographs showing chessboard extinction or those
containing garnet. Selecting a group filters and displays only the relevant micrographs,
streamlining analysis by feature or objective.

• Spots: Lists all labeled spots across the project. Each micrograph displays a hyperlink list
of its corresponding spots. Clicking a spot will load the related micrograph in the main
viewing window and show its metadata in the Metadata Pane.

• Tags: Displays all tags used in the project. Clicking a tag will show all associated spots,
each linked to its correspondingmicrograph. Selecting a spot from the list opens the related
micrograph in the main window and displays the tagged spot’s metadata in the Metadata
Pane.

Managing Samples and Micrographs

In the Samples tab, there are 4 hierarchy levels: Project, Dataset, Sample, Micrograph, refer to
Figure 13 for a labeled example. Users can manage project data as follows:

Project Section:

• 3-Dot Menu contains the option to Edit Project Metadata
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• + Button contains the option to Add New Dataset

Dataset Section:

• 3-Dot Menu contains the following options:

– Edit Dataset Metadata

– Delete Dataset

• + Button contains the following option:

– Add New Sample

Sample Section:

• 3-Dot Menu contains the following options:

– Edit Sample Metadata

– Delete Sample

• + Button contains the following options:

– Add New Reference Micrograph

– Batch Import New Reference Micrographs

Micrograph Section, Reference Micrograph:

• 3-Dot Menu contains the following options:

– Add to Group(s)

– Edit Micrograph Metadata

– Delete Micrograph

• + Button contains the following options:

– Add Associated Micrograph. Associated micrographs inherit scale and spatial
positioning from the reference and are displayed on top of it in the main viewer.

– Batch Import Associated Micrograph

Micrograph Section, Associated Micrograph:

• 3-Dot Menu contains the following options:

– Add to Group(s)

– Edit Micrograph Metadata

– Edit Micrograph Location

– Edit Micrograph Opacity

– Delete Micrograph

• + Button contains the following options:

– Add Associated Micrograph

– Batch Import Associated Micrograph
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• The eye icon toggles visibility of the associated micrograph.

Figure 13: Sections in the Project Navigation Pane, including: Navigation Tabs, Project, Dataset(s),
Sample(s), and Micrographs (both Reference and Associated). All sections and associated ac-
tions are covered in this section, Section 4.3.

Drag-and-Drop Reordering

NEW: StraboMicro supports intuitive drag-and-drop reordering of items in the Project Viewer:

• Drag samples to reorder them within the project hierarchy.

• Drag micrographs to change their order within a sample or move them between samples.

• Visual feedback shows the drop target location as you drag items.

• Items can also be reordered using Ctrl+Up/Down (Windows/Linux) or Cmd+Up/Down (ma-
cOS) keyboard shortcuts.

Project Stats Footer

NEW: At the bottom of the Project Viewer Pane, a statistics footer displays real-time counts:

Total Samples: X • Total Micrographs: Y

This provides a quick overview of your project’s scope without needing to manually count items.

4.4 Micrograph Viewer: Image Display
The Micrograph Viewer in StraboMicro displays the micrograph currently selected in the Project
Viewer Pane. This is the primary workspace for viewing, analyzing, and annotating images. The
viewer is built on the high-performance Konva.js canvas engine, providing smooth panning, zoom-
ing, and rendering of even very large images. Refer to Figure 11 for screenshot of the application
with labeled sections.

Image Display and Scale

The displayed image includes dynamic scale rulers along the top and left edges. As the user
zooms in, zooms out, or pans across the image, the rulers adjust in real time to reflect the current
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magnification level and visible region. This ensures accurate spatial interpretation at any zoom
level.

At the bottom edge of the imagewindow, the live coordinate readout displays the current position
of the cursor as:

X: [value] unit, Y: [value] unit

These coordinates correspond to the location of the cursor on the image and are dynamically
updated as the user moves the mouse. The units used are based on the spatial scale defined
when the image was initially uploaded.

Enhanced Zoom Capabilities

NEW: StraboMicro 2.0 significantly improves zoom capabilities:

• Maximumzoom increased from5x to 20x, allowing detailed examination of finemicrostruc-
tures.

• Smooth zoom transitions using mouse wheel or trackpad gestures.

• Zoom-to-cursor behavior centers the zoom on your point of interest.

• Zoom level indicator displayed in the toolbar.

Dynamic Level-of-Detail (LOD) Rendering

NEW: StraboMicro introduces intelligent Level-of-Detail rendering for associated micrographs:

• Automatic quality adjustment: The system automatically selects the appropriate image
resolution based on current zoom level and screen coverage.

• Three rendering modes:

– Thumbnail mode: Used when the image covers less than 10% of the screen or when
zoomed out significantly.

– Downsampled mode: Used at moderate zoom levels with 10–40% screen coverage.

– Full tile mode: Activated at high zoom or when the image covers more than 40% of the
screen, providing maximum detail.

• Consistent sharpness: Overlays remain crisp and clear at any zoom level, eliminating the
blurry appearance that could occur in the legacy application.

Progressive Tile Loading

NEW: Large images are loaded progressively using a tiled approach:

• Instant initial display: A low-resolution preview appears immediately while high-resolution
tiles load in the background.

• Visual loading indicators: Subtle shimmer effects show which tiles are still loading.

• Priority loading: Tiles in the current viewport are loaded first, followed by adjacent areas.
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• Intelligent caching: Previously loaded tiles are cached for instant display when revisiting
areas or re-opening projects.

Detailed Notes Section

Beneath the main image display is the Detailed Notes section. This collapsible section shows
image-specific metadata, notes, or other user-entered information related to the currently dis-
played micrograph or selected spot. It provides an accessible overview of contextual or observa-
tional data without needing to expand individual metadata sections in the Metadata Pane.

This combination of responsive navigation, accurate spatial coordinates, intelligent rendering,
and linked metadata supports a seamless and precise workflow for image-based geologic anal-
ysis.

4.5 Metadata Pane Overview
TheMetadata Pane displaysmetadata associated with the currently selectedmicrograph or spot.
This includes both the information provided during the micrograph upload process and any addi-
tional metadata entered by the user. The pane is organized with tabs for different data categories.

Figure 14: The Metadata Pane with tabbed organization for Micrograph or Spot data, Sketches,
and Project information. Either Micrograph or Spot will appear as the first tab depending on what
is actively selected in the Micrograph Viewer, Micrograph is the default tab.

4.5.1 Spot Tools

Between the center viewing window and the metadata pane are vertical buttons for creating and
managing spots (from top to bottom):

Show/Hide Metadata Pane – Toggle the visibility of the right panel to maximize viewing
area.

Add Spot – Spots are useful for marking small, specific features such as unique observa-
tions, individual grains, or regions analyzed with other instruments.

Add Line Spot – Line Spots are used to annotate linear features, transects, or boundaries.

Add Polygon Spot – Polygon Spots allow users to define custom shapes representing
larger spatial areas of the micrograph.

Lasso Spots – The Lasso Spots Tool allows users to draw a line around all spots they
would like to select, similar to the Lasso Tool in StraboField. The Lasso Tool can also be
used with the keyboard shortcut Shift+Drag.
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Users can customize the color and transparency of a single spot 2 ways:

1. Select the Spot, right-click the spot and choose Edit Spot Metadata

2. Select the Spot, locate the Spot Metadata section in the right Metadata Pane (Figure 11),
click the Edit pencil button.

Users can customize the color and transparency of several spots 2 ways:

1. Using the Lasso Tool (or Shift+Drag), select multiple Spots, right-click the spots and choose
Edit Selected Spots...

2. Select the Spots, in the upper menu bar go to Spot > Edit Selected Spots

Sketch – The Sketch Mode Button activates the Sketch Tool, see below in Section 8.3 for
more information.

Measure Tool–Measure distances on themicrograph. NEW:Nowdisplaysmeasurements
in real-world units (micrometers, millimeters, etc.) based on the image scale.

4.5.2 Toolbar Functions

The toolbar provides essential navigation and measurement tools:

Cursor Tool – Pan the image and select objects. Click and drag to pan; click on spots or
micrographs to select them.

Zoom Out – Decrease magnification. You can also use the scroll wheel or trackpad pinch
gesture.

Zoom In – Increase magnification up to 20x. You can also use the scroll wheel or trackpad
pinch gesture.

Re-Center–Reset view to the original position and zoom level, fitting the entiremicrograph
in the viewer.

Below the toolbar, themicrograph name and type are displayed, followed byDownload andDelete
buttons.

4.5.3 Data Entry Section

The data section begins below the micrograph name. A label, ``Add Data:'', appears above a
search bar where users can search for a data input type. Alternatively, a dropdownmenu provides
a list of available data pages.

There are 18 specialized data entry pages for geological metadata. These are described in detail
in Section 6: Data Entry and Observation Tools. The available pages include:

• Project/Dataset Metadata

• Sample Metadata

• Micrograph Metadata

• Mineralogy/Lithology
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• Grain Information

• Fabric Information

• Clastic Deformation Bands

• Faults and Shear Zones

• Extinction Microstructures

• Grain Boundary/Contact Information

• Vein Information

• Pseudotachylyte Information

• Fold Information

• Notes

• Associated Files

• Links

4.6 Top Menu Overview
At the top of the StraboMicro2 window, you will find the main menu bar. The primary menu cate-
gories include:

• StraboMicro2, which contains standard File options.

• Edit

• Tools

• Spot

• Account

• View

• Help

Each menu contains tools and options designed to manage your project, customize your view,
access analysis tools, and get help. The following is a summary of the options available in each
menu.

StraboMicro2 Menu

• New Project – Create a new local project. Local means the project will be saved to your
device until manually uploaded to the server.

• Open Local Project (.smz) – Open a StraboMicro project saved on your device.

• Open Remote Project – Open a project from your StraboSpot account.

• Open Shared Project – Open a project shared by another user using a sharing code.

• NEW: Recent Projects – Quick access submenu showing recently opened projects for fast
navigation.

• Close Project – Closing the Project will: Delete all project files from your Documents folder;
remove the project from the Recent Projects menu; clear all version history. Warning: this
action cannot be undone.

• Save Project (Cmd+S/Ctrl+S) – Save the project locally to your device.

• Export as .smz – Export the project as a .smz file.

• Upload to Strabo Server – Upload the StraboMicro project to your StraboSpot account on-
line.
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• NEW: View Version History – View and restore previous versions of your project (requires
cloud sync).

• Edit Project – Opens the Project Metadata for editing.

• Export All Images – Opens the Export Dialog with JPEG and SVG download options, see
Section 3.8.1 for more information.

• Export View with Sketches – Opens the Export Image with Sketches dialog with options
including: what to include in the export, Sketch Layers, Export Format, and Resolution. See
Section 8.7 for more information.

• Export as JSON – Creates a JSON file of your project for external use and opens the file
directory for users to chose where to save the JSON file.

• Export as PDF – Creates a PDF file of the project including images, annotations, and meta-
data.

• Quit StraboMicro2 – Exit the application (Cmd+Q on macOS, Alt+F4 on Windows).

Edit Menu NEW: The Edit menu provides quick access to editing functions:

• Undo (Cmd+Z/Ctrl+Z) – Undo the last action.

• Redo (Cmd+Shift+Z/Ctrl+Y) – Redo the previously undone action.

• Cut (Cmd+X/Ctrl+X) – Cut selected item.

• Copy (Cmd+C/Ctrl+C) – Copy selected item.

• Paste (Cmd+V/Ctrl+V) – Paste from clipboard.

• Select All (Cmd+A/Ctrl+A) – Select all spots on the current micrograph.

• Clear All Spots – Delete all Spots on the current Micrograph in the Micrograph Viewer.

Tools Menu NEW: The Tools menu provides access to advanced analysis capabilities:

• NEW: Point Count – Open the point counting tool for modal analysis.

• NEW: Grain Detection – Automatically detect and outline grains in the current micrograph.

• Image Comparator – Compare two micrographs side by side with synchronized navigation.

• NEW:Grain SizeAnalysis–Analyze grain size distribution fromdetected ormanuallymarked
grains.

Spot Menu

• Quick Spots Presets – Open the Quick Spot Presets dialog for creating Spot templates
either globally (associated with the StraboSpot account) or for the specific Project open.

• NEW: Quick Edit Spots – Open the batch editing dialog for modifying multiple spots simul-
taneously.

• Edit Selected Spots – Open the Edit Spots dialog and edit Primary Mineral, Color, and/or
Opacity of all Spots at the same time.
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• Merge Selected Spots – Will merge two polygon Spots into one Spot. Merge cannot be
applied to point or line Spots.

• Split Spot with Line – Allows a polygon Spot to be split into two polygon Spots with a user
drawn line. Split cannot be applied to point or line spots.

• Configure Mineral Colors – Opens the Configure Mineral Colors dialog, which displays min-
erals and their assigned colors. The dialog shows both:

– Global Colors – Color assignments associated with the StraboSpot user account.

– Project Colors – Project specificmineral color assignments that differ from the Global
color settings.

Account Menu

• Login to StraboSpot – Log in to your StraboSpot account.

• Logout – Log out of your StraboSpot account.

View Menu

• Show Rulers – Toggle visibility of the scaled rulers surrounding the micrograph viewing
area.

• NEW: Show Original Spot Labels – Toggle visibility of spot name labels on the micrograph.

• NEW: ShowMineralogy Spot Labels – Toggle visibility of mineral abbreviation labels on the
micrograph if mineralogy has been defined for the spots.

• Hide Spot Labels – Hide visibility of spot name labels on the micrograph.

• NEW: Show Overlay Outlines – Toggle red outlines around associated micrographs when
viewing a reference image.

• NEW: ShowRecursive Spots–Display spots fromassociatedmicrographs on the reference
image.

• View Spots by Spot Color – Show defined spot color on the Micrograph.

• NEW: View Spots by Mineral Color – Show defined mineral color on the micrograph.

• NEW: Theme – Submenu for theme selection:

– Light – Light color scheme.

– Dark – Dark color scheme.

– System – Follow operating system theme setting.

Help Menu

• About StraboMicro – Displays version information and license details.

• StraboMicro User Guide – Opens the user manual and documentation.

• Check for Updates – Check if a newer version of StraboMicro is available.
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• View Error Logs – Opens a list of Error Logs that can be viewed, copied to the clipboard, or
emailed to StraboSpot support.

• Send Error Report – Send a record of recent actions to developers to help diagnose issues.

4.7 Theme Support
NEW: StraboMicro now includes comprehensive theme support to reduce eye strain and accom-
modate different working environments:

(a) Light Theme (b) Dark Theme

Figure 15: StraboMicro supports both Light and Dark themes, with smooth transitions between
them.

Available Themes

• Light Theme: A bright interface with light backgrounds, ideal for well-lit environments. This
is the classic appearance similar to the original StraboMicro.

• Dark Theme: A dark interface with muted colors that reduces eye strain in low-light condi-
tions. Particularly useful for extended analysis sessions.

• System Theme: Automatically follows your operating system’s theme setting. When your
OS switches between light and dark mode (e.g., based on time of day), StraboMicro will
switch automatically.

Changing Themes

To change the application theme:

1. Navigate to View > Theme in the menu bar.

2. Select your preferred theme: Light, Dark, or System.

3. The theme change takes effect immediately with a smooth transition animation.

Your theme preference is saved automatically and will persist between application sessions.
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4.8 Keyboard Shortcuts
NEW:StraboMicro includes comprehensive keyboard shortcuts to accelerate commonworkflows.
Below are some of the most frequently used shortcuts:

Action macOS Windows/Linux

Save Project Cmd+S Ctrl+S
Undo Cmd+Z Ctrl+Z
Redo Cmd+Shift+Z Ctrl+Y
Zoom In Cmd+Plus Ctrl+Plus
Zoom Out Cmd+Minus Ctrl+Minus
Fit to Window Cmd+0 Ctrl+0
Delete Selected Delete Delete
Select All Spots Cmd+A Ctrl+A
Toggle Full Screen Cmd+Ctrl+F F11
Move Item Up Cmd+Up Ctrl+Up
Move Item Down Cmd+Down Ctrl+Down

For a complete list of all keyboard shortcuts, see Appendix 10.2: Complete Keyboard Shortcuts
Reference.

Tip: Most menu items display their keyboard shortcut next to the menu item text, making it easy to
learn shortcuts as you work.

5 Sample and Spot Management
This section covers the complete workflow for creating samples, adding micrographs, and man-
aging spots in StraboMicro. Several new features have been added to improve workflow effi-
ciency and enable more precise spatial analysis.

5.1 Add / New Sample
To begin adding a new sample, click the + button next to the Dataset, see Section 4.3 and Figure
13 for more information.

The following sections outline each modal that appears during the new sample creation process.

5.1.1 Sample Info

The Sample Info modal collects descriptive metadata for your sample:

• Sample ID/Name*

• IGSN: International Generic Sample Number

• Location: Latitude and Longitude
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Figure 16: New Sample: Sample Info modal in StraboMicro

• Main Sampling Purpose:

– Fabric / Microstructure

– Petrology

– Geochronology

– Geochemistry

– Active Eruption

– Other
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• Description

• Material Type:

– Intact Rock

– Fragmented Rock

– Sediment

– Tephra

– Carbon or Animal

– Other

• Sample Notes

*Required field. Click Create Sample to add the sample to the dataset.

5.2 Load Reference Micrograph

5.2.1 Step 1 of 7: New Reference Micrograph

Locate the Sample in the Project Navigation Pane the Reference Micrograph should be added to.
Click the + button.

• Choose Load Reference Micrograph to add 1 reference micrograph.

• Choose Batch Upload Reference Micrographs to addmultiple reference micrographs
to the sample at the same time.

Supported image formats: .jpeg, .png, .bmp, .tiff

• In the Load Reference Micrograph modal, click Browse to select and upload an image file
from your computer.

• Important: The image must include a clearly visible scale bar.

• Click Next to proceed to the Instrument and Image Info section.

5.2.2 Step 2 of 7: Instrument and Image Information

In the Instrument and Image Information modal, you can:

• Use the Load Metadata from Previous Image option to import metadata from a previously
uploaded micrograph in the project.

• Use the Select... dropdown to choose an existing sample, which will auto-fill its Sample
ID/Name.

• Choose the instrument manually from the dropdown, or click Find Instrument in Database
to search the shared StraboMicro instrument repository.

• For additional details about the instrument repository, see Section 2.6.

Metadata Input by Instrument Type
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• If selecting a new instrument manually, choose from the following Instrument Types:

– Optical Microscopy

– Scanner

– Transmission Electron Microscopy (TEM)

– Scanning Transmission Electron Microscopy (STEM)

– Scanning Electron Microscopy (SEM)

– Electron Microprobe

– Fourier Transform Infrared Spectroscopy (FTIR)

– Raman Spectroscopy

– Atomic Force Microscopy (AFM)

– Other

Supported Image/Data Types per Instrument:

• OpticalMicroscopy: PlanePolarized Light, CrossPolarized Light, Reflected Light, 1/4 Lambda
Plate, Cathodoluminescence, Gypsum Plate.

• Scanner: No Polarizer, Plane Polarized, Cross Polarized, Other.

• TEM: Bright Field, Dark Field, Electron Diffraction (SAED, CBED, NBD, LACBED), EDS (with
periodic table element selection), ACOM, EDS Tomography.

• STEM: Bright Field, Dark Field, ADF, HAADF, EDS (element selection), EELS, CL (Panchro-
matic, Wavelength-Filtered, Spectroscopy).

• SEM: SE, BSE, FSE, EBSD (Euler, IPF-X/Y/Z, Band Contrast, Phase Map, Grain Boundaries),
TKD, ECCI, EDS/WDS (element selection), CL (Panchromatic,Wavelength-Filtered), FIB Imag-
ing.

• FTIR: False Color Map, Intensity Map.

• Raman Spectroscopy: False Color Map, Intensity Map.

• AFM Topography Image.

Metadata Entry Options

• Enter metadata manually or load from the StraboMicro instrument database.

• When applicable (e.g., for EDS, WDS), use the interactive periodic table to select elements.

• Input data for specific analytical modes such as EBSD, CL, or EELS where prompted.

Refer to Appendix 10.1 for explanations of abbreviations.

5.2.3 Step 3 of 7: Instrument Data

Click Next to open the Instrument Data modal.

The instrument type youpreviously selectedwill appear (e.g., Instrument Type: OpticalMicroscopy).
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Fields to Complete:

• Instrument Brand:

• Instrument Model:

• Instrument Location: Institution and lab name

• Software (Data Collection): Application name and version

• Software (Post-Processing): Application name and version

• Notes: Optional field for any additional information

For certain instrument types, an additional Detectors section may appear, including:

• Type

• Make

• Model

Note: If you selected a preloaded instrument from the StraboMicro repository, these fields will be
auto-filled and do not require manual input.

5.2.4 Dependent Step: Instrument Settings

ClickNext to continue the upload process. For certain instrument types, an additional Instrument
Settingsmodal will appear. The fields shown in thismodal are specific to the selected instrument.

For Scanning Electron Microscopy (SEM) or Electron Microprobe:

• Acceleration Voltage (kV)

• Beam Current (nA)

• Spot Size (µm)

• Aperture

• Working Distance (mm) replaces Camera Length

• Other fields may vary depending on instrument configuration

For Transmission Electron Microscopy (TEM):

• Acceleration Voltage (kV)

• Beam Current (nA)

• Spot Size (µm)

• Aperture

• Camera Length (mm)

For Scanning Transmission Electron Microscopy (STEM): Includes all TEM fields, plus:

• Camera Binning

• Dwell Time (s)
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For Fourier Transform Infrared Spectroscopy (FTIR):

• Instrument Purged (Yes/No)

• Environment Purged (Yes/No)

• Aperture (µm2)

• Scan Time (s)

• Resolution (Hz)

• Spectral Resolution (cm-1)

• Wavenumber Range

• Averaging

• Background Composition (KCl, NaCl, Other)

• Background Correction Frequency

• Notes

For Raman Spectroscopy:

• Excitation Wavelength (µm)

• Laser Power (mW)

• Spot Size (µm)

• Diffraction Grating (grooves/mm)

• Integration Time (s)

• Objective (magnification, e.g., 10x, 50x)

• Spatial Resolution (µm)

• Averaging

• Calibration

For Atomic Force Microscopy (AFM):

• Mode (Contact, Intermittent Contact [Tapping])

• Cantilever Stiffness (N/m)

• Tip Diameter (µm)

• Operating Frequency (kHz)

• Scan Dimensions (pixels)

• Scan Area (µm)

• Spatial Resolution (µm)

• Room Temperature (◦C)

• Relative Humidity (%)
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• Sample Temperature (◦C)

Note: Only the fields relevant to the selected instrument type will be displayed. If metadata was
preloaded via the instrument repository, these fields may already be filled in.

5.2.5 Step 4 of 7: Micrograph Metadata

In this section, you will be prompted to enter the following metadata:

• Name: A text field to assign a unique name or identifier to the micrograph.

• Polished: A checkbox indicating whether the sample surface is polished.

– If selected, an additional field will appear to describe the polishing method or details.

• Notes: An optional text field for any additional observations or comments.

5.2.6 Step 5 of 7: Orientation of Reference Micrograph

Define the orientation of the referencemicrograph by selecting one of the following three options:

1. Unoriented Thin Section

• No additional metadata is required.

2. Trend and Plunge of Edges / Strike and Dip of Surface

• This option requires users to define the micrograph orientation using geologic mea-
surements.

• A message at the top of the modal instructs:

”ProvideTWOof THREE: Select the arrowon each edge that represents a lower
hemisphere plunge, and enter the trend andplunge information and/or provide
the strike and dip of the thin section.”

• Input fields include:

– Trend and Plunge values for both horizontal and vertical axes

– Corner selection to define orientation direction

– Strike and Dip of the thin section surface
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Figure 17: Example modal for entering Trend and Plunge or Strike and Dip orientation data.

3. Fabric Reference Frame (XZ, YZ, XY Thin Sections)

• Select the orientation of the thin section based on the structural fabric:

– XZ – Lineation (X) and foliation normal (Z)

– YZ – Perpendicular to lineation (Y) and foliation normal (Z)

– XY – Lineation (X) and perpendicular to lineation (Y) in the foliation plane

• Required metadata:

– Foliation Orientation: Strike and Dip (Geographic coordinates)

– Lineation Orientation: Either

* Trend and Plunge, or

* Rake (Right-Hand Rule, 1–180◦)

– Look Direction: Specify whether the image was taken:

* Looking down through the micrograph (toward the lower hemisphere), or

* Looking up through the micrograph (toward the upper hemisphere)

– A note in the modal provides clarification:

”When viewing the reference micrograph, are you looking toward the lower
hemisphere or upper hemisphere in geographic coordinates?”
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Figure 18: Fabric Reference Framemodal with XZ/YZ/XY options and orientationmetadata fields.

5.2.7 Dependent Step: Define Top Corner (Fabric Reference Frame Only)

If you selected the Fabric Reference Frame option, an additional modal will appear: Define Top
Corner.

• The micrograph image is displayed with clickable buttons at each corner.

• Select the corner that is highest in geographic coordinates by clicking the corresponding
button.

5.2.8 Step 6 of 7: Set Micrograph Scale and Location

After defining the orientation, the next step is to set the scale and spatial information for themicro-
graph. StraboMicro provides five methods for setting scale, including a new 3-Point Registration
system for precise alignment of overlay micrographs.

Choose one of the following scale-setting methods:

1. Trace Scale Bar

• Use drawing tools to trace a line across the visible scale bar in the image.

• Tools include:

– Pointer Tool: Move or reposition the micrograph.

– Line Tool: Click and drag to draw a line. Repeat as many times as needed to
appropriately trace the scale bar in the image.

• The pixel length is automatically calculated. Enter the corresponding real-world length
and select the correct unit (µm, mm, cm).
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• Use mouse scroll to zoom in/out on the image.

• Optionally, check Flip Image to mirror the micrograph across the vertical axis.

2. Pixel Conversion Factor

• Enter the pixel-to-distance conversion factor directly.

• Input the number of pixels and its real-world equivalent (units: µm, mm, cm).

• Flip Image option is also available.

3. Provide Width/Height of Image

• Enter the total width and height of the image manually.

• Select the units from the dropdown.

• The Flip Image checkbox is included.

4. Copy Size from Existing Micrograph

• Select a previously uploaded micrograph to copy its size.

• A dropdown menu lists all available micrographs.

• Flip Image option is also included.

5. 3-Point Registration (Affine Transform Placement) NEW NOTE: The 3-Point Registration
is only available if you are loading a Associated Micrograph.

• This method enables precise spatial alignment of child micrographs onto parent mi-
crographs using three corresponding control points.

• The 3-point registration calculates an affine transformation that accounts for:

– Translation – positioning the image at the correct location

– Rotation – aligning orientation between images

– Scale – matching magnification differences

– Shear – correcting for distortion or skew

How to Use 3-Point Registration:

(a) Select 3-Point Registration from the scale method options.

(b) The parent micrograph is displayed in the left panel. Click to place three control points
on recognizable features (e.g., grain boundaries, mineral inclusions, or other identifi-
able landmarks).

(c) The childmicrograph is displayed in the right panel. Click to place three corresponding
points that match the features selected on the parent.

(d) As you place points, a live preview shows the calculated transformation overlaid on
the parent micrograph.

(e) Adjust point positions as needed by clicking and dragging until the alignment is satis-
factory.

(f) Click Apply to finalize the registration, or Reset to start over.
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Tips for Accurate Registration:

• Choose control points that are spread apart across the image for better accuracy.

• Select features that are clearly visible in both micrographs.

• Zoom in when placing points for sub-pixel precision.

• The transformation quality indicator shows the estimated alignment error.

5.2.9 Step 7 of 7: Scale Input

Once the selectedmethod is selected in step 6, a correspondingmodal will prompt you to finalize
themicrograph’s location and scale. The fields shown in this final step directly correspond to your
earlier selection. After all required inputs are entered, click Finish to add the referencemicrograph
to the sample and save it to the project.

5.3 XPL/PPL Synchronized Viewing

StraboMicro introduces synchronized viewing of plane-polarized light (PPL) and cross-polarized
light (XPL) micrographs. This feature allows researchers to quickly toggle between polarization
modes while maintaining their current view position, enabling efficient mineral identification and
analysis.

5.3.1 Linking PPL and XPL Images

To link two micrographs for synchronized viewing:

1. Right-click on a PPL or XPL micrograph in the sample tree and select Link Sibling PPL/XPL
Pair.

2. In the dialog that appears, select the corresponding XPL micrograph from the dropdown
list.

3. Once linked, a chain icon appears next to both micrographs in the sample tree.

PPL/XPL Link During Micrograph Upload PPL/XPL Linked Micrograph Icon

Figure 19: PPL/XPL micrograph upload process and pairing icon.

5.3.2 Toggling Between Views

Once images are linked:

• Press X on the keyboard to toggle between PPL and XPL views.

• Alternatively, click the Toggle PPL/XPL arrow button in the micrograph viewing area.

• The current polarization mode is indicated in the status bar.
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5.3.3 Synchronized Pan and Zoom

When viewing linked micrographs:

• Pan operations are synchronized –moving the view in one modemoves the corresponding
area in the other.

• Zoom operations are synchronized – zooming in PPL view zooms to the same level in XPL
view.

• The synchronization maintains the exact same field of view when toggling.

5.3.4 Shared Spots

• All spots created on a PPL micrograph automatically appear on its linked XPL counterpart,
and vice versa.

• Spot modifications (moving, resizing, property changes) are reflected in both views.

• This ensures consistent annotation across polarization modes.

5.3.5 Handling Different Image Dimensions

If the linked PPL and XPL images have slightly different dimensions:

• StraboMicro automatically calculates the scale relationship between the images.

• The synchronized view adjusts pan and zoom to maintain alignment.

• A warning icon appears if the dimension difference exceeds 5%, suggesting the use of 3-
Point Registration for better alignment.

5.4 Spot Management
Spots are a central concept in StraboSpot, representing spatial observations atmultiple scales. In
StraboMicro, a spot might represent a grain, a mineral inclusion, or any localized feature within a
thin section or micrograph. This multiscale framework enables users to document observations
consistently, from the field to the microscope.

StraboMicro 2.0 introduces several new spotmanagement features including batch editing, multi-
select operations, merge and split tools, and recursive spot viewing.

5.5 Adding a New Spot
Once amicrograph has been loaded, users can add new spots directly onto the image to annotate
and analyze specific features. Each spot is associated with editable metadata, accessible via the
right metadata pane, which includes information entered duringmicrograph upload and any user-
provided observations.
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5.5.1 Spot Tools

To the right of the central viewing window, a vertical toolbar provides access to spot creation
tools:

Show/Hide Right Panel

Add Spot – For marking discrete features such as mineral grains or points of interest.

Add Line Spot – For linear features such as foliations, transects, or crystal boundaries.

Add Polygon Spot – For selecting areas like individual grains, mineral zones, or deforma-
tion domains.

5.5.2 How to Add a Spot

Follow these steps to add a spot to a micrograph:

1. Determine the appropriate spot type: Choose whether you are marking a point, a line fea-
ture, or an area (polygon).

2. Click the corresponding button in the vertical toolbar to activate that spot mode. The se-
lected tool will highlight in red.

3. Navigate the micrograph: Use click-and-drag to move the image, scroll to zoom, or use the
zoom buttons in the top-right corner.

4. Add the spot to the micrograph:

• Point: Click once to place the spot.

• Line: Click to add vertices. Double-click the final point to complete the line.

• Polygon: Click to define each corner. The shape appears as you add points. Double-
click the last vertex to close the shape.

5. Fill out spot information: Once the spot is placed, a configuration modal appears (see Fig-
ure 20).

6. Enter metadata: Provide the spot name, label color, spot color, transparency, and optional
notes.

7. Save the spot: After saving, the spot appears in the micrograph and is listed in the Spot
Metadata panel on the right side (see Figure 21).

8. Edit the spot: Click the pencil icon (see Figure 21) in the metadata panel to make changes
or add more details.

Tip: If you activate a spot tool but decide not to place a spot, click the Cursor tool (top-right) or
press the Escape key (esc) to exit spot mode and return to default navigation.
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5.5.3 Spot Options

After selecting a spot type—Point, Line, or Polygon—a configuration modal appears (Figure 20)
allowing you to define the following:

• Spot Name: Assign a unique label.

• Label Color: Defines the text color for the spot label on the micrograph.

• Spot Color: Controls the fill or line color of the spot.

• Transparency: Adjust the opacity using a slider.

• Notes: Optional free-text field for observations, interpretations, or measurements.

All spot types can be customized further by navigating to:

Metadata Pane > Spot Metadata Section > Edit > Spot Color > Custom
Color > Edit Transparency

Figure 20: Add Spot configuration modal showing customization options for spot name, label
color, spot color, transparency, and notes.
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Figure 21: Spot Metadata panel showing saved spot entries and editable fields. The pencil icon
is used to edit spot metadata.

5.5.4 Real-World Spot Measurements

StraboMicro automatically calculates and displays real-worldmeasurements for line and polygon
spots when the micrograph has a defined scale.

Line Spot Measurements:

• Total Length: The sum of all line segments, displayed in the spot properties panel.

• For multi-segment lines, individual segment lengths are also available in the detailed view.

Polygon Spot Measurements:

• Area: The enclosed area of the polygon.

• Perimeter: The total boundary length of the polygon.

Smart Unit Selection:

Measurements are automatically displayed in the most appropriate unit based on magnitude:

• Values less than 1000 µm are displayed in micrometers (µm or µm2)

• Values between 1 mm and 10 mm are displayed in millimeters (mm or mm2)

• Values greater than 10 mm are displayed in centimeters (cm or cm2)

Back to Top 55



(a) Line Spot Measurements

(b) Polygon Spot Measurements

Figure 22: Spot properties panel showing real-world measurements for a polygon and line spot,
including length, area, and perimeter with smart unit display.

5.6 Batch Edit and Multi-Select

StraboMicro introduces powerful batch spot editing capabilities that allow you to select andmod-
ify multiple spots simultaneously, significantly improving workflow efficiency when working with
many annotations.

5.6.1 Multi-Select Methods

Lasso Selection:

1. Hold Shift and click-drag to draw a freeform selection area.

2. All spots fully enclosed within the lasso will be selected.

3. Selected spots are highlighted with a distinct selection indicator.

Click Selection:

• Cmd+Click (Mac) or Ctrl+Click (Windows/Linux) to add individual spots to the current se-
lection.

• Click an already-selected spot with the modifier key to remove it from the selection.

• Cmd+A or Ctrl+A selects all spots on the current micrograph.

Selection from Spot List:

• In the Spot Metadata panel, hold Shift and click to select a range of spots.
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• Use Cmd/Ctrl+Click to toggle individual spots in the list.

5.6.2 Batch Property Editing

With multiple spots selected, you can modify shared properties:

• Color: Apply a uniform color to all selected spots.

• Mineral Assignment: Assign the same mineral type to multiple grain spots.

• Tags: Add or remove tags from all selected spots.

• Transparency: Adjust opacity for all selected spots simultaneously.

To batch edit:

1. Select multiple spots using any method described above.

2. Right-click to open the context menu and select Batch Edit Properties.

3. In the batch edit panel, modify the desired properties.

4. Click Apply to All to update all selected spots.

Figure 23: Batch Edit panel showing editable properties for multiple selected spots.

5.6.3 Batch Delete

To delete multiple spots at once:

1. Select the spots you wish to delete.

2. Press Delete or Backspace, or right-click and select Delete Selected Spots.
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3. A confirmation dialog shows the number of spots to be deleted.

4. Click Confirm to proceed or Cancel to abort.

Note: Batch delete operations can be undone using Cmd+Z (Mac) or Ctrl+Z (Windows/Linux).

5.7 Merge and Split Tools
NEW FEATURE

StraboMicro2 provides tools for combining and dividing polygon spots, enabling flexible refine-
ment of annotations as your analysis progresses.

5.7.1 Merge Tool

The merge tool combines multiple adjacent polygon spots into a single unified polygon.

How to Merge Polygons:

1. Select two or more polygon spots that share boundaries or overlap.

2. Press M on the keyboard, or right-click and select Merge Selected Polygons.

3. The polygons are combined into a single polygon encompassing all selected areas.

4. A dialog prompts you to choose which spot’s properties to retain for the merged result, or
to enter new properties.

Merge Behavior:

• Adjacent polygons are combined along shared edges.

• Overlapping polygons create a union of their areas.

• Non-adjacent polygons can be merged into a multi-part polygon if needed.

• The merged polygon inherits the ID of the first selected spot by default.

5.7.2 Split Tool

The split tool divides a single polygon into two separate polygons using a drawn line.

How to Split a Polygon:

1. Select a single polygon spot.

2. Press / (forward slash) on the keyboard, or right-click and select Split Polygon.

3. The cursor changes to a crosshair indicating split mode.

4. Draw a line across the polygon to define the split boundary:

• Click to start the line outside or on the polygon edge.

• Click additional points to create a multi-segment split line if needed.

• Double-click to end the line outside or on the opposite edge.
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5. The polygon is divided into two separate spots along the drawn line.

6. Each resulting polygon appears as a new spot, with properties copied from the original.

Split Behavior:

• The split line must cross the polygon completely.

• Both resulting polygons inherit properties from the original.

• New spot IDs are automatically generated for the split results.

• Press Escape to cancel split mode without making changes.

5.7.3 Undo/Redo Support

Both merge and split operations fully support undo and redo:

• Cmd+Z (Mac) or Ctrl+Z (Windows/Linux) to undo.

• Cmd+Shift+Z (Mac) or Ctrl+Y (Windows/Linux) to redo.

• The undo history preserves the original spot geometries and properties.

5.7.4 Provenance Tracking

StraboMicro maintains a record of merge and split operations for data integrity:

• Merged spots record the IDs of their source spots in the metadata.

• Split spots record the ID of their parent spot.

• This provenance information is preservedwhen exporting data and syncingwith StraboSpot.

• Access provenance details via Spot Metadata > History.

5.8 Recursive Spots

When working with hierarchical micrograph stacks (parent micrographs with child overlays), Stra-
boMicro can display spots from child micrographs on the parent view. This Recursive Spots
feature provides a comprehensive overview of all annotations across the image hierarchy.

5.8.1 Enabling Recursive Spot Display

To show spots from child micrographs on the parent view:

1. Navigate to a parent micrograph that has associated child micrographs.

2. Go to View > Show Recursive Spots in the menu bar, or press Cmd+R (Mac) / Ctrl+R (Win-
dows/Linux).

3. Spots from all child micrographs are now displayed on the parent view.

4. A status indicator in the toolbar shows when recursive spots are active.
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Figure 24: Parent micrograph with recursive spots enabled, showing annotations from a child
micrograph displayed with correct spatial transformations. Recursive line spots are plotted on
the associated child micrograph in pink and green.

5.8.2 How Recursive Spots Are Rendered

When recursive spot display is enabled:

• Position: Spots are transformed to the correct location on the parent micrograph based on
the child’s placement.

• Scale: Spot sizes are adjusted to match the scale relationship between parent and child.

• Rotation: If the child micrograph is rotated relative to the parent, spots are rotated accord-
ingly.

• Visual Distinction: Recursive spots display with a subtle border or badge indicating their
source micrograph.

5.8.3 Interacting with Recursive Spots

Recursive spots support full interactivity:

• Click to select: Clicking a recursive spot selects it and displays its properties.

• Right-click menu: Access the standard spot context menu, plus an option to Go to Source
Micrograph.

• Editing: Modifying a recursive spot updates the original spot on its source micrograph.
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• Hover information: Hovering displays a tooltip showing the spot name and source micro-
graph.

5.8.4 Filtering Recursive Spots

To manage which recursive spots are displayed:

• By depth: Use View > Recursive Spot Depth to limit how many levels deep to show (e.g.,
only immediate children, or all descendants).

• Bymicrograph: In the sample tree, toggle visibility of individual childmicrographs to show/hide
their spots.

• By spot type: Use the spot filter controls to show only points, lines, or polygons.

Note: Recursive spot rendering is computationally intensive for deeply nested hierarchies with
many spots. If performance is affected, consider limiting the recursive depth or hiding some child
micrographs.

5.9 Spot Navigation
The tabs at the top of the left Project Navigation Pane allow users to choose how they navigate
through the project. Once spots have been added to reference and associated micrographs, they
will appear in a nested structure within the panel, organized by micrograph and spot name.

Each spot name functions as a clickable hyperlink. Clicking a spot name will:

• Load and display the corresponding micrograph in the central viewing panel.

• Highlight the selected spot on the micrograph with a red outline, indicating it is active.

• Open the Spot Metadata toggle panel on the right side, showing detailed metadata for the
selected spot (see Figure 21).

This navigation structure enables efficient browsing between spots, micrographs, and related
metadata, helping users quickly access and update their observations across the project.

5.9.1 Keyboard Navigation

StraboMicro supports keyboard shortcuts for efficient spot navigation:

• Arrow Up/Down: Scroll the Project Navigation Pane up/down.

• Tab: Move to the next spot in the list.

• Enter: Open the selected spot for editing.

6 Data Entry and Observation Tools
StraboMicro provides a flexible framework for entering detailed observational data across mul-
tiple spatial contexts. Users can choose to associate data with an entire micrograph image, a
specific point (spot), a line representing a transect or trace, or a polygon outlining an area of
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interest. This structure allows observations to be scaled and shaped according to the nature of
the feature being studied—ranging from localized points and linear structures to broader areas
or the full thin section.

In addition, features and observations can be explicitly linked to previously defined mineralogical
or lithological classifications, supporting consistent interpretation and integrated analysis.

This section describes how to enter data at each spatial level and outlines the types of information
that can be recorded within each context.

6.1 Adding Data
To begin entering data:

• To add data to a micrograph: Click anywhere on the micrograph (not on a spot) to ensure
it is selected and active.

• To add data to a spot: Click the spot to select it. When active, the spot will be outlined in
red and its metadata panel will appear on the right (see Figure 25).

Figure 25: Spot Metadata panel showing selected spot with editable data fields.

Once the correct layer is selected (either amicrograph or spot), use theAdd Data field to add data.
You may either scroll through the list or use the search bar to find a specific option. Click the
desired data type and complete the corresponding form. Details for each data type are outlined
in the sections below.
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6.2 Types of Data
The following subsections provide descriptions and example screenshots for each type of data
entry modal available in StraboMicro.

6.2.1 Mineralogy and Lithology

Use this panel to document mineral constituents and lithologic characteristics of the sample.

• Mineralogy Tab: Add observed minerals and include optional notes. (See Figure 26.)

• Lithology Tab: Describe lithology and add supporting notes. (See Figure 27.)

Figure 26: Mineralogy data modal for entering observed minerals.
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Figure 27: Lithology data modal with fields for rock type and additional notes.

6.2.2 Grain Size, Shape, and SPO

These options allow detailed documentation of grain characteristics after mineralogy has been
entered.

• Grain Size: Enter modal or observed grain sizes. (See Figure 28.)

• Grain Shape: Record observed grain morphologies. (See Figure 29.)

• ShapePreferredOrientation (SPO):AddSPO information to describe directional alignments.
(See Figure 30.)
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Figure 28: Grain Size data modal with fields for entering quantitative grain size information.

Figure 29: Grain Shape modal showing morphology options.
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Figure 30: Shape Preferred Orientation (SPO) modal for documenting alignment of grains.

6.2.3 Fabrics

Fabrics can be classified as foliation, lineation, or fabric trace, and further characterized as either
primary or secondary, and penetrative or spaced.

When adding a fabric, you must choose a ”Define By” option. This selection determines which
additional metadata fields are available. The four options are:

• Composition

• Grain Size

• Grain Shape Orientation

• Cleavage (Solution Seam)

Each option enables a different data entry form, as shown in the figures below.
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Fabric Data Entry Form

Fabric defined by Composition
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Fabric defined by Grain Size

Fabric defined by Grain Shape

Fabric defined by Clevage
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Multiple fabrics may be defined for a single spot or micrograph if needed.

6.2.4 Clastic Deformation Bands

Clastic deformation bands can be characterized by several properties:

• Type: Select one or more from the following—cataclastic, dilation, shear, or compaction.

• Thickness: Specify the thickness of the band.

• Cement Type: Optionally note the type(s) of cement present.

These input fields appear in the clastic deformation band data modal.

Figure 31: Data entry modal for clastic deformation bands

6.2.5 Grain Boundaries and Contacts

All grain boundary and grain contact observations can be linked to previously defined mineralogy
or lithology for the selected image or spot, improving contextual understanding and interpretive
accuracy. A variety of grain boundarymorphologiesmay be selected using check boxes—multiple
selections are allowed as applicable. Boundary descriptors can be further refined using additional
criteria based on the initial selection.
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Figure 32: User interface options for grain boundary characterization, including point and line
spot tools, mineralogical associations, and descriptor check boxes.

6.2.6 Intragranular Structures

Intragranular structures are features that occur within individual mineral grains. When document-
ing these structures, users can specify the associated mineral by selecting from the previously
defined mineralogy or lithology list.
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Figure 33: Interface for adding Intragranular structures, showing the option to associate each
feature with a defined mineral.

6.2.7 Veins

Observational data related to veins within a thin section can be entered directly within this form.
Unlike other features, vein mineralogy is defined here and does not need to be selected from the
previously defined mineralogy or lithology list.

Users can document various characteristics of veins, including crystal shape, growthmorphology,
inclusion trails, kinematic indicators, and any additional relevant notes. This allows for detailed
description of vein textures and formation processes.

Back to Top 71



Figure 34: Interface for entering vein-related observations, includingmineralogy, morphology, and
kinematic features.

6.2.8 Pseudotachylyte

Pseudotachylyte data entry can be further refined by selecting from a set of observed features.
These options allow for detailed characterization of textures and components associated with
pseudotachylyte formation.

The figures below display all available metadata input options. The first figure shows the primary
metadata modal, followed by individual conditional fields that appear based on the selected fea-
ture. Observed features include:

• Matrix / groundmass

• (Micro)crystallites

• Survivor clasts

• Sulphide / oxide droplets

• Fabric

• Injection features

• Chilled margins

• Vesicles / amygdules
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Main Metadata Modal

Matrix / Groundmass
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(Micro) Crystallites

Survivor Clasts
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Sulphide / Oxide Droplets

Fabric

Injection Features

Chilled Margins
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Vesicles / Amygdules

Figure 35: Pseudotachylyte metadata entry options. Each screenshot shows the available fields
for a specific observed feature when selected in the form interface.

6.2.9 Folds

The FoldsModal provides a structured approach for describing key characteristics of folds. Users
can specify attributes such as:

• Custom labels

• Interlimb angle geometry

• Closure geometry

• Axial trace orientation

• Symmetry

• Fold style

• Continuity

• Facing direction

• Additional notes

This allows for consistent and comprehensive documentation of fold structures at the micro-
graph or spot level.
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Figure 36: Fold Modal: Fold Geometry
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Figure 37: Fold Modal: Fold Style and Continuity

6.2.10 Faults and Shear Zones

The Faults and Shear Zonesmodal allows users to input structural data directly ontomicrographs
or spatial points (spots). Users can define shear sense and specify associated shear sense indi-
cators. Additional metadata such as measured offsets and zone widths can be recorded, along
with any relevant observations entered into the freeform notes field.
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Figure 38: Screenshot of the Faults and Shear Zones data input modal.

6.2.11 Extinction Microstructures

Extinctionmicrostructuremetadata can be added to amicrograph or spot and includes attributes
such as the mineral phase, type of heterogeneous extinction, presence of subgrain structures,
extinction bands, and dislocations.

Multiple microstructures can be recorded in this section. For example, if a sample exhibits chess-
board extinction in quartz and patchy, undulose extinction in feldspar, both structures can be
documented as separate entries within the metadata.
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Figure 39: Screenshot of the Extinction Microstructures data input modal.

6.2.12 Fractures

Fractures can be recorded on amicrograph or spot using the Fracturesmodal. Themineralogy of
fractured phases does not need to be predefined—relevant minerals can be specified within the
modal itself. Users can also define the kinematic mode, input measured aperture or offset values
(with units), and indicate whether the fracture is sealed or healed using a checkbox. A freeform
notes field is available for additional observations.
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Figure 40: Screenshot of the Fractures data input modal.

6.2.13 Notes

The Notes field provides a freeform text area for entering and editing descriptive or contextual
information. This section supports extended text and is ideal for capturing observations, inter-
pretations, or any additional metadata that may not fit into predefined fields.
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Figure 41: Screenshot of the Notes text entry modal using the Add Data funtion in the metadata
pane.

Figure 42: Screenshot of the Notes text entry field under the micrograph view.

6.2.14 Associated Files

Users can attach external files to a micrograph or spot using the Associated Files modal. Files
can be added individually or in bulk by selecting multiple files at once.

Single File Import To add a single file, select the appropriate file type from a dropdown menu
(Figure 43), and an optional note can be attached. Notes are linked to the currently selected file
and will reset after each upload to ensure clear association.

Bulk File Import (New in StraboMicro) StraboMicro introduces a streamlined bulk import work-
flow for adding multiple associated files simultaneously:

• Multi-select files: Use Cmd+click (macOS) or Ctrl+click (Windows/Linux) in the file
picker to select multiple files at once.
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• Preview selected files: Selected files appear as removable chips in the dialog, allowing you
to review and remove individual files before import (see Figure 44).

• Shared metadata: A single file type and notes field applies to all selected files, streamlining
the process when importing files of the same category.

• Progress tracking: A progress indicator displays during import, showing the current file
being processed and overall completion status.

Clickable File Names (New in StraboMicro) Associated file names are now interactive links that
open the file using the system’s default application:

• Visual indicator: A small external link icon appears next to clickable file names to indicate
they can be opened.

• Edit dialog: File names in the Associated Files edit dialog are clickable links.

• Accordion summary: File names displayed in the collapsed accordion view are also click-
able for quick access.

• System integration: Clicking a file name launches the appropriate application based on file
type (e.g., PDFs open in Preview or Adobe Reader, images open in the default image viewer).
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Figure 43: Screenshot of the Associated Files modal, showing file selection and type dropdown.
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Figure 44: Bulk import interface showing multiple selected files as removable chips with shared
metadata fields.

6.2.15 Links

The Links section allows users to add one or more external or internal references. Multiple links
can be added as needed to connect relevant documents, datasets, or resources.
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Figure 45: Screenshot of the Links data entry interface.

7 Advanced Tools
StraboMicro introduces a suite of powerful analytical tools designed to accelerate petrographic
workflows. These advanced features enable systematic point counting, automated grain detec-
tion using both classical computer vision and AI-powered methods, rapid spot classification,
reusable metadata presets, quantitative grain size analysis, and multi-image comparison. This
section provides detailed documentation for each tool.

7.1 Point Count System
The Point Count System enables systematic modal analysis and petrographic studies through
structured point counting on micrographs. Access this tool via Tools > Point Count.
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Figure 46: Point Count interface showing the grid overlay, active counting point, and statistics
panel.

7.1.1 Purpose and Applications

Point counting is a fundamental technique in petrology for determining the modal composition
of rocks. The Point Count System provides:

• Systematic sampling across the micrograph using a customizable grid

• Rapid mineral identification using keyboard shortcuts

• Real-time statistics with counts and percentages

• Session persistence for long counting sessions

• Export capabilities for further analysis

7.1.2 Grid Generation

When initiating a point count session, configure the sampling grid:

• Grid Spacing: Set the distance between counting points in micrometers. Smaller spacing
yields more points but requires longer counting time.
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• Grid Offset: Optionally offset the grid origin to avoid edge effects or to target specific re-
gions.

• Random Offset: Enable slight random perturbation of grid points to reduce bias from peri-
odic textures.

• Point Count Target: Set a target number of points (e.g., 300, 500, 1000) commonly used in
petrographic studies.

7.1.3 Keyboard Navigation

Navigate efficiently through counting points using keyboard controls:

• Arrow Keys: Move to adjacent grid points (Up, Down, Left, Right)

• Tab, Space, or Enter: Advance to the next uncounted point

• Back Arrow: Return to the previous point

The current counting point is highlighted with a crosshair indicator, and the micrograph view au-
tomatically centers on the active point at high magnification.

7.1.4 Quick Mineral Shortcuts

Assign minerals to counting points rapidly using letter keys:

• A–Z Keys: Each letter can be mapped to a mineral in your project’s mineralogy list

• Customizable Mappings: Configure which mineral each key represents via the shortcut
configuration panel

• Common Defaults: Q=Quartz, F=Feldspar, M=Mica, O=Olivine, P=Pyroxene, etc.

• Visual Feedback: The assigned mineral appears briefly on screen after each keystroke

Figure 47: Keyboard shortcut configuration panel for mineral assignments.
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7.1.5 Statistics Panel

The statistics panel displays live counting data:

• Total Points: Number of points counted vs. total grid points

• Mineral Counts: Raw count for each identified mineral

• Percentages: Modal percentage for each mineral (with standard error)

• Progress Bar: Visual indicator of counting progress

7.1.6 Session Management

Point count sessions can be saved and resumed:

• Auto-Save: Sessions are automatically saved at regular intervals

• Resume Session: Reopen a previous session to continue counting

• Multiple Sessions: Maintain separate sessions for different areas or counting schemes

• Session Notes: Add notes to document counting criteria or observations

7.1.7 Export Results

Export point count data for external analysis:

• CSV Export: Tabular data with point coordinates, assigned minerals, and summary statis-
tics

• Include Metadata: Option to include micrograph metadata and session parameters

• Statistical Summary: Separate summary file with modal percentages and confidence inter-
vals

7.2 Grain Detection – OpenCV Method
The OpenCV grain detection method uses classical computer vision algorithms to identify and
outline grain boundaries automatically. Access via Tools > Grain Detection > OpenCV
Detection.

7.2.1 Algorithm Overview

The OpenCV method employs a multi-stage processing pipeline:

1. Preprocessing: Noise reduction and contrast enhancement

2. Canny Edge Detection: Identifies potential grain boundaries based on intensity gradients

3. Watershed Segmentation: Separates touching grains using marker-based watershed algo-
rithm

4. Contour Extraction: Converts segmented regions to polygon boundaries

5. Filtering: Removes artifacts based on size and shape criteria
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7.2.2 Preview Mode

Before committing detected grains to your project, use Preview Mode to evaluate results:

• Overlay Display: Detected boundaries shown as colored outlines on the micrograph

• Toggle View: Switch between original image and detection overlay

• Zoom Inspection: Examine detection quality at high magnification

• Statistics Preview: View count of detected grains and size distribution

7.2.3 Adjustable Parameters

Fine-tune detection by adjusting these parameters:

• Sensitivity: Controls the threshold for edge detection. Higher values detect more bound-
aries but may include noise.

• Minimum Grain Size: Excludes detected regions smaller than this threshold (in square mi-
crometers). Useful for filtering noise and inclusions.

• MaximumGrain Size: Excludes regions larger than this threshold. Helpful for ignoring back-
ground or matrix areas.

• Edge Threshold: Adjusts the Canny edge detector’s sensitivity to intensity gradients.

• Smoothing: Controls the degree of boundary smoothing applied to detected polygons.
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Figure 48: Parameter adjustment panel for OpenCV grain detection.

7.2.4 Creating Polygon Spots

After reviewing the detection results, commit detected grains to your project:

• Accept All: Creates polygon spots for all detected grains

• Selective Accept: Click individual detections to include/exclude them

• NamingConvention: Spots are automatically namedwith a configurable prefix (e.g., “Grain_001”)

• Default Properties: Set default color, transparency, and initial classification for new spots

7.3 Grain Detection – FastSAM AI Method
The FastSAM AI method uses a neural network trained for image segmentation, providing supe-
rior accuracy for complex textures and challenging grain boundaries. Access via Tools > Grain
Detection > AI Detection.

7.3.1 Technology Overview

The AI detection method leverages:
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• FastSAMNeural Network: A fast segment-anything model optimized for real-time segmen-
tation

• GrainSight Algorithm: Custom post-processing optimized specifically for thin section mi-
crographs

• ONNX Runtime: Cross-platform inference engine for model execution

• GPU Acceleration: Utilizes available GPU hardware for faster processing

7.3.2 Automatic Model Download

On first use, the AI model is automatically downloaded:

• Source: Models are hosted on HuggingFace for reliable distribution

• Size: Approximately 150 MB download

• Storage: Models are cached locally in the application data directory

• Updates: The application checks for model updates periodically

7.3.3 Advantages Over Classical Methods

The AI method excels in scenarios where classical methods struggle:

• Complex Textures: Better handling of porphyroblastic, poikiloblastic, and granoblastic tex-
tures

• Variable Lighting: More robust to uneven illumination and optical artifacts

• Subtle Boundaries: Detects low-contrast boundaries between similar minerals

• Intergrown Grains: Improved separation of interlocking crystal boundaries

7.3.4 Cross-Platform Support

The AI detection runs on all supported platforms:

• macOS: Native support for Apple Silicon (M1/M2/M3) and Intel processors

• Windows: Support for NVIDIA GPUs via CUDA, or CPU fallback

• Linux: Full support with GPU acceleration where available

7.3.5 GPU Acceleration

When available, GPU acceleration significantly improves processing speed:

• Automatic Detection: The application automatically detects and uses available GPU

• CPU Fallback: If no compatible GPU is found, processing uses CPU (slower but functional)

• Memory Management: Large images are processed in tiles to manage GPU memory

• Performance Indicator: Status bar shows whether GPU or CPU is being used
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7.4 Quick Edit Mode
Quick Edit Mode provides a streamlined interface for rapidly reviewing and classifying spots
after grain detection. Access via Edit > Quick Edit Spots or Cmd+Shift+Q (macOS) /
Ctrl+Shift+Q (Windows/Linux).

Figure 49: Quick EditMode interface showing spot navigation, classification states, and statistics
panel.

7.4.1 Purpose

After automated grain detection creates hundreds of polygon spots, Quick Edit Mode enables
rapid:

• Review of detected boundaries for accuracy

• Mineral classification assignment

• Deletion of incorrectly detected spots

• Batch operations on multiple spots

7.4.2 Keyboard Navigation

Navigate between spots efficiently:
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• Arrow Keys: Move to adjacent spots (based on spatial position)

• Tab: Advance to next unreviewed spot

• Shift+Tab: Return to previous spot

• Space: Mark current spot as reviewed (without classification)

• Delete/Backspace: Remove current spot

7.4.3 Quick Mineral Assignment

Assign minerals instantly using letter keys:

• A–Z Keys: Each letter maps to a mineral from your project’s mineralogy

• Configurable Mappings: Customize which mineral each key represents

• Auto-Advance: After assignment, automatically moves to next unreviewed spot

• Undo Support: Cmd+Z / Ctrl+Z reverses the last assignment

7.4.4 Statistics Panel

Track your progress through the review:

• Total Spots: Number of spots in the current micrograph

• Reviewed: Count and percentage of reviewed spots

• Remaining: Count of spots still requiring review

• By Mineral: Breakdown of classifications by mineral type

7.4.5 Lasso Selection

Select multiple spots for batch operations:

• Shift+Drag: Draw a lasso to select multiple spots

• Batch Edit: Right-click to edit all selected spots

• Batch Delete: Press Delete to mark all selected spots for removal

• Clear Selection: Press Escape to deselect all spots

7.5 Quick Apply Presets
Quick Apply Presets allow you to create reusablemetadata templates for rapid spot classification.
Access via Edit > Quick Apply Presets or Shift + Cmd + P on Mac or Shift + Ctrl +
P on Windows.
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Figure 50: Quick Apply Presets panel showing global and project-level presets with keyboard
shortcuts.

7.5.1 Purpose

When classifying spots, you often need to apply the same combination of metadata repeatedly.
Presets enable:

• One-click application of complex metadata combinations

• Consistent data entry across multiple spots

• Time savings when processing large numbers of grains

• Standardized classification schemes within a project or across projects

7.5.2 Preset Scope

Presets can be defined at two levels:

• Global Presets: Available across all projects. Useful for standard classifications (e.g., “Quartz
– Strained”, “Feldspar – Perthitic”)

• Project Presets: Specific to the current project. Useful for sample-specific categories or
temporary classifications
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7.5.3 Keyboard Shortcuts

In Quick Edit Mode, apply presets instantly:

• Keys 1–9: Apply preset 1 through 9 to the selected spot

• Preset Order: Arrange presets in the panel to assign their shortcut numbers

• Visual Indicator: Shortcut numbers displayed next to each preset name

7.5.4 Additive Merge Behavior

Presets merge with existing spot data:

• Non-Destructive: Applying a preset does not erase existing metadata

• Field Override: Preset values replace existing values only for fields included in the preset

• Field Addition: Preset values are added to empty fields

• Merge Lists: For list fields (e.g., associated minerals), preset values are appended

7.5.5 Batch Application

Apply presets to multiple spots at once:

• Multi-Select: Select multiple spots using lasso or Shift+click

• Apply to Selection: Use keyboard shortcut or right-click menu to apply preset

• Confirmation: Optional confirmation dialog for large batch operations

7.5.6 Creating Presets from Existing Spots

Build presets from already-classified spots:

• Select Spot: Choose a spot with the desired metadata configuration

• Create Preset: Go to Spot > Quick Spot Presets... in themenu, choose scope (global
or project). Click New Preset.

• Select Copy from Existing Spot: Review and edit the selected spot information.

• Name and Save: Provide a descriptive name and click Create

7.6 Grain Size Analysis
Grain Size Analysis provides quantitative morphometric measurements of polygon spots, en-
abling statistical characterization of grain populations. Access via Tools > Grain Size
Analysis or Cmd+Shift+A (macOS) / Ctrl+Shift+A (Windows/Linux).
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Figure 51: Grain Size Analysis interface showing per-grain metrics, population statistics, and vi-
sualization options.

7.6.1 Per-Grain Metrics

For each polygon spot, the following measurements are calculated:

• Area: Total area enclosed by the polygon boundary (in µm2 or mm2)

• Perimeter: Length of the polygon boundary

• Equivalent Diameter: Diameter of a circle with equivalent area: deq = 2
√

A/π

• Aspect Ratio: Ratio of major to minor axis of the best-fit ellipse

• Orientation: Angle of the major axis from horizontal (0–180°)

• Circularity: Measure of how circular the grain is: 4πA/P2 (1.0 = perfect circle)

7.6.2 Population Statistics

Aggregate statistics for the grain population:

• Mean: Average value for each metric

• Median: Middle value when sorted (less sensitive to outliers)

• Standard Deviation: Measure of spread around the mean

• Skewness: Measure of distribution asymmetry (positive = tail toward larger sizes)

• Sorting Coefficient: Measure of size distribution uniformity (well-sorted = narrow range)
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7.6.3 Rock Type Classification Schemes

Apply standard geological classification schemes:

Wentworth Scale (Sedimentary)

• Clay: < 4 µm

• Silt: 4–62 µm

• Sand (very fine to very coarse): 62 µm – 2 mm

• Gravel: > 2 mm

Igneous Classification

• Aphanitic: < 1 mm (grains not visible to naked eye)

• Phaneritic fine: 1–2 mm

• Phaneritic medium: 2–5 mm

• Phaneritic coarse: 5–30 mm

• Pegmatitic: > 30 mm

Metamorphic Classification

• Very fine grained: < 0.1 mm

• Fine grained: 0.1–1 mm

• Medium grained: 1–5 mm

• Coarse grained: 5–30 mm

• Very coarse grained: > 30 mm

7.6.4 Visualizations

Generate publication-ready charts:

Size Histogram

• Bin Configuration: Adjustable bin width and range

• Scale Options: Linear or logarithmic x-axis

• Classification Overlay: Optional vertical lines showing classification boundaries

• Normal Curve: Optional fitted normal distribution overlay
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Figure 52: Grain size histogram with Igneous classification boundaries overlaid.

Rose Diagram

• Orientation Distribution: Circular histogram of grain long-axis orientations

• Symmetry: Choose bidirectional (0–180°) or unidirectional (0–360°) plotting

• Mean Vector: Display mean orientation with confidence interval

• Fabric Strength: Calculate and display fabric intensity metrics

Figure 53: Rose diagram showing preferred orientation of grain long axes.

7.6.5 Mineral Grouping

Generate statistics grouped by mineral classification:

• Per-Mineral Statistics: Separate size distributions for each mineral phase

• Comparative Analysis: Side-by-side comparison of grain size by mineral

• Filter Options: Include or exclude specific minerals from analysis

7.6.6 Scope Options

Choose the scope of analysis:

• Current Micrograph: Analyze only spots on the active micrograph

• All Micrographs: Aggregate analysis across all micrographs in the sample
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• Selected Spots: Analyze only currently selected spots

7.6.7 Export Options

Export analysis results for external use:

• CSV Export: Complete per-grain measurements in tabular format

• Summary Statistics: Separate file with population statistics

• PDF Report: Formatted report including charts, statistics, and methodology

• Chart Images: Export individual charts as PNG or SVG

7.7 Image Comparator
The Image Comparator provides a full-screen multi-canvas view for comparing multiple micro-
graphs side by side. Access via Help > Image Comparator.

Figure 54: Image Comparator showing a 2x2 grid layout with four micrographs displayed simul-
taneously.

7.7.1 Purpose

The Image Comparator enables:

• Visual comparison of different imaging modes (PPL, XPL, BSE, etc.) of the same area

• Comparison of similar features across different samples

• Before/after comparison of processed images
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• Teaching and presentation with multiple images visible

7.7.2 Grid Layout

Configure the comparison view:

• Layout Options: 2x1 or 2x2 grid configurations

• Flexible Assignment: Chose micrographs from the project using the dropdowm list

7.7.3 Independent Pan and Zoom

Each canvas operates independently:

• Individual Navigation: Pan and zoom each image separately

• Zoom Controls: Mouse wheel or pinch gesture to zoom

• Pan Controls: Click and drag to pan the image

• Reset View: Double-click to fit image to canvas

7.7.4 Overlay Support

Display spot overlays in the comparator:

• Show Outlines: Toggle visibility of spot outlines on each canvas

• Per-Canvas Control: Enable overlays independently for each image

8 Sketch Overlay System

8.1 Introduction to Sketch Overlay
The Sketch Overlay system provides an “acetate overlay” capability for freeform annotations on
your micrographs. Think of it as placing a transparent acetate sheet over a physical thin section
slide and drawing on it with colored markers. You can add notes, highlight features, and mark up
the image without affecting the underlying scientific data.

Key Concept: Sketches are intentionally separate from the scientific spot annotation system.
While spots represent formal geological observations with structured metadata, sketches are
designed for informal markup and visual communication.

8.1.1 Common Use Cases

• Teaching and Presentations: Highlight features of interest when explaining concepts to
students or colleagues

• Informal Markup: Quickly mark areas for later investigation without creating formal spot
annotations

• Contextual Notes: Add text labels and reminders directly on the micrograph
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• Feature Highlighting: Use the marker tool to draw attention to specific regions

• Collaborative Review: Annotate micrographs for discussion with collaborators

• Draft Annotations: Sketch preliminary boundaries before creating formal polygon spots

Multiple sketch layers can be created per micrograph, allowing you to organize different types
of annotations separately—for example, one layer for grain boundaries and another for teaching
notes.

8.2 Entering and Exiting Sketch Mode
Sketch mode provides a dedicated drawing environment with specialized tools for freeform an-
notation.

8.2.1 Entering Sketch Mode

To enter sketch mode, use one of the following methods:

• Click the Sketch button in the main toolbar (Figure 55)

• Press the S key on your keyboard

When sketch mode is active:

• The normal spot tools (Point, Line, Polygon) are replaced with sketch tools

• The toolbar displays sketch-specific controls including tool selection, color picker, andwidth
slider

• The X3 button changes to Exit Sketch

• A visual indicator confirms you are in sketch mode

Figure 55: The Sketch button in the main toolbar. Click to enter sketch mode. Refer to Section
4.5.1 or 5.5.1 for more information about the main toolbar.

8.2.2 Exiting Sketch Mode

To exit sketch mode and return to normal operation:

• Click the Exit Sketch button in the toolbar

• Press the Escape key on your keyboard

All sketches remain visible after exiting sketch mode, but you cannot draw new strokes until you
re-enter sketch mode.
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8.3 Sketch Tools
Four drawing tools are available in sketch mode (Figure 56). Each tool is optimized for different
annotation tasks.

Figure 56: Sketch tools in the toolbar: Pen, Marker, Eraser, and Text.

8.3.1 Pen Tool

Keyboard shortcut: 1

The Pen tool creates precise, thin strokes ideal for detailed annotations and tracing features.

• Stroke width: 2–5 pixels (thin, precise lines)

• Opacity: 1.0 (fully opaque)

• Best for: Outlining grain boundaries, tracing fractures, detailed markup

How to use:

1. Select the Pen tool by clicking its icon or pressing 1

2. Click and drag on the micrograph to draw

3. Release the mouse button to complete the stroke

8.3.2 Marker Tool

Keyboard shortcut: 2

The Marker tool creates thick, semi-transparent strokes that work like a highlighter pen.

• Stroke width: 15–30 pixels (thick, visible strokes)

• Opacity: 0.4 (semi-transparent)

• Best for: Highlighting regions of interest, emphasizing features, drawing attention to areas

How to use:

1. Select the Marker tool by clicking its icon or pressing 2

2. Click and drag to highlight areas on the micrograph

3. The semi-transparent nature allows the underlying image to remain visible

8.3.3 Eraser Tool

Keyboard shortcut: 3

The Eraser tool removes strokes from the current sketch layer.

• Deletion mode: Deletes entire strokes (not partial segments)
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• Visual feedback: Strokes highlight when the eraser hovers over them

• Works on: Both pen and marker strokes in the active layer

How to use:

1. Select the Eraser tool by clicking its icon or pressing 3

2. Click on any stroke to delete it entirely

3. Alternatively, click and drag across multiple strokes to delete them in sequence

Note: The eraser deletes complete strokes. If you need to remove only part of a stroke, delete
the entire stroke and redraw the portion you want to keep.

8.3.4 Text Tool

Keyboard shortcut: 4 or T

The Text tool allows you to place text annotations directly on the micrograph.

• Placement: Click to position text at any location

• Editing: Text can be repositioned by dragging after creation

• Color: Uses the currently selected color from the color picker

How to use:

1. Select the Text tool by clicking its icon or pressing 4 (or T)

2. Click on the micrograph where you want to place the text

3. An input field appears—type your text and press Enter to confirm

4. The text is placed at the clicked location

To reposition text:

• With the Text tool active, click and drag existing text to move it

To edit existing text:

• Double-click on existing text to open the edit input field

• Modify the text and press Enter to confirm changes

8.4 Color and Width Controls
The sketch toolbar provides controls for customizing the appearance of your annotations (Fig-
ure 57).

8.4.1 Color Picker

The color swatch in the toolbar displays your current drawing color. Click the swatch to open the
full spectrum color picker.

• Full spectrum: Choose any color from the complete color spectrum
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Figure 57: Color picker and width slider in the sketch toolbar.

• Hex input: Enter specific hex color codes for precise color matching

• Applies to: Pen strokes, marker strokes, and text annotations

The color picker closes automatically when you click outside of it, or you can click the swatch
again to dismiss it.

8.4.2 Width Slider

The width slider adjusts the stroke width for the Pen and Marker tools.

• Range: 1–50 pixels

• Preview: A visual preview shows the current width and color

• Default values: Pen defaults to thin strokes; Marker defaults to thick strokes

Adjust the slider before drawing to set the width for subsequent strokes. Existing strokes are not
affected by width changes.

8.5 Layer Management
Each micrograph can have multiple sketch layers, allowing you to organize annotations by pur-
pose. Layers are managed through the Sketches tab in the right Properties panel (Figure 58).
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Figure 58: The Sketches tab in the Properties panel showing layer management controls.

8.5.1 Accessing Layer Management

1. Select a micrograph in the Sample Tree (left panel)

2. In the right Properties panel, click the Sketches tab

3. The panel displays all sketch layers for the current micrograph

8.5.2 Creating a New Layer

1. Click the + New Layer button at the bottom of the Sketches panel

2. A new layer is created with a default name (e.g., “Layer 1”)

3. The new layer becomes the active layer for drawing

8.5.3 Selecting the Active Layer

Click on a layer name in the list to make it the active layer. All new drawing operations will be
added to the active layer. The active layer is highlighted in the list.

8.5.4 Layer Visibility

Each layer has an eye icon indicating its visibility status:
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• Eye icon visible: Layer is shown on the micrograph

• Eye icon hidden/crossed: Layer is hidden

• Click the eye icon to toggle visibility

Quick visibility controls:

• Show All: Click to make all layers visible

• Hide All: Click to hide all layers

8.5.5 Renaming a Layer

To give a layer a descriptive name:

1. Double-click on the layer name in the list

2. The name becomes editable—type the new name

3. Press Enter or click outside to confirm the change

Tip: Use descriptive names like “Grain boundaries”, “Teaching notes”, or “Draft annotations” to
keep your layers organized.

8.5.6 Deleting a Layer

To delete a layer and all its contents:

1. Click the three-dot menu button (…) next to the layer name

2. Select Delete from the context menu

3. Confirm the deletion when prompted

Warning: Deleting a layer removes all strokes and text on that layer. This action can be undone
using Undo (Cmd+Z on Mac, Ctrl+Z on Windows).

8.6 Undo and Redo
The sketch system supports full undo and redo functionality, integrated seamlessly with themain
application’s undo system.

8.6.1 Undo

• macOS: Press Cmd+Z

• Windows/Linux: Press Ctrl+Z

Undo reverses the most recent action, including:

• Drawing a stroke (pen or marker)

• Deleting a stroke with the eraser

• Adding text
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• Deleting text

• Moving text

• Creating or deleting layers

8.6.2 Redo

• macOS: Press Cmd+Shift+Z

• Windows/Linux: Press Ctrl+Shift+Z

Redo restores an action that was previously undone.

Note: The undo/redo system works across both sketch operations and spot operations. For
example, you can undo a sketch stroke, then undo a spot creation, maintaining a unified history.

8.7 Exporting with Sketches
StraboMicro allows you to export micrograph images with your sketch annotations composited
on top.

8.7.1 Export Options

To export a view with sketches:

1. Go to File > Export View with Sketches

2. The Export dialog appears (Figure 59)

3. Configure the export options as described below

4. Click Export and choose a save location

8.7.2 Include/Exclude Options

The export dialog provides checkboxes to control what is included in the exported image:

• Micrograph image: Include or exclude the base micrograph

• Spot annotations: Include or exclude scientific spot overlays

• Sketch layers: Select which sketch layers to include (each layer has its own checkbox)

Tip: To export only the sketches on a transparent background (without the micrograph), uncheck
the “Micrograph image” option and select PNG format.

8.7.3 Format and Resolution

Format options:

• PNG: Supports transparency; recommended for sketches-only export

• JPEG: Smaller file size; no transparency support

Resolution options:
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Figure 59: Export dialog with sketch layer selection options.

• 1x: Standard resolution (matches screen display)

• 2x: High quality (recommended for presentations)

• 3x: Very high quality

• 4x: Maximum quality (for print or large displays)

8.8 Keyboard Shortcuts Summary
Table 2 summarizes all keyboard shortcuts for the sketch overlay system.

Table 2: Sketch Overlay Keyboard Shortcuts

Action macOS Windows/Linux

Enter sketch mode S S
Exit sketch mode Escape Escape
Pen tool 1 1
Marker tool 2 2
Eraser tool 3 3
Text tool 4 or T 4 or T
Undo Cmd+Z Ctrl+Z
Redo Cmd+Shift+Z Ctrl+Shift+Z
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8.9 Tips and Best Practices

8.9.1 Organizing Your Annotations

• Use separate layers for different purposes: Create distinct layers for teaching notes, draft
annotations, and final markup

• Name layers descriptively: Names like “Grain boundaries”, “Fracture traces”, or “Student
questions” help you find annotations quickly

• Use Hide All before presentations: Hide all sketch layers, then selectively show only the
layers relevant to your presentation

8.9.2 Choosing the Right Tool

• Pen tool: Best for precise work—tracing grain boundaries, marking small features, or creat-
ing detailed annotations

• Marker tool: Best for highlighting—drawing attention to regions, emphasizing features in
presentations, or creating visual hierarchy

• Text tool: Best for labels and notes—mineral names, measurement values, or reminders for
future analysis

8.9.3 Export Strategies

• For presentations: Export at 2x resolution with both micrograph and selected sketch layers

• For different audiences: Create separate exports with different layer combinations—one
for students, another for colleagues

• For overlay creation: Export sketches only (without micrograph) as PNG with transparency,
then composite in presentation software

8.9.4 Workflow Integration

• Draft before finalizing: Use sketches to draft polygon boundaries before creating formal
spot annotations

• Review workflow: Collaborators can add sketch annotations for discussion before formal
data entry

• Teaching workflow: Create a “Teaching” layer on frequently-used micrographs that can be
shown or hidden as needed

9 Troubleshooting and FAQs

9.1 Getting Help
If you experience any problems or issues with StraboMicro, please use the Help > Send Error
Reportoption to send issues directly to the StraboMicro developers. This interface automatically
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includes error logs which are essential for troubleshooting and debugging. Providing detailed
error logs helps our team quickly identify and resolve issues.

For additional support resources, refer to Section 1.5 for contact information and office hours.

9.2 Common Issues and Fixes
1. StraboMicro Crashes and Fails to Launch: If StraboMicro crashes and subsequently fails to

open, it is possible that the current project or cached data has become corrupted. In such
cases, it may be necessary to delete the application’s cached data.

To remove cached data, navigate to the StraboMicro2Data folder located in
your Documents directory, and delete the cached project folders within it.

Important: Before deleting any data, ensure you create a backup copy of the contents of
the StraboMicro2Data folder to preserve any data that may be recoverable.

2. Performance Issues with Large Images: StraboMicro 2.0 uses an advanced tiled rendering
system designed to handle large images (100MB+ TIFF files) efficiently. If you experience
performance issues:

• Clear the tile cache by navigating to your Application Support folder:

– macOS: ~/Library/Application Support/StraboMicro2/tile-cache

– Windows: %APPDATA%\StraboMicro2\tile-cache

• Delete the contents of the tile-cache folder

• Restart StraboMicro2—tiles will be regenerated as needed

3. Project Won’t Open: If a project fails to open or appears corrupted:

• Try using File > View Version History to restore a previous version of your
project

• Check if the .smz file has been moved, renamed, or corrupted

• Ensure the project file is not being accessed by another application

4. Overlay Images Appear Pixelated: StraboMicro uses a Level-of-Detail (LOD) rendering sys-
tem that dynamically loads image resolution based on zoom level and screen coverage.

• Zoom in closer to the image—higher resolution tiles will load automatically

• Wait a moment for tile loading to complete (a loading indicator may appear)

• Check if the original image was imported at full resolution

5. Spots Not Appearing on Image: If spots are not visible on your micrograph:

• Ensure View > Show Spot Labels is enabled

• Check if the spots are on a hidden layer in the layer panel

• For spots on child micrographs, try View > Show Recursive Spots to display spots
from associated images on the parent micrograph
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9.3 Frequently Asked Questions (FAQs)

Do I have to manually update StraboMicro?

No, StraboMicro updates automatically. Updates are downloaded in the background and installed
when you next launch the application. You will be notified when a new version has been installed.

Where is my project data stored?

Projects are stored in ~/Documents/StraboMicro2Data/. Each project has its own folder con-
taining the original images and a project.json file with all metadata and annotations. You can
also export projects as .smz files for backup or sharing.

Can I recover a previous version of my project?

Yes! StraboMicro automatically saves version history for your projects. Use File > View
Version History to see all saved versions and restore any previous state. This is useful if
you accidentally delete data or want to revert changes.

How do I change between dark and light themes?

Go to View > Theme and select your preferred option:

• Dark: Dark background with light text

• Light: Light background with dark text

• System: Automatically follows your operating system’s theme setting

What image formats are supported?

StraboMicro supports the following image formats:

• TIFF: Full support including large files (100MB+) with progressive loading

• JPEG: Standard support

• PNG: Standard support

• BMP: Standard support

Large TIFF files are handled efficiently through the tiled rendering system, allowing smooth navi-
gation even with very large micrographs.

Can I work offline?

Yes, all core features of StraboMicro work offline. Projects are saved locally on your computer.
The only features that require an internet connection are:

• Uploading projects to StraboSpot.org

• Downloading projects from StraboSpot.org

• Sending error reports
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• Checking for updates

How do I export my micrographs with annotations?

There are several export options available:

• File > Export All Images for batch export of all micrographs with annotations

• Use the download button on individual micrographs in the sample tree for single-image
export

• SVG vector export is available for annotations that need to be scaled or edited in vector
graphics software

What’s the difference between spots and sketches?

Spots and sketches serve different purposes in StraboMicro:

• Spots: Scientific annotations with structured metadata. Spots can contain detailed infor-
mation such as mineralogy, fabric characteristics, deformation features, and other geosci-
entific data. Spots are designed for rigorous documentation and can be uploaded to Stra-
boSpot.org.

• Sketches: Freeformdrawings for informalmarkup, teaching, or highlighting features. Sketches
include tools like pen, highlighter, and shapes. They are useful for quick annotations, pre-
sentations, or educational purposes but do not contain structured metadata.

How do I use keyboard shortcuts in Quick Edit mode?

Quick Edit mode provides efficient keyboard-driven editing of spot data:

• Arrow keys: Navigate between spots on the current micrograph

• Letter keys (A–Z): Quickly assign minerals from the mineral list

• Number keys (1–9): Apply saved presets to the current spot

• Enter: Save changes and advance to the next spot

• Escape: Exit Quick Edit mode

See Section 7 for detailed information on Quick Edit mode.

Can multiple people work on the same project simultaneously?

StraboMicro does not support simultaneous collaborative editing of the same project. However,
you can share projects with collaborators:

• Use the Share feature to give others a copy of your project

• Each copy is independent and changes are not synchronized

• For collaborative workflows, consider dividing work by sample or micrograph and merging
results later
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Why should I update StraboMicro?

Updating software is a simple but powerful way to protect your system, enjoy new features, and
ensure smooth operation. Updates may include:

• Bug fixes and stability improvements

• New features and enhancements

• Performance optimizations

• Security patches

Ignoring updates can lead to compatibility issues and may prevent you from opening projects
created with newer versions.

10 Appendices

10.1 Glossary of Terms

Abbreviations (Alphabetical)

• ACOM – Automated Crystal Orientation Mapping

• ADF – Annular Dark Field

• AFM – Atomic Force Microscopy

• BSE – Backscattered Electron

• CBED – Convergent Beam Electron Diffraction

• CL – Cathodoluminescence

• ECCI – Electron Channeling Contrast Imaging

• EBSD – Electron Backscatter Diffraction

• EDS – Energy Dispersive X-ray Spectroscopy

• EELS – Electron Energy Loss Spectroscopy

• FIB – Focused Ion Beam

• FSE – Forescattered Electron

• FTIR – Fourier Transform Infrared Spectroscopy

• HAADF – High-Angle Annular Dark Field

• IPF – Inverse Pole Figure (e.g., IPF-X, IPF-Y, IPF-Z)

• LACBED – Large Area Convergent Beam Electron Diffraction

• NBD – Nano Beam Diffraction

• PI – Principal Investigator
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• SAED – Selected Area Electron Diffraction

• SE – Secondary Electron

• SEM – Scanning Electron Microscopy

• STEM – Scanning Transmission Electron Microscopy

• TEM – Transmission Electron Microscopy

• TKD – Transmission Kikuchi Diffraction

• WDS – Wavelength-Dispersive X-ray Spectroscopy

StraboMicro Application Terms

• Dataset – A collection of related samples within a project

• Micrograph – A digital image captured through a microscope

• Overlay – An associated micrograph placed on top of a reference image

• Project – The top-level container for all data in StraboMicro

• Sample – A physical specimen containing one or more micrographs

• Sketch Layer – A transparent drawing layer for annotations

• Spot – A user-defined region of interest on a micrograph (point, line, or polygon)

• .smz File – StraboMicro project archive format (ZIP-based)
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10.2 Keyboard Shortcuts
StraboMicro provides extensive keyboard shortcuts for efficient workflow. On macOS, use Cmd;
on Windows/Linux, substitute Ctrl for Cmd.

General Shortcuts

Shortcut Action

Cmd+N New Project
Cmd+O Open Project
Cmd+S Save Project
Cmd+Shift+S Save Project As
Cmd+Z Undo
Cmd+Shift+Z Redo
Cmd+Q Quit Application

Navigation

Shortcut Action

Click and Drag Pan canvas
Scroll / Pinch Zoom in/out

View Options

Shortcut Action

Cmd+Shift+L Toggle Spot Labels
Cmd+Shift+O Toggle Micrograph Outlines
Cmd+Shift+R Toggle Recursive Spots (show spots from child micro-

graphs)

Drawing Tools

Shortcut Action

V Select tool (default selection mode)
P Point spot tool
L Line spot tool
G Polygon spot tool
M Measure tool
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Spot Editing

Shortcut Action

Double click Confirm geometry (complete polygon/line)
Escape Cancel editing

Sketch Mode

Shortcut Action

S Enter sketch mode
Escape Exit sketch mode
1 Pen tool
2 Marker tool
3 Eraser tool
4 or T Text tool

Quick Edit Mode

Quick Edit Mode provides rapid data entry across multiple spots. Activate with Cmd+Shift+Q.

Shortcut Action

Arrow Keys Navigate between spots
A--Z Assign mineral using single-letter shortcut
1--9 Apply preset to selected spot(s)
Enter Advance to next spot
Shift+Drag Lasso select multiple spots

Advanced Tools

Shortcut Action

Cmd+Shift+Q Open Quick Edit Mode
Cmd+Shift+P Open Quick Apply Presets panel
Cmd+Shift+G Open Grain Size Analysis tool

Reordering Items

Use these shortcuts when an item is selected in the Sample Tree or Spot List:

Shortcut Action

Cmd+Up Move item up in list
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Shortcut Action

Cmd+Down Move item down in list
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10.3 Data Schema Overview

Project Hierarchy

StraboMicro organizes data in a hierarchical structure:

Project
|-- Dataset
| |-- Sample
| |-- Micrograph (Reference Image)
| | |-- Spot (Point, Line, or Polygon)
| | |-- Associated Micrograph (Overlay)
| | |-- Spot
| | |-- Associated Micrograph (nested)
| | |-- ...
| |-- Micrograph
| |-- ...
|-- Dataset

|-- ...

• Project: Top-level container with metadata (name, description, PI, dates)

• Dataset: Logical grouping of related samples

• Sample: Physical specimen with associated micrographs

• Micrograph: Digital image with spatial registration data

• Spot: Region of interest with geological observations

.smz File Format

Projects are saved as .smz files, which are ZIP archives containing:

project.smz (ZIP archive)
|-- project.json # All project metadata and structure
|-- images/
| |-- <uuid>.tif # Original micrograph images
| |-- <uuid>.tif
| |-- ...
|-- thumbnails/
| |-- <uuid>.png # Generated thumbnail images
|-- sketches/
| |-- <uuid>.png # Sketch layer images
|-- cache/ # (Optional) Pre-generated tile cache

|-- <hash>/
|-- metadata.json
|-- tile_0_0.png
|-- ...
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project.json Structure

The project.json file contains the complete project data in JSON format:

{
"formatVersion": "2.0",
"projectId": "<uuid>",
"name": "Project Name",
"description": "...",
"created": "2024-01-15T10:30:00Z",
"modified": "2024-01-20T14:45:00Z",
"datasets": [
{
"datasetId": "<uuid>",
"name": "Dataset Name",
"samples": [
{

"sampleId": "<uuid>",
"name": "Sample Name",
"micrographs": [...],
"properties": {...}

}
]

}
],
"preferences": {...}

}

Compatibility

StraboMicro 2.0 maintains backward compatibility with legacy StraboMicro .smz files. When
opening a legacy file, it will be automatically upgraded to the new format. A backup of the original
file is created before migration.
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10.4 Licensing and Attribution

StraboMicro2 License

StraboMicro2 is released under the MIT License:

Permission is hereby granted, free of charge, to any person obtaining a copy of this software
and associated documentation files (the “Software”), to deal in the Software without restric-
tion, including without limitation the rights to use, copy, modify, merge, publish, distribute,
sublicense, and/or sell copies of the Software, and to permit persons to whom the Software
is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or sub-
stantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIA-
BILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT
OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

Third-Party Attributions

StraboMicro2 incorporates the following open-source libraries and models:

Component License Description

FastSAM Apache 2.0 Fast Segment Anything Model used
for AI-powered grain boundary detec-
tion. Developed by CASIA IVA Lab.

Konva.js MIT High-performance 2D canvas library
used for image rendering and interac-
tive drawing tools.

Sharp Apache 2.0 High-performance Node.js image pro-
cessing library used for TIFF decoding,
tile generation, and image manipula-
tion.

Electron MIT Framework for building cross-
platform desktop applications with
JavaScript, HTML, and CSS. Devel-
oped by GitHub/OpenJS Foundation.

React MIT JavaScript library for building user in-
terfaces. Developed by Meta.

Zustand MIT Lightweight statemanagement library
for React applications.
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Component License Description

SQLite Public Domain Embedded SQL database engine used
for mineral and lithology reference
data.
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