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1 Introduction

1.1 Overview of the StraboSpot Ecosystem?
The StraboSpot ecosystem is a suite of interconnected applications and software tools designed
to support the collection, management, integration, and sharing of field and laboratory data in the
geosciences. Its primary objective is to align data practices with the FAIR principles—Findable,
Accessible, Interoperable, and Reusable—by providing a unified system for managing multidisci-
plinary geologic data.

Developed through ongoing community input, the StraboSpot ecosystem includes several spe-
cialized applications: StraboField, which supports workflows in structural geology, petrology,
sedimentology, and tephra volcanology; StraboMicro, which facilitates microscopy-based geo-
science research; and StraboExperimental, which serves the experimental deformation commu-
nity. Each of these platforms utilizes controlled vocabularies developed by their respective sci-
entific communities to promote standardized data collection and to improve the discoverability
and interoperability of geologic data.

StraboSpot offersmore than just a centralized data repository—it also includes tools for capturing
and organizing field and laboratory observations, including images. The system is built around
the concept of spots, which represent observations applied across defined spatial scales. This
hierarchical structure allows users to nest observations from the regional to the microscopic
scale and to organize data and images according to their specific workflow needs. This flexible
framework enables users to capture and relate geologically complex information in a coherent
and connected manner.
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Figure 1: Overview of the StraboSpot ecosystem, three applications: StraboField, StraboMicro,
and StraboExperimental all connected to the database at StraboSpot.org

1.2 StraboMicro: A Platform for Microscopy-Based Geoscience
Research

StraboMicro is a desktop application specifically designed to support microscopy-based work-
flows in geoscience research. It provides a unique, image-centric organizational structure that
enables users to efficiently manage and annotate micrographs while preserving spatial relation-
ships and associated scientific metadata.

Core Functionality
StraboMicro allows users to create andmanage projects composed of geological samples. Each
sample includes:

• ReferenceMicrographs: Typically low-resolution, full-sample scans or stitched images that
provide contextual overviews.

• Associated Micrographs: Higher-resolution images of the same sample area, often col-
lected using different imaging techniques (e.g., polarized light, SEM, CL) or instruments.
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Geoscience-Specific Metadata
A key feature of StraboMicro is its ability to link spatial image data with detailed geoscientific
metadata. Users can annotate images with geologically meaningful information, such as:

• Project and dataset metadata

• Sample-specific metadata

• Micrograph-level metadata

• Mineralogy and lithology

• Grain and fabric characteristics

• Deformation structures (e.g., clastic deformation bands, faults, shear zones)

• Microstructural features (e.g., extinction patterns, grain boundaries)

• Veins, pseudotachylytes, folds, and fractures

• User notes, associated files, and external links

Spatial Annotation with Spots
Users can add spatial annotations called spots directly onto images. Spots may be defined as
points, lines, or polygons, each capable of storing customized observational data. This feature
supports rigorous documentation of spatially-resolved geological features.

Project Management and Data Sharing
StraboMicro is designed to facilitate the lifecycle of a research project:

• As new samples and observations are added, projects evolve in an organized and traceable
manner.

• Projects can be shared publicly online, allowing others to view and search the data.

• A Digital Object Identifier (DOI) can be generated for each project, ensuring proper citation
and long-term accessibility for publication and archiving purposes.

Benefits
StraboMicro enhances research productivity by:

• Keeping all images and data visually organized and spatially linked

• Enabling detailed, metadata-rich annotations of geological observations

• Supporting transparent, reproducible science with long-term data preservation

StraboMicro represents a significant advancement in the integration of image-based data and
geoscientific analysis, providing a robust platform for both research and education in the Earth
sciences.
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1.3 System Requirements
There are no specific hardware requirements for running the software. While higher-performance
systems may offer improved speed and responsiveness, the software does not mandate any
minimum system specifications.

1.4 Getting Help and Support
To get started with StraboMicro and to enhance your understanding of its features, we recom-
mend the following resources:

• YouTube Tutorials: Watch the official StraboMicro tutorial videos available on our YouTube
channel for step-by-step guidance.

• User Manual: Refer to this manual for detailed explanations of functions and features.

• Weekly Office Hours: Join our live support sessions held every Thursday from 1:00 PM to
3:00 PM CDT (UTC-5).
Register here: https://strabospot.org/help

• Email Support: For additional help, contact us at StraboSpot@gmail.com.

2 Installation and Setup

2.1 Creating a StraboSpot Account
To use StraboMicro and access associated data services, you must first create a StraboSpot
account. Follow the steps below to register:

1. Open your web browser and navigate to https://www.StraboSpot.org.

2. On the homepage, go to the Accountmenu in the top navigation bar and select Register.

3. Fill out the registration form with your full name and a valid email address. Please use a
real and accessible email address, as it will be used to verify your account and for future
communication.

4. After submitting the form, check your email inbox for a confirmation message from Stra-
boSpot.

5. Open the email and click the confirmation link to activate your account.

6. Once confirmed, you may log in to the StraboSpot website using your new credentials.

Note: If you do not receive the confirmation email within a few minutes, check your spam or junk
folder. If the issue persists, contact support at StraboSpot@gmail.com.

2.2 Downloading the Application
Follow the steps below to download the latest version of StraboMicro:
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1. Open your web browser and navigate to https://www.StraboSpot.org.

2. Log in to your account:

(a) On the homepage, click Account > Log In.

(b) Enter your login credentials.

3. Navigate to the StraboMicro download page:

(a) Select Software > StraboMicro > Download StraboMicro.

4. Download the most recent version of StraboMicro that is compatible with your operating
system and processor type (e.g., Intel vs. Apple Silicon for macOS).

2.3 Installing on Windows/macOS/Linux
Windows:

• Double-click the downloaded .exe file.

• Follow the on-screen instructions in the installer.

• After installation, launch the application from your Start Menu or desktop shortcut.

macOS:

• Open the downloaded .dmg file.

• Drag the StraboMicro application into the Applications folder.

• Launch the app. If prompted, allow the app to run in System Preferences under Security
& Privacy.

Linux:

• Extract the downloaded archive (e.g., .tar.gz).

• Navigate to the extracted folder in a terminal.

• Run the executable file using: ./StraboMicro

2.4 First-Time Setup
When launching StraboMicro for the first time:

• You may be prompted to grant necessary system permissions.

• The application will create a default folder named StraboMicroData in your Documents
directory. This folder stores project data and application cache.

• Ensure you are connected to the internet to enable automatic syncing with your StraboSpot
account and access to vocabulary updates.
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2.5 Updating the Software
If you are using a version of StraboMicro older than 1.2.9, automatic updates are not supported.
You must manually update to the latest version. After this update, the application will automati-
cally update going forward.

2.5.1 Checking Your StraboMicro Version

To verify your current version of the application:

1. Open the StraboMicro application.

2. Click the Help tab on the top navigation bar.

3. Select About StraboMicro.

4. Locate and confirm the application version number (e.g., 1.2.12).

• If your application is version 1.2.12 or later, no further action is required.

• If your version is older, follow the instructions below to update the application.

2.5.2 Manually Updating StraboMicro

1. Save your current project:

(a) Go to File > Save Project As… and choose a location on your computer.

2. (Optional) Upload your project to the StraboSpot server:

(a) Go to File > Upload Project.

(b) This uploads your project data to your StraboSpot account online.

(c) To verify the upload:

i. Open your browser and go to https://www.StraboSpot.org.

ii. Log in to your account (Account > Log In).

iii. Navigate to Account > My StraboMicro Data.

iv. Confirm that your project appears in the list with the correct upload date.

3. Delete previously cached data:

(a) Open your file explorer and navigate to your Documents directory.

(b) Locate the StraboMicroData folder.

(c) Select anddelete all folders insideStraboMicroData. This ensures compatibilitywith
the new version.

4. Reinstall the latest version:

(a) Repeat the steps in the Downloading the Application and Installing sections above.
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2.6 StraboMicro Instrument Catalog
The StraboMicro Instrument Catalog enables laboratories and research groups to associate in-
strumentation with current and past research projects. It is designed to reduce redundancy in the
data input process by storing instrument metadata, including:

• Instrument name

• Type and make

• Location

• Collection and post-processing software

• Detectors

• Additional notes

Once instrument information is entered into the catalog, any StraboMicro user can select that
instrument during data entry. Relevant metadata will automatically populate, streamlining the
workflow and ensuring consistency.

2.6.1 Becoming an Institution Principal Investigator (PI)

There are two ways to become a designated PI for an institution or laboratory:

1. During the ’Add New Sample’ upload process within StraboMicro, a link to add a new insti-
tution to the catalog can be found in the ’Select Instrument’ modal (Figure 2). Clicking the
link generates an email request — see Section 5.1.3 for details.

2. Alternatively, you may directly email the development team to request PI access. See Sec-
tion 1.4 for contact information.

Figure 2: Screenshot of the StraboMicro Select Instrument modal with the PI request link.
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2.6.2 Accessing and Updating the Instrument Repository

Once approved as a PI, you can manage instruments associated with your institution by visiting
www.strabospot.org. After logging in:

1. Navigate to your account.

2. Select My Instruments.

3. Access the StraboMicro Instrument Catalog, where you can view existing institutions and
instruments.

4. Use the provided links to add or edit instruments and institutional affiliations.

3 Manage StraboMicro Projects
StraboMicro projects differ slightly in structure from other StraboSpot applications. In StraboMi-
cro, each Project contains one or more Samples, which store the data.

To create a new project, open the StraboMicro desktop application. For installation details, see
Section 2: Installation and Setup.

From the File menu, choose either New Project or New Project from Field Data.

3.1 New Project
The New Project modal includes the following fields:

• Project Name*

• Start Date

• End Date

• Purpose of Study

• Team Members

• Area of Interest

• GPS Datum (default: WGS84)

• Magnetic Declination

• Notes

*Required field. After entering project details, you will be prompted to provide a Dataset Name.

Once complete, the interface automatically opens the New Sample modal—the same one used
when selecting Add / New Sample or Create New Sample (see Section 3.2).

3.1.1 New Project from Field Data

Navigation: File > New Project from Field Data
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This option creates a micrograph-based project using field data collected in StraboField.

Step 1: Select a Project

Opens theSelect a Project fromServermodal, listing all projects associatedwith your StraboSpot
account.

• Select a project and click Next.

Step 2: Select a Dataset

Choose a dataset within the selected project.

• All available datasets will be listed.

• Click a dataset to view associated samples.

Step 3: Choose a Sample

A searchable list of samples appears.

• Select a sample to begin the New Sample workflow.

• The process starts at the Load Reference Micrograph step (see Section 5.1.2).

Note: You may return later to import additional samples from the same dataset.

Metadata Auto-Population

Field samples automatically import the following metadata:

• Project and Dataset:

– Project Name, Start Date, GPS Datum, Magnetic Declination

– Last Modified Timestamp, Location, Dataset Name

• Sample:

– Sample ID/Name, Direct Link (StraboSpot.org), Location

– Sampling Purpose, Description, Material Type, Inplaceness

– Orientation Info, Size, Weathering, Notes

3.2 Open Existing Projects
StraboMicro allows you to open existing projects stored locally, in your StraboSpot account, or
shared via code or DOI.

3.2.1 Open a Local Project

To open a local ‘.smz‘ file:

1. Launch the StraboMicro application.
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2. Go to File � Open Local Project.

3. Navigate to the ‘.smz‘ file on your device.

4. Select the file and click Open.

3.2.2 Open a Remote Project

To open a project from your StraboSpot account:

1. Ensure you’re logged into StraboMicro.

2. Confirm your login at the top of the window (Logged in as [email]).

3. Go to File � Open a Remote Project.

4. Select the project and click Open.

3.2.3 Open a Project with a Share Code

To access a shared project:

1. Launch StraboMicro.

2. Go to File � Open a Project with a Share Code.

3. Enter the provided code and click Next.

See Section 3.7.2 for instructions on generating share codes.

3.3 Save Projects

3.3.1 Save to Local Device

To save the currently open project:

1. Go to File � Save Project, or use Ctrl+S (Windows/Linux) or Cmd+S (macOS).

2. Choose a destination folder.

3. Enter a file name with the .smz extension.

4. Click Save.

3.3.2 Upload to StraboSpot Server

To back up or share your project online:

1. Go to File � Upload Project.

2. Read the upload prompt:

Uploading your project backs up your data andmakes it accessible via StraboSpot.org.

3. If the project already exists, check Project Already Exists. Overwrite? to proceed.
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Note: StraboSpot.org retains version history. Frequent uploads are recommended to prevent
data loss and preserve project history.

3.4 Download Projects

3.4.1 Download .smz File

Method 1: From StraboSpot.org

1. Go to https://strabospot.org or access it via the StraboMicro app (File > Go to My
Data).

2. Log in and navigate to Account > My StraboMicro Data.

3. Click Options next to a project and select Download.

Method 2: From the Online Viewer

1. Go tohttps://strabospot.org, log in, and open the desired project viaMy StraboMicro
Data > View.

2. Click Download .SMZ in the top-right corner of the viewer.

3.4.2 Download Project as PDF

Method 1: From the Desktop App

1. Open your project in StraboMicro.

2. Go to File > Export Project as PDF.

3. Choose a destination folder.

Method 2: From the Online Viewer

1. Log in to https://strabospot.org.

2. Navigate to Account > My StraboMicro Data.

3. Open the project via Options > View.

4. Click Download PDF in the viewer.

Note: Projects must be uploaded to the server before they can be viewed or exported online.

3.4.3 Download JSON File

1. In StraboMicro, go to File > Export Project as JSON.

2. Select the destination folder.

3. The project will be saved as a JSON file.
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3.5 Download Project Images
Method 1: Export All Images

1. Go to File > Export All Images.

2. Select a destination folder.

3. The app will export a .zip containing all annotated micrographs.

Note: Images include all visible annotations at the time of export.

Method 2: Export Individual Annotated Images

1. Open a micrograph.

2. Click the Download button in the right panel.

Tip: To hide overlays in exports, use the Show/Hide icon before downloading.

3.6 Project Privacy
All projects are private by default in StraboMicro and StraboSpot. Users have full control over
project visibility and can change privacy settings at any time.

To update a project’s privacy, visit www.strabospot.org and log in. Navigate to your account,
then select My StraboMicro Data. A list of your projects will be displayed, each with a toggle
labeled Public? next to the project title.

If the toggle is switched to the right and appears green, the project is public and discoverable by
other users through the StraboSpot search interface. If your project is public and you would like
to make it private again, simply toggle the switch back to the left.

3.7 View and Share Projects

3.7.1 View in Online StraboMicro Viewer

1. Log in at https://strabospot.org.

2. Go to Account > My StraboMicro Data.

3. Click Options > View next to a project.

Ensure the latest version has been uploaded before viewing online.

3.7.2 Sharing Projects

The Share feature allows others to download your project using a short code—no login required.
Shared projects are independent copies; changes made by others do not affect your original.

Important: Share codes always retrieve the most recent uploaded version, not a snapshot. To
share a static version, use a .smz export.
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3.7.3 Generate a Share Code

1. Log in at https://strabospot.org.

2. Go to Account > My StraboMicro Data.

3. Click Options > Share next to the desired project.

4. Follow on-screen instructions to generate and copy the share code.

Note: Shared projects are not collaborative; each copy is independent.

3.8 DOI Creation
You can generate a DOI (Digital Object Identifier) for a static, citable version of your project. Once
created, the DOI links to a permanent snapshot, unaffected by future changes.

3.8.1 Generate a DOI

1. Log in at https://strabospot.org.

2. Go to Account > My StraboMicro Data.

3. Click Options > Get DOI for Project.

4. Follow the instructions to finalize DOI creation.

3.8.2 View a Project via DOI

1. Go to https://strabospot.org.

2. Navigate to Search > Search All StraboSpot Data.

3. Log in to your account.

4. Enter the DOI and click Add.

5. Select View next to the desired project.

4 User Interface Overview
StraboMicro features a user interface layout designed for intuitive navigation and efficient inter-
action with image data and metadata. The layout is organized into five main sections:
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Figure 3: Overview of the StraboMicro desktop application, descriptions for each section are
below.

• Project Viewer: Project navigation pane, where users can browse and select images within
a project. At the top of this pane, navigation tabs allow users to organize and view images
by Sample, Groups, Spots, or Tags. Selecting a different tab changes the organizational
structure displayed in the left pane, enabling flexible image navigation based on the user’s
workflow or data structure.

• Micrograph Viewer: Displays the currently selected image for viewing, annotation, and anal-
ysis.

• Metadata Pane: Metadata and information pane, where users can enter and manage struc-
tured data associated with each image. Data fields may be expanded by toggling arrow
icons to reveal additional information.

• Detailed Notes Section: A detailed notes section containing all notes from any of the fields
available for the selected micrograph or spot. This section updates according to whether a
micrograph or spot is selected.

• Menu Bar: Provides access to core application functions, including filemanagement, tools,
project settings, and help documentation.

This modular layout supports a streamlined and customizable workflow: navigate images on the
left, analyze them in the center, view or enter detailed data on the right, and quickly review meta-
data below the main image. The tabbed navigation system in the project viewer pane enhances
flexibility by allowing users to organize data according to their preferred context.
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4.1 StraboMicro Terminology
Understanding key terms used in StraboMicro will help users organize and interpret their image
data effectively. Two important concepts in the platform are Reference Micrographs and Asso-
ciated Micrographs.

Reference Micrograph

A Reference Micrograph is typically a low-resolution or stitched image—often a full thin section
scan—that serves as a spatial framework for other, more detailed images. It provides context and
scale for viewing and organizing high-resolution micrographs.

Associated Micrograph

An Associated Micrograph is any image that is spatially linked to a ReferenceMicrograph. These
images inherit the scale and spatial position defined by the reference image, allowing users to
relate high-magnification data (e.g., specific features, grains, or deformation structures) back to
the broader context of the thin section.

There is no limit to the number of nested Associated Micrographs. Users can create hierarchical
relationships among images at increasing levels of magnification or focus. This nested structure
supports the documentation of geologic features from the thin section scale down to the grain
or subgrain level.

Example Hierarchy

• Reference: Thin Section Scan

• Associated: Shear Zone Micrograph

• Associated: Specific Area within Shear Zone

• Associated: Image of Individual Grain

• Associated: EBSD Map of Grain

This hierarchical framework allows for the integration of multiple scales of observation, support-
ing detailed documentation and analysis within a consistent spatial context.

4.2 Project Viewer Pane: Project Navigation
The Project Viewer Pane in StraboMicro serves as the primary navigation area for organizing and
accessing project content, including samples, micrographs, groups, spots, and tags. The pane is
designed to support flexible workflows and customizable data organization.

Navigation Tabs

At the top of the Project Viewer Pane are four navigation tabs that control how data is displayed:
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• Samples (Default): Displays a hierarchical view of all samples, including reference and as-
sociated micrographs. Each sample is represented with a thumbnail image and can be
expanded to reveal its related micrographs.

• Groups: Displays groups of micrographs organized by user-defined themes or characteris-
tics. For example, users can group all micrographs showing chessboard extinction or those
containing garnet. Selecting a group filters and displays only the relevant micrographs,
streamlining analysis by feature or objective.

• Spots: Lists all labeled spots across the project. Each micrograph displays a hyperlink list
of its corresponding spots. Clicking a spot will load the related micrograph in the main
viewing window and show its metadata in the Metadata Pane.

• Tags: Displays all tags used in the project. Clicking a tag will show all associated spots,
each linked to its correspondingmicrograph. Selecting a spot from the list opens the related
micrograph in the main window and displays the tagged spot’s metadata in the Metadata
Pane.

Managing Samples and Micrographs

In the Samples tab, users can manage project data as follows:

• To add a new sample, click the + button next to Add/New Sample at the top of the Project
Viewer Pane.

• Click the sample name or the toggle arrow to its left to expand or collapse its associated
micrographs.

• Click the three-dot menu to the right of a sample name for the following options:

– Add a new reference micrograph

– Edit sample metadata

– Delete sample

• For each reference micrograph, a separate three-dot menu provides:

– Add to group(s)

– Edit micrograph metadata

– Delete micrograph

• Use the + button below the referencemicrograph to add an associatedmicrograph. Associ-
atedmicrographs inherit scale and spatial positioning from the reference and are displayed
on top of it in the main viewer.

• The eye icon toggles visibility of the associated micrograph.
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• The up/down arrows below the eye icon allow you to adjust the stacking order of associated
micrographs, moving them up or down in the visibility layer stack.

The StraboMicro application layout supports efficient navigation and flexible organization of com-
plex image datasets, enabling users to quickly locate, view, andmanagemicrographs and related
data within their project.

4.3 Micrograph Viewer: Image Display
The Micrograph Viewer in StraboMicro displays the micrograph currently selected in the Project
Viewer Pane. This is the primary workspace for viewing, analyzing, and annotating images.

Image Display and Scale

The displayed image includes a dynamic scale bar along the top and left edges. As the user
zooms in, zooms out, or pans across the image, the scale bar adjusts in real time to reflect the
current magnification level. This ensures accurate spatial interpretation at any zoom level.

At the bottom edge of the image window, the live coordinate readout displays the current position
of the cursor as X: [value] unit, Y: [value] unit. These coordinates correspond to the
location of the cursor on the image and are dynamically updated as the user moves the mouse.
The units used are based on the spatial scale defined when the image was initially uploaded.

Detailed Notes Section

Beneath themain image display is theDetailed Notes section. This section shows image-specific
metadata, notes, or other user-entered information related to the currently displayed micrograph.
It provides an accessible overview of contextual or observational data without needing to expand
individual metadata sections in the Metadata Pane.

This combination of responsive navigation, accurate spatial coordinates, and linked metadata
supports a seamless and precise workflow for image-based geologic analysis.

4.4 Metadata Pane Overview
The Metadata Pane displays metadata associated with the micrograph. This includes both the
information provided during themicrograph upload process and any additional metadata entered
by the user later.

4.4.1 Spot Tools

Between the center viewing window and the metadata pane are four vertical buttons (from top
to bottom):

Show/Hide Metadata Pane

Add Spot - Spots are useful for marking small, specific features
such as unique observations, individual grains, or regions ana-
lyzed with other instruments.

20



Add Line Spot - Line Spots are used to annotate linear features or
transects.

Add Polygon Spot - Polygon Spots allow users to define custom
shapes representing larger spatial areas of the micrograph.

Users can customize the color and transparency of all spot types via:

Spot Metadata > Edit > Spot Color > Custom Color > Edit Transparency

4.4.2 Toolbar Functions

Cursor Tool – Pan and select objects.

Zoom Out – Decrease magnification.

Zoom In – Increase magnification.

Measure Tool – Measure distances on the micrograph.

Re-Center – Reset view to original position.

Below the toolbar, themicrograph name and type are displayed, followed byDownload andDelete
buttons.

4.4.3 Data Entry Section

The data section begins below the micrograph name. A label, ``Add Data:'', appears above a
search bar where users can search for a data input type. Alternatively, a dropdownmenu provides
a list of available data pages.

There are 18 specialized data entry pages for geological metadata. These are described in detail
in Section 6: Data Entry. The available pages include:

• Project/Dataset Metadata

• Sample Metadata

• Micrograph Metadata

• Mineralogy/Lithology

• Grain Information

• Fabric Information

• Clastic Deformation Bands

• Faults and Shear Zones

• Extinction Microstructures

• Grain Boundary/Contact Information

• Vein Information

• Pseudotachylyte Information

• Fold Information

• Notes

• Associated Files

• Links
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4.5 Top Menu Overview
At the top-left banner of the StraboMicrowindow, you will find the main menu bar, similar to most
desktop applications. The primary menu categories include:

• StraboMicro

• File

• Account

• Help

Each menu contains a set of tools and options designed to manage your project, access your
account, or get help. The following is a summary of the options available in each menu.

StraboMicro Menu

• Quit StraboMicro – Exit the application.

File Menu

• New Project: Create a new local project. Local means the project will be saved to your
device until manually uploaded to the server.

• New Project From Field Data: Create a new StraboMicro project from StraboField data.

• Open Local Project: Open a StraboMicro project saved on your device.

• Open Remote Project: Open a project on your StraboSpot account.

• Open Shared Project: ”Due to the fact that StraboMicro project files can be quite large and
difficult to share, this interface has been created to allow StraboMicro users to share project
files using a small, simple code. To open a project shared by another user, simply enter the
code into the box below and click Next. The project file will be downloaded and opened
automatically. Please be aware that this system DOES NOT allow two users to work on
the same project. The project file downloaded using this code is unique and not tied to
the original file. To share your own project file with others, please visit the StraboSpot.org
website and go to My Data to share your uploaded StraboMicro Projects.”

• Close Project: Close the project, all changes are recorded locally.

• Save Project: Save the project locally to the users device.

• Save Project As…: Choose where to save a copy of the project

• UploadProject: Upload the StraboMicro project to your StraboSpot account online. Backing
up the project online

• Export Project as PDF: Creates a PDF file of the StraboMicro project including the images,
annotations, and metadata.

• Export Project as JSON: Create a JSON file of your StraboMicro project to be saved outside
of the StraboMicro file structure.

• Export All Images: Export all images in the StraboMicro project.
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• Preferences: Opens a new menu with image, view, and database options.

– Image Options: User can choose or change they image quality of the micrographs
added to the project in StraboMicro. If a user has a large number of micrographs, a
lower pixel size will preserve the speed and responsiveness of StraboMicro. High pixel
size will preserve higher image quality but may compromise the operating speed and
responsiveness of StraboMicro.

* ”TheMicrograph Image Quality setting controls how large images are handled when
adding them to a project. Due to existing software constraints, large images are
down-scaled to prevent memory constraints from being overwhelmed when load-
ing and displaying images. The Image Quality setting controls what size the long
edge of incoming images are scales down to. Below is a table of down-scaled
values. These numbers represent the size (in pixels) of the long axis of the down-
scaled image. Please note: that this setting only applies to newly added images.
Images added prior to changing this setting will remain at their former resolution.”

* Micrograph Image Quality Options:

· Low: 1000 Pixels

· Medium: 2500 Pixels

· High: 5000 Pixels

– View Options: The user can choose to show or hide red outlines on associated micro-
graphs nested within a reference micrograph. These outlines appear only when the
reference micrograph is selected and displayed in the main window. They indicate
the spatial position and size of each associated micrograph relative to the reference
image.

– DB Options (Database Options): User can define the Database Endpoint URL

Account Menu

• Go to My Data at StraboSpot.org: Automatically opens StraboSpot.org > Account > My
StraboMicro Data, it will display all StraboMicro projects. The My Data page contains the
Project Options:

– View

– Download

– Share

– Get DOI

– Delete

• Logout: Log out of the StraboSpot account with the current project.

Help Menu

• About StraboMicro: Displays the StraboMicro Software Version downloaded on the current
device and the MIT License.
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• Send Error Report: Sends a record of recent actions in StraboMicro to our developers to
help replicate the issues or errors users are experiencing.

• Clear Preferences: Resets all user preferences.

• Check for Software Update: Built in quick check for users to update the StraboMicro ver-
sion.

5 Sample and Spot Management

5.1 Add / New Sample
To begin adding a new sample, click the Add / New Sample button:

Figure 4: Add / New Sample button

The following sections outline each modal that appears during the new sample creation process.

5.1.1 Sample Info

The Sample Info modal collects descriptive metadata for your sample:

• Sample ID/Name*

• Location: Latitude and Longitude

• Main Sampling Purpose:

– Fabric / Microstructure

– Petrology

– Geochronology

– Geochemistry

– Active Eruption

– Other

• Description

• Material Type:

– Intact Rock

– Fragmented Rock

– Sediment

– Tephra

– Carbon or Animal
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Figure 5: Sample Info modal in the StraboMicro Desktop App

– Other

• Inplaceness: 1 = Float, 5 = Definitely in Place

• Oriented Sample: Yes / No

• Sample Size

• Weathering Degree: 1 = Highly Weathered, 5 = Fresh

• Notes

*Required field. Click Next to continue.

5.1.2 Load Reference Micrograph

Supported image formats: .jpeg, .png, .bmp, .tiff

• In the Load Reference Micrograph modal, click Browse to select and upload an image file
from your computer.

• Important: The image must include a clearly visible scale bar.
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• A note in the modal states: “You can add additional reference micrographs to this sam-
ple later.” This allows for uploading multiple images (e.g., lower magnification views) as
needed.

• Click Next to proceed to the Instrument and Image Info section.

Figure 6: Load Reference Micrograph modal

5.1.3 Instrument and Image Info – Enter or Import Metadata

In the Instrument and Image Info modal, you can:

• Use the Load Metadata from Previous Image option to import metadata from a previously
uploaded micrograph in the project.

• Use the Select... dropdown to choose an existing sample, which will auto-fill its Sample
ID/Name.

• Choose the instrument manually, or click Find Instrument in Database to search the shared
StraboMicro instrument repository.

Figure 7: Instrument and Image Info modal
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About the Instrument Repository:

• The StraboMicro Instrument Database allows institutional PIs to upload instrument meta-
data and operating parameters.

• Researchers can use these entries to auto-fill instrument fields and to identify equipment
at other institutions for potential collaboration.

• For additional details, see Section 2: The Instrument Repository.

Figure 8: Instrument selection popup showing available instruments from the StraboMicro repos-
itory

Requesting a New Institute Entry:

• If your institution is not listed, click the blue link at the top of themodal: “Need your institute
added to the database? Click here.”

• This generates an email to StraboSpot@gmail.com with the following template:

Hello,

Please add the following institute to the StraboMicro Apparatus Repository:

Lab or Facility Name:
Institute Name:

StraboSpot Account: *your account email address*

Thanks,

*your account name*

• Complete the Lab/Facility and Institute fields before sending.
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Metadata Input by Instrument Type

• If selecting a new instrument manually, choose from the following Instrument Types:

– Optical Microscopy

– Scanner

– Transmission Electron Microscopy (TEM)

– Scanning Transmission Electron Microscopy (STEM)

– Scanning Electron Microscopy (SEM)

– Electron Microprobe

– Fourier Transform Infrared Spectroscopy (FTIR)

– Raman Spectroscopy

– Atomic Force Microscopy (AFM)

– Other

Supported Image/Data Types per Instrument:

• OpticalMicroscopy: PlanePolarized Light, CrossPolarized Light, Reflected Light, 1/4 Lambda
Plate, Cathodoluminescence, Gypsum Plate.

• Scanner: No Polarizer, Plane Polarized, Cross Polarized, Other.

• TEM: Bright Field, Dark Field, Electron Diffraction (SAED, CBED, NBD, LACBED), EDS (with
periodic table element selection), ACOM, EDS Tomography.

• STEM: Bright Field, Dark Field, ADF, HAADF, EDS (element selection), EELS, CL (Panchro-
matic, Wavelength-Filtered, Spectroscopy).

• SEM: SE, BSE, FSE, EBSD (Euler, IPF-X/Y/Z, Band Contrast, Phase Map, Grain Boundaries),
TKD, ECCI, EDS/WDS (element selection), CL (Panchromatic,Wavelength-Filtered), FIB Imag-
ing.

• FTIR: False Color Map, Intensity Map.

• Raman Spectroscopy: False Color Map, Intensity Map.

• AFM Topography Image.

Metadata Entry Options

• Enter metadata manually or load from the StraboMicro instrument database.

• When applicable (e.g., for EDS, WDS), use the interactive periodic table to select elements.

• Input data for specific analytical modes such as EBSD, CL, or EELS where prompted.

Abbreviations (Alphabetical)

• ACOM – Automated Crystal Orientation Mapping

• ADF – Annular Dark Field

• AFM – Atomic Force Microscopy
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• BSE – Backscattered Electron

• CBED – Convergent Beam Electron Diffraction

• CL – Cathodoluminescence

• ECCI – Electron Channeling Contrast Imaging

• EBSD – Electron Backscatter Diffraction

• EDS – Energy Dispersive X-ray Spectroscopy

• EELS – Electron Energy Loss Spectroscopy

• FIB – Focused Ion Beam

• FSE – Forescattered Electron

• FTIR – Fourier Transform Infrared Spectroscopy

• HAADF – High-Angle Annular Dark Field

• IPF – Inverse Pole Figure (e.g., IPF-X, IPF-Y, IPF-Z)

• LACBED – Large Area Convergent Beam Electron Diffraction

• NBD – Nano Beam Diffraction

• PI – Principal Investigator

• SAED – Selected Area Electron Diffraction

• SE – Secondary Electron

• SEM – Scanning Electron Microscopy

• STEM – Scanning Transmission Electron Microscopy

• TEM – Transmission Electron Microscopy

• TKD – Transmission Kikuchi Diffraction

• WDS – Wavelength-Dispersive X-ray Spectroscopy

5.1.4 Instrument Data

Click Next to open the Instrument Data modal.

At the top of this modal, a message recommends uploading an instrument template via the Stra-
boSpotwebsite. This enablesmetadata fields to be auto-populated in future sessions. If possible,
ask the instrument’s Principal Investigator (PI) to submit a template at: https://strabospot.
org

Below themessage, the instrument type you previously selectedwill appear (e.g., Instrument Type:
Optical Microscopy).

Fields to Complete:

• Instrument Make: Brand and model

• Instrument Location: Institution and lab name

29

https://strabospot.org
https://strabospot.org


• Software (Data Collection): Application name and version

• Software (Post-Processing): Application name and version

• Notes: Optional field for any additional information

For certain instrument types, an additional Detectors section may appear, including:

• Type

• Make

• Model

Note: If you selected a preloaded instrument from the StraboMicro repository, these fields will be
auto-filled and do not require manual input.

Figure 9: Instrument Data modal in StraboMicro

5.1.5 Instrument Settings

ClickNext to continue the upload process. For certain instrument types, an additional Instrument
Settingsmodal will appear. The fields shown in thismodal are specific to the selected instrument.

For Scanning Electron Microscopy (SEM) or Electron Microprobe:

• Acceleration Voltage (kV)
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Figure 10: Instrument Settings modal example for Scanning Electron Microscopy (SEM). Fields
shown vary by instrument type.

• Beam Current (nA)

• Spot Size (µm)

• Aperture

• Working Distance (mm) replaces Camera Length

• Other fields may vary depending on instrument configuration

For Transmission Electron Microscopy (TEM):

• Acceleration Voltage (kV)

• Beam Current (nA)

• Spot Size (µm)

• Aperture

• Camera Length (mm)

For Scanning Transmission Electron Microscopy (STEM): Includes all TEM fields, plus:

• Camera Binning

• Dwell Time (s)

For Fourier Transform Infrared Spectroscopy (FTIR):

• Instrument Purged (Yes/No)

• Environment Purged (Yes/No)

• Aperture (µm2)

• Scan Time (s)

• Resolution (Hz)

• Spectral Resolution (cm-1)

• Wavenumber Range

• Averaging

• Background Composition (KCl, NaCl, Other)
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• Background Correction Frequency

• Notes

For Raman Spectroscopy:

• Excitation Wavelength (µm)

• Laser Power (mW)

• Spot Size (µm)

• Diffraction Grating (grooves/mm)

• Integration Time (s)

• Objective (magnification, e.g., 10x, 50x)

• Spatial Resolution (µm)

• Averaging

• Calibration

For Atomic Force Microscopy (AFM):

• Mode (Contact, Intermittent Contact [Tapping])

• Cantilever Stiffness (N/m)

• Tip Diameter (µm)

• Operating Frequency (kHz)

• Scan Dimensions (pixels)

• Scan Area (µm)

• Spatial Resolution (µm)

• Room Temperature (°C)

• Relative Humidity (%)

• Sample Temperature (°C)

Note: Only the fields relevant to the selected instrument type will be displayed. If metadata was
preloaded via the instrument repository, these fields may already be filled in.

5.1.6 Micrograph Metadata

In this section, you will be prompted to enter the following metadata:

• Name: A text field to assign a unique name or identifier to the micrograph.

• Polished: A checkbox indicating whether the sample surface is polished.

– If selected, an additional field will appear to describe the polishing method or details.

• Notes: An optional text field for any additional observations or comments.
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Figure 11: MicrographMetadatamodal displaying fields for Name, Polished checkbox, andNotes.

5.1.7 Orientation of Reference Micrograph

Define the orientation of the referencemicrograph by selecting one of the following three options:

1. Unoriented Thin Section

• No additional metadata is required.

2. Trend and Plunge of Edges / Strike and Dip of Surface

• This option requires users to define the micrograph orientation using geologic mea-
surements.

• A message at the top of the modal instructs:

“ProvideTWOof THREE: Select the arrowon each edge that represents a lower
hemisphere plunge, and enter the trend andplunge information and/or provide
the strike and dip of the thin section.”

• Input fields include:

– Trend and Plunge values for both horizontal and vertical axes

– Corner selection to define orientation direction

– Strike and Dip of the thin section surface
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Figure 12: Example modal for entering Trend and Plunge or Strike and Dip orientation data.

3. Fabric Reference Frame (XZ, YZ, XY Thin Sections)

• Select the orientation of the thin section based on the structural fabric:

– XZ – Lineation (X) and foliation normal (Z)

– YZ – Perpendicular to lineation (Y) and foliation normal (Z)

– XY – Lineation (X) and perpendicular to lineation (Y) in the foliation plane

• Required metadata:

– Foliation Orientation: Strike and Dip (Geographic coordinates)

– Lineation Orientation: Either

* Trend and Plunge, or

* Rake (Right-Hand Rule, 1–180°)

– Look Direction: Specify whether the image was taken:

* Looking down through the micrograph (toward the lower hemisphere), or

* Looking up through the micrograph (toward the upper hemisphere)
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– A note in the modal provides clarification:

“When viewing the reference micrograph, are you looking toward the lower
hemisphere or upper hemisphere in geographic coordinates?”

Figure 13: Fabric Reference Framemodal with XZ/YZ/XY options and orientationmetadata fields.

5.1.8 Define Top Corner (Fabric Reference Frame Only)

If you selected the Fabric Reference Frame option, an additional modal will appear: Define Top
Corner.

• The micrograph image is displayed with clickable buttons at each corner.

• Select the corner that is highest in geographic coordinates by clicking the corresponding
button.

5.1.9 Set Micrograph Scale and Location

After defining the orientation, the next step is to set the scale and spatial information for the mi-
crograph. This involves selecting one of the available scaling methods. Based on your selection,
the system will guide you through a corresponding follow-up modal to complete the location and
scale setup.
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Choose one of the following scale-setting methods:

1. Trace Scale Bar

• Use drawing tools to trace a line across the visible scale bar in the image.

• Tools include:

– Pointer Tool: Move or reposition the micrograph.

– Line Tool: Click once to begin drawing a line, and click again to finish.

• The pixel length is automatically calculated. Enter the corresponding real-world length
and select the correct unit (µm, mm, cm).

• Use mouse scroll to zoom in/out on the image.

• Optionally, check Flip Image to mirror the micrograph across the vertical axis.

Figure 14: Example: Trace Scale Bar modal

2. Pixel Conversion Factor

• Enter the pixel-to-distance conversion factor directly.

• Input the number of pixels and its real-world equivalent (units: µm, mm, cm).

• Flip Image option is also available.

Figure 15: Example: Pixel Conversion Factor modal

3. Provide Width/Height of Image

• Enter the total width and height of the image manually.

• Select the units from the dropdown.

• The Flip Image checkbox is included.

Figure 16: Example: Provide Width/Height modal

4. Copy Size from Existing Micrograph
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• Select a previously uploaded micrograph to copy its size.

• A dropdown menu lists all available micrographs.

• Flip Image option is also included.

Figure 17: Example: Copy Size from Existing Micrograph modal

Once the selected method is completed, a corresponding modal will prompt you to finalize the
micrograph’s location and scale. The fields shown in this final step directly correspond to your
earlier selection. After all required inputs are entered, click Finish to add the referencemicrograph
to the sample and save it to the project.

5.2 Spot Management
Spots are a central concept in StraboSpot, representing spatial observations atmultiple scales. In
StraboMicro, a spot might represent a grain, a mineral inclusion, or any localized feature within a
thin section or micrograph. This multiscale framework enables users to document observations
consistently, from the field to the microscope.

5.3 Adding a New Spot
Once amicrograph has been loaded, users can add new spots directly onto the image to annotate
and analyze specific features. Each spot is associated with editable metadata, accessible via the
right panel, which includes information entered during micrograph upload and any user-provided
observations.

5.3.1 Spot Tools

To the right of the central viewing window, a vertical toolbar provides access to spot creation
tools:

Show/Hide Right Panel

Add Spot – For marking discrete features such as mineral grains
or points of interest.

Add Line Spot – For linear features such as foliations, transects,
or crystal boundaries.

Add Polygon Spot – For selecting custom regions like mineral
zones or deformation domains.
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5.3.2 How to Add a Spot

Follow these steps to add a spot to a micrograph:

1. Determine the appropriate spot type: Choose whether you are marking a point, a line fea-
ture, or an area (polygon).

2. Click the corresponding button in the vertical toolbar to activate that spot mode. The se-
lected tool will highlight in red.

3. Navigate the micrograph: Use click-and-drag to move the image, scroll to zoom, or use the
zoom buttons in the top-right corner.

4. Add the spot to the micrograph:

• Point: Click once to place the spot.

• Line: Click to add vertices. Double-click the final point to complete the line.

• Polygon: Click to define each corner. The shape appears as you add points. Double-
click the last vertex to close the shape.

5. Fill out spot information: Once the spot is placed, a configuration modal appears (see Fig-
ure 18).

6. Enter metadata: Provide the spot name, label color, spot color, transparency, and optional
notes.

7. Save the spot: After saving, the spot appears in the micrograph and is listed in the Spot
Metadata panel on the right side (see Figure 23).

8. Edit the spot: Click the pencil icon (see Figure 21) in the metadata panel to make changes
or add more details.

Tip: If you activate a spot tool but decide not to place a spot, click the Cursor tool (top-right) to
exit spot mode and return to default navigation.

5.3.3 Spot Options

After selecting a spot type—Point, Line, or Polygon—a configuration modal appears (Figure 18)
allowing you to define the following:

• Spot Name: Assign a unique label.

• Label Color: Defines the text color for the spot label on the micrograph.

• Spot Color: Controls the fill or line color of the spot.

• Transparency: Adjust the opacity using a slider.

• Notes: Optional free-text field for observations, interpretations, or measurements.

All spot types can be customized further by navigating to:

Spot Metadata > Edit > Spot Color > Custom Color > Edit Transparency
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Figure 18: Add Spot configuration modal showing customization options for spot name, label
color, spot color, transparency, and notes.
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Figure 19: Color and transparency selection interface.

Figure 20: Spot Metadata panel showing saved spot entries and editable fields.

Figure 21: Pencil icon used to edit spot metadata.

5.4 Spot Navigation
The tabs at the top of the left panel allow users to choose how they navigate through the project.
Once spots have been added to reference and associated micrographs, they will appear in a
nested structure within the panel, organized by micrograph and spot name.

Each spot name functions as a clickable hyperlink. Clicking a spot name will:

• Load and display the corresponding micrograph in the central viewing panel.

• Highlight the selected spot on the micrograph with a red outline, indicating it is active.
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• Open the Spot Metadata toggle panel on the right side, showing detailed metadata for the
selected spot (see Figure 23).

This navigation structure enables efficient browsing between spots, micrographs, and related
metadata, helping users quickly access and update their observations across the project.

Figure 22: Spot navigation panel showing nested structure and clickable spot names

6 Data Entry and Observation Tools
StraboMicro provides a flexible framework for entering detailed observational data across mul-
tiple spatial contexts. Users can choose to associate data with an entire micrograph image, a
specific point (spot), a line representing a transect or trace, or a polygon outlining an area of
interest. This structure allows observations to be scaled and shaped according to the nature of
the feature being studied—ranging from localized points and linear structures to broader areas
or the full thin section.

In addition, features and observations can be explicitly linked to previously defined mineralogical
or lithological classifications, supporting consistent interpretation and integrated analysis.

This section describes how to enter data at each spatial level and outlines the types of information
that can be recorded within each context.
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6.1 Adding Data
To begin entering data:

• To add data to a micrograph: Click anywhere on the micrograph (not on a spot) to ensure
it is selected and active.

• To add data to a spot: Click the spot to select it. When active, the spot will be outlined in
red and its metadata panel will appear on the right (see Figure 23).

Figure 23: Spot Metadata panel showing selected spot with editable data fields.

Once the correct layer is selected (either a micrograph or spot), use the dropdown menu in the
right-hand panel to choose a data type. You may either scroll through the list or use the search
bar to find a specific option. Click the desired data type and complete the corresponding form.
Details for each data type are outlined in the sections below.

6.2 Types of Data
The following subsections provide descriptions and example screenshots for each type of data
entry modal available in StraboMicro.

6.2.1 Mineralogy and Lithology

Use this panel to document mineral constituents and lithologic characteristics of the sample.

• Mineralogy Tab: Add observed minerals and include optional notes. (See Figure 24.)

• Lithology Tab: Describe lithology and add supporting notes. (See Figure 25.)
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Figure 24: Mineralogy data modal for entering observed minerals.

Figure 25: Lithology data modal with fields for rock type and additional notes.

6.2.2 Grain Size, Shape, and SPO

These options allow detailed documentation of grain characteristics after mineralogy has been
entered.

• Grain Size: Enter modal or observed grain sizes. (See Figure 26.)

• Grain Shape: Record observed grain morphologies. (See Figure 27.)

• ShapePreferredOrientation (SPO):AddSPO information to describe directional alignments.
(See Figure 28.)
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Figure 26: Grain Size data modal with fields for entering quantitative grain size information.
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Figure 27: Grain Shape modal showing morphology options.
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Figure 28: Shape Preferred Orientation (SPO) modal for documenting alignment of grains.

6.2.3 Fabrics

Fabrics can be classified as foliation, lineation, or fabric trace, and further characterized as either
primary or secondary, and penetrative or spaced.

When adding a fabric, you must choose a “Define By” option. This selection determines which
additional metadata fields are available. The four options are:

• Composition

• Grain Size

• Grain Shape Orientation

• Cleavage (Solution Seam)

Each option enables a different data entry form, as shown in the figures below.
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Figure 29: Fabric defined by composition
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Figure 30: Fabric defined by grain size
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Figure 31: Fabric defined by grain shape orientation
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Figure 32: Fabric defined by cleavage (solution seam)

Multiple fabrics may be defined for a single spot or micrograph if needed.

6.2.4 Clastic Deformation Bands

Clastic deformation bands can be characterized by several properties:

• Type: Select one or more from the following—cataclastic, dilation, shear, or compaction.

• Thickness: Specify the thickness of the band.

• Cement Type: Optionally note the type(s) of cement present.

These input fields appear in the clastic deformation band data modal.
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Figure 33: Data entry modal for clastic deformation bands

6.2.5 Grain Boundaries and Contacts

All grain boundary and grain contact observations can be linked to previously defined mineralogy
or lithology for the selected image or spot, improving contextual understanding and interpretive
accuracy. A variety of grain boundarymorphologiesmay be selected using check boxes—multiple
selections are allowed as applicable. Boundary descriptors can be further refined using additional
criteria based on the initial selection.
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Figure 34: User interface options for grain boundary characterization, including point and line
spot tools, mineralogical associations, and descriptor check boxes.

6.2.6 Intragranular Structures

Intragranular structures are features that occur within individual mineral grains. When document-
ing these structures, users can specify the associated mineral by selecting from the previously
defined mineralogy or lithology list.
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Figure 35: Interface for adding Intragranular structures, showing the option to associate each
feature with a defined mineral.

6.2.7 Veins

Observational data related to veins within a thin section can be entered directly within this form.
Unlike other features, vein mineralogy is defined here and does not need to be selected from the
previously defined mineralogy or lithology list.

Users can document various characteristics of veins, including crystal shape, growthmorphology,
inclusion trails, kinematic indicators, and any additional relevant notes. This allows for detailed
description of vein textures and formation processes.
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Figure 36: Interface for entering vein-related observations, includingmineralogy, morphology, and
kinematic features.

6.2.8 Pseudotachylyte

Pseudotachylyte data entry can be further refined by selecting from a set of observed features.
These options allow for detailed characterization of textures and components associated with
pseudotachylyte formation.

The figures below display all available metadata input options. The first figure shows the primary
metadata modal, followed by individual conditional fields that appear based on the selected fea-
ture. Observed features include:

• Matrix / groundmass

• (Micro)crystallites

• Survivor clasts

• Sulphide / oxide droplets
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• Fabric

• Injection features

• Chilled margins

• Vesicles / amygdules

Main Metadata Modal

Matrix / Groundmass
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(Micro) Crystallites

Survivor Clasts

Sulphide / Oxide Droplets

Fabric

Injection Features

56



Chilled Margins

Vesicles / Amygdules

Figure 37: Pseudotachylyte metadata entry options. Each screenshot shows the available fields
for a specific observed feature when selected in the form interface.

6.2.9 Folds

The FoldsModal provides a structured approach for describing key characteristics of folds. Users
can specify attributes such as:

• Custom labels

• Interlimb angle geometry

• Closure geometry

• Axial trace orientation

• Symmetry

• Fold style

• Continuity

• Facing direction

• Additional notes

This allows for consistent and comprehensive documentation of fold structures at the micro-
graph or spot level.
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Figure 38: Fold Modal: Fold Geometry
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Figure 39: Fold Modal: Fold Style and Continuity

6.2.10 Faults and Shear Zones

The Faults and Shear Zonesmodal allows users to input structural data directly ontomicrographs
or spatial points (spots). Users can define shear sense and specify associated shear sense indi-
cators. Additional metadata such as measured offsets and zone widths can be recorded, along
with any relevant observations entered into the freeform notes field.
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Figure 40: Screenshot of the Faults and Shear Zones data input modal.

6.2.11 Extinction Microstructures

Extinctionmicrostructuremetadata can be added to amicrograph or spot and includes attributes
such as the mineral phase, type of heterogeneous extinction, presence of subgrain structures,
extinction bands, and dislocations.
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Multiple microstructures can be recorded in this section. For example, if a sample exhibits chess-
board extinction in quartz and patchy, undulose extinction in feldspar, both structures can be
documented as separate entries within the metadata.

Figure 41: Screenshot of the Extinction Microstructures data input modal.

6.2.12 Fractures

Fractures can be recorded on amicrograph or spot using the Fracturesmodal. Themineralogy of
fractured phases does not need to be predefined—relevant minerals can be specified within the
modal itself. Users can also define the kinematic mode, input measured aperture or offset values
(with units), and indicate whether the fracture is sealed or healed using a checkbox. A freeform
notes field is available for additional observations.
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Figure 42: Screenshot of the Fractures data input modal.

6.2.13 Notes

The Notes field provides a freeform text area for entering and editing descriptive or contextual
information. This section supports extended text and is ideal for capturing observations, inter-
pretations, or any additional metadata that may not fit into predefined fields.

Figure 43: Screenshot of the Notes text entry field.

6.2.14 Associated Files

Users can attach external files to a micrograph or spot using the Associated Files modal. Files
are added one at a time by selecting the appropriate file type from a dropdown menu (Figure 44),
and an optional note can be attached to each file. Notes are linked to the currently selected file
and will reset after each upload to ensure clear association.
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Figure 44: Screenshot of the Associated Files modal, showing file selection and type dropdown.

6.2.15 Links

The Links section allows users to add one or more external or internal references. Multiple links
can be added as needed to connect relevant documents, datasets, or resources.

d

Figure 45: Screenshot of the Links data entry interface.

7 Troubleshooting and FAQs
If you experience any problems or issues with StraboMicro, please use the ”Send Error Report”
option available in the Help menu, outlined in Section 4.5. This interface enables users to send is-
sues directly to StraboMicro developers, including error logs which are essential for troubleshoot-
ing and debugging.
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7.1 Common Issues and Fixes
1. StraboMicro Crashes and Fails to Launch: If StraboMicro crashes and subsequently fails

to open, it is possible that the current project has become corrupted. In such cases, it may
be necessary to delete the application’s cached data.

To remove cached data, navigate to the StraboMicroData folder located in your
Documents directory, and delete all subfolders within it.

Important: Before deleting any data, ensure you create a backup copy of the contents of
the StraboMicroData folder to preserve any data that may be recoverable.

2. StraboMicro will not update: ”Installation Failed. Failed to install shortcut.” If you receive
this error, try unchecking the ’Add Desktop Shortcut’ checkbox. See Figure 46 for an exam-
ple of the error.

Figure 46: Add Desktop Shortcut Permissions Error: unable to add desktop shortcut due to com-
puter permissions, therefore unable to update the StraboMicro application.

7.2 Frequently Asked Questions (FAQs)

Do I have to manually update StraboMicro every time a new version is released?

No, if you are using version 1.2.9 or newer the StraboMicro desktop application will automatically
update.

64



Why should I update StraboMicro?

Updating software is a simple but powerful way to protect your system, enjoy new features, and
ensure smooth operation. Ignoring updates can lead to security risks, performance issues, and
compatibility problems over time.

8 Appendices

8.1 Glossary of Terms

Abbreviations (Alphabetical)

• ACOM – Automated Crystal Orientation Mapping

• ADF – Annular Dark Field

• AFM – Atomic Force Microscopy

• BSE – Backscattered Electron

• CBED – Convergent Beam Electron Diffraction

• CL – Cathodoluminescence

• ECCI – Electron Channeling Contrast Imaging

• EBSD – Electron Backscatter Diffraction

• EDS – Energy Dispersive X-ray Spectroscopy

• EELS – Electron Energy Loss Spectroscopy

• FIB – Focused Ion Beam

• FSE – Forescattered Electron

• FTIR – Fourier Transform Infrared Spectroscopy

• HAADF – High-Angle Annular Dark Field

• IPF – Inverse Pole Figure (e.g., IPF-X, IPF-Y, IPF-Z)

• LACBED – Large Area Convergent Beam Electron Diffraction

• NBD – Nano Beam Diffraction

• PI – Principal Investigator

• SAED – Selected Area Electron Diffraction

• SE – Secondary Electron

• SEM – Scanning Electron Microscopy

• STEM – Scanning Transmission Electron Microscopy

• TEM – Transmission Electron Microscopy
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• TKD – Transmission Kikuchi Diffraction

• WDS – Wavelength-Dispersive X-ray Spectroscopy

8.2 Keyboard Shortcuts

8.3 Data Schema Overview

8.4 Licensing and Attribution
StraboMicro is released under theMIT License (MIT): Permission is hereby granted, free of charge,
to any person obtaining a copy of this software and associated documentation files (the ”Soft-
ware”), to deal in the Software without restriction, including without limitation the rights to use,
copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to per-
mit persons to whom the Software is furnished to do so, subject to the following conditions: The
above copyright notice and this permission notice shall be included in all copies or substantial por-
tions of the Software. THE SOFTWARE IS PROVIDED ”AS IS”, WITHOUTWARRANTYOFANYKIND,
EXPRESSOR IMPLIED, INCLUDINGBUTNOT LIMITEDTOTHEWARRANTIESOFMERCHANTABIL-
ITY, FITNESS FOR A PARTICULAR PURPOSE ANDNONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABIL-
ITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
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