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This document catalogs all improvements, new features, and enhancements in StraboMicro2 compared to the legacy JavaFX StraboMicro application.
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Major New Features

These features are entirely new to StraboMicro2 and did not exist in the legacy app.

1. Version History System

Full project versioning with snapshots and restore capability.

Snapshots: Every save creates a version snapshot
Named checkpoints: Create named versions that persist through auto-pruning
Diff preview: Visual comparison showing added/removed/modified entities
Restore: Restore any previous version with automatic backup of current state
Auto-pruning: Maintains max 200 versions, 30 days retention, minimum 10 kept
Storage stats: View version history storage usage

Access: File > View Version History...

2. Autosave System

Automatic saving prevents data loss.

5-minute timer: Saves automatically after 5 minutes of inactivity
Close protection: Auto-saves on app close if unsaved changes exist
Version integration: Creates version snapshot on each autosave

3. High-Resolution Overlay System (LOD)

Dynamic Level-of-Detail rendering ensures overlays are always sharp.

Dynamic resolution: Overlays render at appropriate resolution based on zoom level
Three LOD modes :

THUMBNAIL: < 10% screen coverage or zoomed out
DOWNSAMPLED: 10-40% coverage, moderate zoom
TILED: > 40% coverage or high zoom (full resolution)

Viewport culling: Only loads tiles for visible areas
Memory management: LRU eviction prevents memory overflow

Result: No more pixelated overlays when zoomed in!

4. Recent Projects Menu

Quick access to previously opened projects. Can now have multiple projects open at a time.

Quick switching: File > Recent Projects submenu
Last 10 projects: Shows most recently opened projects
Relative dates: Displays "Today", "Yesterday", "Nov 25", etc.
Current indicator: Checkmark next to currently open project
Auto-rebuild: Index rebuilds on app startup by scanning project folders
Unsaved changes: Prompts to save before switching

5. Recursive Spots

View spots from child micrographs on the parent view. Currently only traverses to first child, but grandchild and beyond may be possible with extra development work.

Transformed display: Child spots render with correct position, scale, and rotation
Full interactivity: Click to select, right-click for context menu
Toggle control: View > Show Recursive Spots

Use case: See all analytical spots from high-mag images while viewing the reference micrograph.

6. SVG Export with Vector Spots



Export micrographs as editable vector graphics.

Vector spots: All spots export as editable SVG paths
Editable labels: Text labels are editable in vector software
Raster base: Base image embedded as JPEG
Software compatible: Works with Adobe Illustrator, Inkscape, Affinity Designer

Access: Download dropdown > "Download as SVG (Vector)" Or: File > Export all Images > "SVG (Vector)"

7. Real-World Spot Measurements

Automatic calculation of physical dimensions.

Line spots: Shows total length (sum of all segments)
Polygon spots: Shows area (shoelace formula) and perimeter
Smart units: Auto-selects μm, mm, or cm based on magnitude
Calibration required: Only displays when micrograph has scale set
Precision: 3 decimal places
Measurements appear in "Spot Metadata" section of metadata bar.

8. Overlay Drill-Down Navigation

Click-to-navigate through overlay hierarchy. Feature requested by Julie.

Direct navigation: Click any overlay micrograph to jump to it
Back button: Navigate back through history
Unlimited depth: A → B → C → back to B → back to A
Visual feedback: Cursor changes to pointer on hover
Sidebar integration: Navigation stack clears when selecting from sidebar

9. Sentry Error Tracking

Automatic crash reporting for production builds.

Automatic reporting: Crashes sent to Sentry dashboard
Production only: Disabled in development mode
Privacy: User paths scrubbed before sending
Release tracking: Errors tagged with app version

10. Bulk Associated Files Import

Import multiple associated files at once.

Multi-select: Cmd/Ctrl+click for multiple files
Preview: Selected files shown as removable chips
Shared metadata: File type and notes applied to all
Progress tracking: Visual feedback during import

11. Clickable Associated Files

Quick access to associated files.

Click to open: File names open with user's system default app
Visual indicator: Small external link icon (↗)
Works everywhere: Both in edit dialog and accordion summary

12. Project Stats Footer

Running totals in the sidebar.

Always visible: Pinned to bottom of left sidebar
Live updates: Changes as content is added/removed
Content: "Total Samples: x • Total Micrographs: x"

13. File Association (.smz)

Double-click .smz files to open them.

macOS: Registered via Info.plist
Windows: Registered via NSIS installer
Single instance: Second instance passes file to first
Works when running: Opens file in already-running app

14. GitHub Actions CI/CD

Automated build and release pipeline.

Multi-platform: Builds for macOS (Intel + Apple Silicon) and Windows
Automated releases: Creates releases on git tag
Code signing: Configured for notarization (when certificates available)



15. Automatic Updates

Automatic updates based on GitHub uploads.

Instant Availability: Updates available automatically once built by GitHub
Instant Notification: Updates are checked for with every app launch and every 30 minutes while running
No Manual Install: Updates are downloaded in background and implemented next app launch

16. Point Count System

Systematic point counting for modal analysis and petrographic studies.

Grid generation: Customizable grid overlay with adjustable spacing
Keyboard navigation: Arrow keys to move between grid points
Quick mineral shortcuts: Configurable letter keys (A-Z) for rapid mineral assignment
Statistics panel: Live counts and percentages by mineral
Session management: Save and resume point count sessions
Export: Export results as CSV

Access: Tools > Point Count...

17. Grain Detection (OpenCV)

Automated grain boundary detection using classical computer vision.

Edge detection: Canny edge detection for boundary identification
Watershed segmentation: Marker-based watershed algorithm for grain separation
Preview mode: See detected grains before committing
Adjustable parameters: Sensitivity, minimum grain size, edge threshold
Batch creation: Creates polygon spots for all detected grains

Access: Tools > Grain Detection > OpenCV Detection...

18. FastSAM AI Grain Detection

AI-powered grain detection using the FastSAM (Fast Segment Anything Model) neural network.

GrainSight algorithm: Specialized contour extraction optimized for thin sections
Automatic model download: Downloads ONNX model from HuggingFace on first use
High accuracy: Better boundary detection than classical methods, especially for complex textures
Cross-platform: Works on macOS, Windows, and Linux
WASM inference: Runs entirely in-browser via WebAssembly for maximum compatibility

Access: Tools > Grain Detection > AI Detection (FastSAM)...

19. Quick Edit Mode

Keyboard-driven interface for rapidly reviewing and classifying spots after grain detection.

Keyboard navigation: Arrow keys to move between spots
Quick mineral assignment: Letter keys (A-Z) for instant classification (shared shortcuts with Point Count)
Visual states: Unreviewed (black outline), selected (red), classified (green)
Filled rendering: Spots display with standard fill, color, and opacity
Statistics panel: Track progress with reviewed/remaining counts
Auto-advance: Automatically moves to next spot after classification
Lasso selection: Batch classify similar grains with Shift+drag

Access: Edit > Quick Edit Spots... (Cmd+Shift+Q)

20. Batch Edit & Multi-Select

Select and edit multiple spots simultaneously.

Lasso selection: Shift+drag to select multiple spots
Cmd/Ctrl+Click: Add/remove spots from selection
Batch property editing: Change color, mineral, tags for all selected spots
Batch delete: Delete multiple spots at once
Visual feedback: Selected spots highlighted with distinct styling

Access: Use Shift+drag on canvas, or Cmd/Ctrl+click spots

21. Merge & Split Tools

Combine or divide polygon spots for grain boundary refinement.

Merge spots: Combine multiple adjacent polygons into one (M key)
Split spot : Draw a line to divide a polygon into two parts (/ key)
Undo support: Full undo/redo for merge and split operations
Provenance tracking: Merged/split spots track their origin

Access: Select spots, then use M to merge or / to split



22. Grain Size Analysis

Quantitative morphometric analysis of polygon spots with statistical visualization.

Per-grain metrics: Area, perimeter, equivalent diameter, aspect ratio, orientation, circularity
Population statistics: Mean, median, std dev, skewness, sorting coefficient
Rock type schemes: Wentworth (sedimentary), igneous, and metamorphic classification scales
Size histogram: Distribution chart with classification overlay
Rose diagram: Grain orientation distribution (0-180°)
Mineral grouping: Statistics broken down by classified mineral
Scope options: Analyze current micrograph or all micrographs
CSV export : Export all metrics for external analysis
PDF reports: Generate formatted reports with charts and statistics

Access: Tools > Grain Size Analysis... (Cmd+Shift+G)

23. Image Comparator

Full-screen multi-canvas view for comparing micrographs side-by-side.

Grid layout: View multiple micrographs in a grid arrangement
Independent pan/zoom: Each canvas has independent navigation
Sync option: Optionally synchronize pan/zoom across all canvases
Overlay support: Shows associated micrographs with outlines
Affine overlay support: Works with 3-point registered overlays
Theme-aware: Background adapts to light/dark theme

Access: Help > Image Comparator...

24. Affine Transform Placement (3-Point Registration)

Precise overlay alignment using three-point correspondence.

3-point registration: Click three points on parent, then three corresponding points on child
Affine transform: Supports translation, rotation, scale, and shear
Live preview: See the transformed overlay before applying
Persistent: Transform data saved with project and regenerated on import
Export support: Affine overlays included in composite images and PDFs

Access: New Micrograph wizard > "3-Point Registration" placement option

25. Splash Screen

Professional startup experience with branding.

App logo: Displays StraboMicro logo during startup
Version display : Shows current app version
Loading indicator: Visual feedback during initialization

26. Properties Panel Tabs

Organized metadata viewing with tabbed interface.

Micrograph/Spot tab: Shows details for selected micrograph or spot
Sketches tab: Sketch layer management (appears when micrograph selected)
Project tab: Quick access to project-level metadata
Tab persistence: Remembers last selected tab

27. Wizard Thumbnail Preview

Visual confirmation during micrograph import.

Thumbnail display : Shows preview of selected image in wizard header
Immediate feedback: Confirms correct image selection before proceeding

28. Ruler/Measurement Tool

On-canvas distance measurement.

Click and drag: Draw measurement line on canvas
Real-world units: Displays distance in µm, mm, or cm (when scale is set)
Crosshair cursor: Clear visual indication when tool is active
Non-persistent: Measurement clears after use (for quick checks)

Access: Drawing toolbar ruler icon, or Tools > Measure (M key)

29. Micrograph Opacity Slider

Fine-grained opacity control for overlay micrographs.

Slider control: Adjust opacity from 0-100%
Quick access: Popover appears from opacity button



Live preview: See changes in real-time
Per-micrograph: Each overlay can have different opacity

Access: Click opacity icon in micrograph context menu or properties panel

30. Linux Support

Full support for Linux distributions.

AppImage format: Single-file distribution for easy installation
Sandbox compatibility : Works with Electron sandbox restrictions
Tested distros: Ubuntu, Fedora, and derivatives

31. Sketch Overlay System

Complete freehand drawing and annotation system layered on top of micrographs.

Pen tool : Thin freehand strokes with configurable color and width (1-50px)
Marker tool : Semi-transparent highlighter strokes (3x width, 40% opacity)
Eraser tool: Click or drag-to-erase strokes and text items with visual hover feedback
Text tool: Place text annotations with configurable font size (8-72px)
Multi-layer system: Create unlimited sketch layers per micrograph with independent visibility
Layer management: Rename, reorder, show/hide, and delete layers via dedicated Sketches tab
Color picker: Full hex color picker for stroke and text color
Undo/redo: All sketch operations (stroke, text, layer changes) fully undoable
Export: Export micrograph with selected sketch layers as PNG or JPEG at 1x-4x resolution

Access: Drawing toolbar > Sketch Mode button, or press S. Export via File > Export Micrograph with Sketches...

Result: Annotate micrographs with freehand drawings without affecting the underlying image data!

32. XPL/PPL Synchronized Viewing

Toggle between cross-polarized (XPL) and plane-polarized (PPL) views of the same thin section with synchronized navigation.

Sibling pairing: Link complementary PPL and XPL micrographs (must share same aspect ratio)
One-click toggle: Instantly switch between PPL and XPL views
Synchronized pan/zoom: View position preserved when toggling between siblings
Shared spots: Annotations are shared between paired micrographs
Add sibling: Create a new paired image directly from an existing micrograph (inherits position/scale)
Link existing: Pair two existing micrographs with matching dimensions

Access: Press X to toggle, or click the swap icon in the viewer toolbar

Result: Seamlessly compare polarized light views without losing your place!

33. Mineral Color Tool

View spots colored by their mineral classification instead of individual spot colors.

Two view modes: Toggle between "View by Spot Color" and "View by Mineral Color" via View menu
Global colors: App-wide mineral-to-color mappings applied to all projects
Project overrides: Per-project color overrides that take precedence over global settings
Color configuration: Full color picker for each mineral with add/remove capability
Default palette: Built-in color defaults for common minerals
Case-insensitive: Mineral name matching works regardless of capitalization

Access: View > View Spots by Mineral Color. Configure via Spot > Configure Mineral Colors...

Result: Instantly visualize mineral distribution across your micrograph!

34. Quick Spot Presets

Reusable metadata templates for rapidly applying properties to spots.

Template system: Save spot color, label, opacity, and all geological feature data as a named preset
Key bindings: Bind presets to number keys 1-9 for instant application in Quick Edit mode
Two scopes: Global presets (app-wide) and project-specific presets
Drag-to-reorder: Rearrange presets via drag and drop
Preset summary: Each preset displays a summary of included data types
Duplicate & edit: Clone existing presets and modify for variations

Access: Spot > Quick Spot Presets... (Cmd+Shift+P)

Result: Apply complex geological classifications to spots with a single keypress!

35. Startup Messages

In-app announcements from the StraboSpot team.

Server-fetched: Messages loaded from StraboSpot backend on app launch
Markdown rendering: Rich text formatting with clickable links
Dismissible: "Don't show this again" checkbox to hide individual messages
External links: Links open in the user's default browser



36. Batch Import File Validation

Pre-validation of image files during import to catch problems before they cause errors.

Magic-byte detection: Reads first 8 bytes of each file to verify actual image format (PNG, JPEG, TIFF, BigTIFF, BMP)
Cloud storage detection: Identifies files that appear present but haven't been downloaded from cloud storage (Dropbox, iCloud, OneDrive)
Warning indicators: Invalid files show warning icons with descriptive messages
Graceful handling: Only valid files proceed to import; invalid files can be fixed and re-selected

Result: No more cryptic "unsupported image format" errors from cloud-synced files!

Significant Improvements

These features existed in the legacy app but have been substantially improved.

Image Handling

Feature Legacy App StraboMicro2

Maximum zoom
level 5x 20x

Overlay rendering Fixed resolution, pixelated at
zoom Dynamic LOD, sharp at any zoom

Tile caching None Disk-based cache with LRU eviction

Loading feedback None Progressive tile loading with visual
indicators

Image formats Limited Java ImageIO TIFF, JPEG, PNG, BMP via Sharp library

Large image support Memory issues Streaming with libvips, handles 100MB+ files

User Experience

Feature Legacy App StraboMicro2

Theme support Light only Dark/Light/System with smooth transitions

Panel layout Fixed sizes Resizable, collapsible with drag handles

Window state Not saved Position, size, maximized state persisted

Session state Lost on restart Full session persistence to file

Sidebar expansion Resets on restart Expansion state persists

Undo/Redo Limited Comprehensive with Cmd+Z / Cmd+Shift+Z

Toolbar position Fixed Dockable toolbars with 4-edge cycling (right/bottom/left/top),
persisted

View preferences Reset on restart All View menu toggles synced and persisted across sessions

Export Capabilities

Feature Legacy App StraboMicro2

PDF export Basic layout React-PDF with Table of Contents, internal links, all metadata
fields

Image export Low Resolution Only / Poorly
Annotated Composite with overlays + spots + labels, or SVG vector

Sketch export Not available Export with selectable sketch layers, PNG/JPEG, 1x-4x resolution



README in
archive None Auto-generated README.txt with project summary
Feature Legacy App StraboMicro2

Batch Operations

Feature Legacy App StraboMicro2

Batch associated files Not available Multi-select with shared metadata

Batch import
validation None Magic-byte pre-validation with cloud storage

detection

Data Organization

Feature Legacy App StraboMicro2

Reorder items Limited to Up/Down
Arrow

Drag & drop for datasets, samples,
micrographs

Keyboard reorder Not available Ctrl/Cmd + Up/Down arrows

Canvas & Drawing Tools

Feature Legacy App StraboMicro2

Spot labels Basic rendering Three label modes: Original name, Mineralogy abbreviation, or
None

Edit polygon geometry Limited Advanced midpoint handle mode, move entire feature

Drawing tool shortcuts Not available Keyboard shortcuts: P (point), L (line), G (polygon), M (measure)

Freehand annotation Not available Full sketch overlay system with pen, marker, eraser, and text tools

Metadata & Analysis

Feature Legacy App StraboMicro2

Grain size data Not visible in
panel Grain size metrics displayed in Properties Panel spot view

Point count data Not visible in
panel

Point count summaries displayed in Properties Panel spot
view

Instrument
requests Manual process Mailto link in metadata panel to request new instruments

Parity Features

These features exist in both apps with similar core functionality:

Project Management

New project creation with metadata
Save project / Save as
Open local .smz files
Open remote projects from server
Open shared projects via code
Upload project to server
Edit project metadata

Hierarchy



Dataset creation and management
Sample creation and management
Micrograph creation and management
Project → Dataset → Sample → Micrograph → Spot structure

Spots & Annotations

Point spot creation
Line spot creation
Polygon spot creation
78 geological data types
Spot color and label customization
Copy data from existing spots

Instrument Support

Optical Microscope
SEM (Secondary Electron, Backscattered Electron)
TEM
EBSD
Cathodoluminescence
Instrument database lookup

Scale & Orientation

Scale bar tracing
Micrograph orientation (trend/plunge)
Flip horizontal

Integration

StraboSpot field data linking
Sample import from StraboSpot
Mineral database (204KB SQLite)
Lithology database (20KB SQLite)

Micrograph Features

Opacity control for overlays
Visibility toggle for associated micrographs

Summary

StraboMicro2 represents a significant advancement over the legacy JavaFX application:

36+ entirely new features not present in the legacy app
30+ significant improvements to existing functionality
Modern tech stack enabling faster development and better UX
Complete spot generation workflow: Point Count → Grain Detection → Quick Edit → Grain Analysis
AI-powered analysis: FastSAM neural network for grain detection
Full annotation system: Sketch overlays with multi-layer drawing tools
Cross-platform with native-quality experience on macOS, Linux and Windows

The most impactful improvements for users are:

1. Version History - Never lose work again
2. High-Resolution Overlays - Sharp images at any zoom level
3. Sketch Overlays - Freehand drawing directly on micrographs
4. XPL/PPL Toggle - Seamless polarized light comparison
5. Recent Projects - Quick access to your work
6. Dark Theme - Reduced eye strain
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